1. tourboy's Avatar
    When I start my Rezound and go into Gauge Battery Widget, it shows Maps listed although I never started the app; battery usage indicates 20%. When I go into APP and looks at Running apps, Maps does not appear. However in Gauge Battery Widget, I can click on Maps and Force Stop it, but this seems to be temporary as at some later point without turning off the phone, the app will again appear under the Top Battery Consumers list within Gauge Batery Widget.
    09-07-2012 06:41 AM
  2. acejavelin's Avatar
    When I start my Rezound and go into Gauge Battery Widget, it shows Maps listed although I never started the app; battery usage indicates 20%. When I go into APP and looks at Running apps, Maps does not appear. However in Gauge Battery Widget, I can click on Maps and Force Stop it, but this seems to be temporary as at some later point without turning off the phone, the app will again appear under the Top Battery Consumers list within Gauge Batery Widget.
    Try clearing the data from Maps, and making sure Latitude is off...

    Also try uninstalling updates (yeah, I know...) and see if it continues then install the current version, it's actually pretty good.

    There might be another app that is touching Maps too... I remember some other people had this issue a while back but I don't remember the resolution but in the back of mind I am thinking Factory Reset.
    09-07-2012 07:04 AM
  3. MrSmith317's Avatar
    I think just "google location services" shows up as Maps in some power monitors. Maybe disable that option in settings -> location services and see if your Maps problem goes away.
    09-07-2012 07:28 AM
  4. tourboy's Avatar
    Already checked Location and it is disabled.

    I think just "google location services" shows up as Maps in some power monitors. Maybe disable that option in settings -> location services and see if your Maps problem goes away.
    09-07-2012 11:22 AM
  5. tourboy's Avatar
    Did a Force Stop on it a bit ago, picked up the phone a few minutes ago and noticed the Forced Stop button is active yet again.
    09-07-2012 12:49 PM
  6. daniel-k's Avatar
    I am also noticing that my battery life has diminished since the last Maps update. The difference isn't horrible, but it is definitely noticeable. Something has changed.

    I too tried the force stop on Google Location Services, but it just comes back. Not sure I really understand what the various location services do and whether or not I want them. I have noticed that something called "TrafficAppWidgetUpdateService" is always running. I don't care that much about traffic, but can't see how to get rid of it.

    I'm willing to try a factory re-set, but may as well wait until the system up-date that we are supposedly going to get this month.
    09-08-2012 01:46 PM
  7. daniel-k's Avatar
    Replying to my own post -- Here is a screen shot showing my battery usage after less than four hours since a full charge. This shows that "Maps" is the biggest user.

    Note that I did not use the phone at all during this time period. No calls - no nothing. The screen was off until I checked and made the screen shot. I've never had this happen until the last Maps update. I've tried force stopping as suggested above and I've fiddled with Latitude, but nothing seems to help. I've noticed that there have been other posts about similar problems with the Rezound and with other Android phones and there have been several different suggested fixes, but not seem to work. This is a stock unrooted Rezound and I have made no changes since ICS and I haven't installed any new apps since then.Why does Google Maps keep running in background?-2012-09-09-18.32.50.jpg

    WAZZUP??
    09-09-2012 10:35 PM
  8. Ankit Senjaliya's Avatar
    ya its damn even i am tired to killing maps which isalways running in background ..damn truely hate it
    11-19-2012 05:50 AM
  9. mike7728's Avatar
    have u tried disabling it?it'll pop back up if u switch batteries, so make sure u disable whenever u battery pull

    Sent from my ADR6425LVW using Xparent Red Tapatalk 2
    11-19-2012 10:57 PM
  10. Chandan Kumar4's Avatar
    simply uninstall the lastest update and keep the factory version........... thats all i did
    07-09-2013 03:34 AM
LINK TO POST COPIED TO CLIPBOARD