1. Mikey D_PhD's Avatar
    Good afternoon. After the update, I get a notification when turning on GPS. Is there a way to disable this notification? Thanks for any input. Stock phone, no root, MR2 update OTA.
    07-09-2011 11:40 AM
  2. yodatom10's Avatar
    Good afternoon. After the update, I get a notification when turning on GPS. Is there a way to disable this notification? Thanks for any input. Stock phone, no root, MR2 update OTA.
    The gps icon has always been there only way to get rid of it is by rooting.
    Edit :if you mean the Verizon warning when u reboot the phone there should be option to never show again.
    07-09-2011 02:15 PM
  3. bcoley's Avatar
    The notification the OP refers to occurs when the user selects the GPS widget, and is a caution about the location information that can accessed from the phone by third party apps etc because the user has activated Standalone GPS Services. I cannot find a way to turn off that notification. Would love to hear from someone who has.
    07-09-2011 02:42 PM
  4. Mikey D_PhD's Avatar
    I've rebooted and I don't see the option to turn off the location services warning for the gps when I turn it on. I have the toggle on my home screen, but I've also tried turning on from the location menu in settings and there is no option to disable the warning. I remember that I clicked ok on that warning one time before the update and it never showed up again. Just trying not to have to click extra times. Thanks.
    07-09-2011 02:43 PM
  5. Mikey D_PhD's Avatar
    Bump. Anyone have any suggestions?
    07-10-2011 10:10 PM
  6. yodatom10's Avatar
    Bump. Anyone have any suggestions?
    Ok from my understanding what your issue is when you go to turn on any apps that use gps you are greeted with a big box warning u about location services. And u have to click ok to use the app. If that's the case I know when i first booted up after applying the update there were to options ok and don't warn again. I click don't warn again and have not seen the warning since. I believe the only way to get that option to show back up is by doing a factory reset and clicking don't warn again on your first boot
    07-10-2011 10:53 PM
  7. Mikey D_PhD's Avatar
    Thanks everyone. I think I'll just deal with a couple of extra clicks for the time being. Since I'm not rooted I don't want to do a factory reset.
    07-12-2011 09:48 AM
  8. Green_Laser's Avatar
    I'm in same boat. can't get rid of notification.
    07-12-2011 12:28 PM
  9. adampetrasek's Avatar
    Same boat also. Never had this before. And it's super frustrating. Since I use tasker to manage my gps l don't want confirm every time gps is turned on! Please help
    07-12-2011 12:50 PM
  10. Jrocker23's Avatar
    Same boat also. Never had this before. And it's super frustrating. Since I use tasker to manage my gps l don't want confirm every time gps is turned on! Please help
    Just uncheck the gps option, then go back to home screen and repeat but this time check the options back out to option screen and restart phone. You should get the warning again
    07-12-2011 03:06 PM
  11. Mikey D_PhD's Avatar
    Alright. I figured out a way to do this. Turn the gps on and turn off the phone, not reboot. Give it time to power all the way down and power up. At this point there should be a dialog box come up with the option to 'never warn'. That did it for me.
    07-12-2011 03:26 PM
  12. adampetrasek's Avatar
    Alright. I figured out a way to do this. Turn the gps on and turn off the phone, not reboot. Give it time to power all the way down and power up. At this point there should be a dialog box come up with the option to 'never warn'. That did it for me.
    I did this, and got the 'Never Warn' option. and clicked it. But that did not stop the warning from coming up. Tasker turned my GPS off and back on and it popped up again with the ok or cancel option. And it also comes up if i manually turn it off and back on.
    07-12-2011 04:10 PM
  13. KJ78's Avatar
    I did this, and got the 'Never Warn' option. and clicked it. But that did not stop the warning from coming up. Tasker turned my GPS off and back on and it popped up again with the ok or cancel option. And it also comes up if i manually turn it off and back on.
    Same here. I click never warn but I still get warnings. How annoying.
    07-12-2011 09:36 PM
  14. CPB's Avatar
    Alright. I figured out a way to do this. Turn the gps on and turn off the phone, not reboot. Give it time to power all the way down and power up. At this point there should be a dialog box come up with the option to 'never warn'. That did it for me.
    Ditto. The "Never Warn" dialogue came up, and I selected the "Never Warn" option but I guess it is ignored. I still get the warning manually turning on the standalone GPS services. What on earth!
    07-12-2011 09:42 PM
  15. yodatom10's Avatar
    Ditto. The "Never Warn" dialogue came up, and I selected the "Never Warn" option but I guess it is ignored. I still get the warning manually turning on the standalone GPS services. What on earth!
    I don't have that issue. Did u click never warn the first time u booted up. Or after the first boot
    07-12-2011 10:03 PM
  16. CPB's Avatar
    Before the update I told it to never warn... it worked fine. After the update the phone rebooted but no new "never warn" screen came up, however the GPS warning started popping up each time. I just now followed Mikey D's instructions and shut off/on the phone, "never warn" screen came up again, but it ignored my preference. I think this is what most people are experiencing.
    07-12-2011 10:06 PM
  17. yodatom10's Avatar
    Before the update I told it to never warn... it worked fine. After the update the phone rebooted but no new "never warn" screen came up, however the GPS warning started popping up each time. I just now followed Mikey D's instructions and shut off/on the phone, "never warn" screen came up again, but it ignored my preference. I think this is what most people are experiencing.
    I just tried replacafing whats happing to u and I could not do it. I did my update by flashing the ruu and not the ota. Maybe that plays a role
    07-12-2011 10:13 PM
  18. CPB's Avatar
    Could be, i flashed with OTA. I just completely turned off the phone and turned it back on.. "never warn" message popped up again to my surprise, made sure to carefully select "never warn" and tried manually disabling and re-enabling the GPS... the warning still came up lol this is a bit ridiculous....haha
    07-12-2011 10:17 PM
  19. yodatom10's Avatar
    Could be, i flashed with OTA. I just completely turned off the phone and turned it back on.. "never warn" message popped up again to my surprise, made sure to carefully select "never warn" and tried manually disabling and re-enabling the GPS... the warning still came up lol this is a bit ridiculous....haha
    I'm glad I did the ruu because that would drive me crazy.
    07-12-2011 10:27 PM
  20. adampetrasek's Avatar
    I'm glad I did the ruu because that would drive me crazy.
    Yeah. it's pretty ridiculous. and even more ridiculous that i'd have to wipe my phone by installing a ruu to fix this bull$hit!
    07-13-2011 01:45 PM
  21. CPB's Avatar
    Just an update.. I factory reset my phone (due to the fact I could never connect to "My Verizon" account) and while the reset fixed the connectivity to My Verizon, the GPS warning is still there
    07-15-2011 10:06 PM
  22. bogeyx5's Avatar
    From what I understand, you get this message after you turn on your phone and start trying to activate location services:

    One or more of the Location settings is enabled on your device. Consequently, you are enabling access to location information which could pose certain risks to users of this device. Verizon Wireless encourages you to check your wireless device periodically and only use software, widgets, peripheral components and services from reliable sources. Verizon Wireless makes no representation of accuracy, completeness or timeliness of any location data, product or service.
    OK or Never Warn.

    Here are messages EVERY TIME you activate each of the following three location service:

    VZW Location Services
    By selecting VZW Location Services, you are enabling Verizon Wireless and third party authenticated and validated location services to access certain location information available through this device and/or the network.
    OK or Cancel

    Standalone GPS Services
    By selecting Standalone GPS Services, you are enabling access to al location information by any third party through the web, software, or any peripheral components you install, download, add or attach to the device, or by any other means. Enabling this functionality could pose certain risks to users of this device.
    OK or Cancel

    Google Location Services
    Allow Googles Location service to collect anonymous location data. Collection will occur even when no applications are running.
    Agree or Disagree


    Looks like you can have the first message to never warn you again but you will continue to get all the other messages each time you turn them on (you don't get a message when it is turned off). Hope someone can find a way to disable all warnings without rooting.
    07-15-2011 11:20 PM
  23. danstheman's Avatar
    Ok from my understanding what your issue is when you go to turn on any apps that use gps you are greeted with a big box warning u about location services. And u have to click ok to use the app. If that's the case I know when i first booted up after applying the update there were to options ok and don't warn again. I click don't warn again and have not seen the warning since. I believe the only way to get that option to show back up is by doing a factory reset and clicking don't warn again on your first boot
    No- that may happen also, but here is the issue the OP is describing: Every time you turn on GPS, either from the notification bar, or apparently from a widget, a big dialog box pops up saying "By selecting "Standalone GPS services" you are allowing access to all location information by any third party..." etc. You have to click either 'Agree' or 'Cancel'.

    This happens every single time you turn on GPS. Rebooting does not help, and I have not found any other way to stop it. This is only an issue since the Jellybean update. I have a Verizon S3, not sure if it affects other carriers also.
    01-20-2013 08:25 AM
  24. danstheman's Avatar
    Alright. I figured out a way to do this. Turn the gps on and turn off the phone, not reboot. Give it time to power all the way down and power up. At this point there should be a dialog box come up with the option to 'never warn'. That did it for me.
    Didn't work for me. I followed your instructions, turned on GPS then turned the phone off, waited a few minutes, then back on. Dialog box is still there.
    01-20-2013 08:47 AM
LINK TO POST COPIED TO CLIPBOARD