1. JCisMe's Avatar
    Stock, unrooted TB, with all of the OTA updates applied.

    I have a linksys wireless G router at home that I connect my phone to with wifi. The problem is that the wifi connection will just stop working. The wifi indicator in the notification bar looks like it is connected, but I get no data. I can't send or receive emails. When I open up the browser on the phone I get an error stating that there is no connection.

    I have a very hard time believing that this is due to my router setup. I have a Windows laptop that is connected wirelessly to the same router 100% of the time and that never has any connection problems. So the router is perfectly capable of maintaining a long running connection, but the TB is not.

    I have tried wifi-fixer, and it is only OK. It will reconnect every so often but it messes things up when I'm actively doing something when the timer triggers.

    I've been having this problem ever since I got the TB in March. I've been hoping that the OTA updates would fix this but so far they haven't. The only saving grace is that I'm in a 4G area and have unlimited data so I have all but abandoned wifi completely.

    I would love to find out if my phone does this on all networks or if it only happens at home. But I unfortunately do not have access to wifi at work, so don't have any other networks where I spend an extended period of time.

    Has anybody else experienced this? Is there something that I can do to fix this? Do I have a dud phone? Should I get a replacement from VZW?
    08-30-2011 11:35 AM
  2. recDNA's Avatar
    Visit a mcdonalds andbtry their wifi.
    08-30-2011 03:03 PM
  3. anon(394005)'s Avatar
    You can try changing your wireless router to G only instead of "mixed", unless you have older devices that require B. Some devices and some routers just don't play nice together when the router is in mixed mode.
    08-30-2011 03:18 PM
  4. Eric The Duke's Avatar
    Stock, unrooted TB, with all of the OTA updates applied.

    I have a linksys wireless G router at home that I connect my phone to with wifi. The problem is that the wifi connection will just stop working. The wifi indicator in the notification bar looks like it is connected, but I get no data. I can't send or receive emails. When I open up the browser on the phone I get an error stating that there is no connection.

    I have a very hard time believing that this is due to my router setup. I have a Windows laptop that is connected wirelessly to the same router 100% of the time and that never has any connection problems. So the router is perfectly capable of maintaining a long running connection, but the TB is not.

    I have tried wifi-fixer, and it is only OK. It will reconnect every so often but it messes things up when I'm actively doing something when the timer triggers.

    I've been having this problem ever since I got the TB in March. I've been hoping that the OTA updates would fix this but so far they haven't. The only saving grace is that I'm in a 4G area and have unlimited data so I have all but abandoned wifi completely.

    I would love to find out if my phone does this on all networks or if it only happens at home. But I unfortunately do not have access to wifi at work, so don't have any other networks where I spend an extended period of time.

    Has anybody else experienced this? Is there something that I can do to fix this? Do I have a dud phone? Should I get a replacement from VZW?
    I had a similar problem with the TB and my home wifi network. My connection was always shakey. The SSID of my network was hidden. I set my router to broadcast my SSID and my wifi connection has been flawless ever since. I'd really like to keep my SSID hidden, but it's not that big a deal as I have other security on my network. I will try hidding my SSID again when the gingerbread update comes out.
    08-30-2011 10:54 PM
  5. VegasAlien's Avatar
    I had the same trouble with the Linksys SSID broadcast and fixed it by broadcasting my id. Have another issue with WIFI. When my WiFi radio is on I do not get 4G. Turn off the Wifi and the 4G comes back. Worked with Cisco yesterday and tried different channels with no effect. Verizon says 4G is at 700 MHz and my router is 2.4GHz so there should be no interfrence.
    08-31-2011 12:35 PM
  6. dhendriksen's Avatar
    I have this problem, only at home. At work I'm on wifi all day without incident. My wifi at home also works flawlessly with literally dozens of devices.

    I have the WRVS4400N, which is commercial grade gear. I will check my SSID settings and see if it improves.
    08-31-2011 12:45 PM
  7. anon(394005)'s Avatar
    I too have the SSID broadcast turned off (Linksys router). That's not necessarily the problem. As I previously mentioned, try getting off "mixed" mode first. It worked for me.
    08-31-2011 12:58 PM
  8. Eric The Duke's Avatar
    I too have the SSID broadcast turned off (Linksys router). That's not necessarily the problem. As I previously mentioned, try getting off "mixed" mode first. It worked for me.
    My network is set to G only and when I hide my SSID, I get connection problems. THe only solution I've got to work is broadcasting my SSID. I hope when gingerbread comes out I will be able to hide my SSID again.
    08-31-2011 10:24 PM
  9. Eric The Duke's Avatar
    I had the same trouble with the Linksys SSID broadcast and fixed it by broadcasting my id. Have another issue with WIFI. When my WiFi radio is on I do not get 4G. Turn off the Wifi and the 4G comes back. Worked with Cisco yesterday and tried different channels with no effect. Verizon says 4G is at 700 MHz and my router is 2.4GHz so there should be no interfrence.
    That's how it's supposed to happen. When you establish a wi-fi connection, the cellular data connection is killed. It saves some juice on your battery.
    08-31-2011 10:32 PM
  10. Eric The Duke's Avatar
    So far on gingerbread, I have been able to hide my SSID and I haven't had any problems.
    10-01-2011 10:22 AM
  11. FrankXS's Avatar
    When my WiFi radio is on I do not get 4G. Turn off the Wifi and the 4G comes back. Worked with Cisco yesterday and tried different channels with no effect. Verizon says 4G is at 700 MHz and my router is 2.4GHz so there should be no interfrence.
    This behavior is by design. You cannot use two data networks simultaneously. You have to choose either Wifi or Cell Data.

    -Frank
    10-01-2011 10:34 AM
LINK TO POST COPIED TO CLIPBOARD