1. boyer61's Avatar
    I know facebook is doing this, But it adds a + to the beginning of the number, thus not allowing me to send a text message. How can i fix this?
    09-08-2011 10:44 PM
  2. dragonsamus's Avatar
    Can't you just edit the phone number?
    09-08-2011 11:49 PM
  3. boyer61's Avatar
    no I've tried everything they have their # on facebook so I can't change it
    09-09-2011 08:59 AM
  4. FrankXS's Avatar
    I don't know if this would work, but have you tried turning off (or adjusting, I guess) assisted dialing?

    -Frank
    09-09-2011 09:52 AM
  5. boyer61's Avatar
    where could I find those options?
    09-09-2011 11:48 AM
  6. FrankXS's Avatar
    where could I find those options?
    Menu | Settings | Call | Assisted Dialing.

    -Frank
    09-09-2011 12:19 PM
  7. dragonsamus's Avatar
    It looks like the only way to remove the +1 is to add the contact in yourself.
    09-09-2011 12:25 PM
  8. Profireman25's Avatar
    It looks like the only way to remove the +1 is to add the contact in yourself.
    My dad is having the same problem. Facebook adds the 1 for you, I have an htc inspire (AT&T) and i do not have this problem. I have already tried everything suggested here and thought I would see if anyone else was having this problem. Nothing I have tried has fixed this issue, anyone else have any ideas?
    09-09-2011 08:04 PM
  9. boyer61's Avatar
    I tried disabling assisted dialing and it didnt work. I tried to add the number myself, but it will default to the one on facebook.
    09-09-2011 10:32 PM
  10. jrmarinojr's Avatar
    There is no fix. Do do not sync your contacts with Facebook.
    09-09-2011 10:33 PM
  11. mikestorm's Avatar
    I have a similar issue. I can't voice dial places of businesses (e.g "Call Pep Boys Auto" ) because of the plus prefix. Assisted dialing isn't the issue. Drives me crazy.
    09-10-2011 08:19 PM
  12. boyer61's Avatar
    There has got to be a fix. it has to do with the country code...
    09-11-2011 08:22 PM
  13. boyer61's Avatar
    I've finally found the fix!
    I sync all my contacts from Facebook, on the contact that has the +1 you need to create a new contact, with the name and # you want. It should link them together. Once linked, open the contact and long press 'call mobile'. You will now see an option to edit the #. Delete the +1 and save it!!

    Finally! I was tired of getting error messages every rime I would text someone with a +1 in front of their #.

    Sent from my Thunderbolt.
    09-14-2011 06:53 AM
  14. soboness5's Avatar
    I've finally found the fix!
    I sync all my contacts from Facebook, on the contact that has the +1 you need to create a new contact, with the name and # you want. It should link them together. Once linked, open the contact and long press 'call mobile'. You will now see an option to edit the #. Delete the +1 and save it!!

    Finally! I was tired of getting error messages every rime I would text someone with a +1 in front of their #.

    Sent from my Thunderbolt.
    This would take forevvvvverrrrrrrrrrrrrrrrr. Can't Facebook fix whatever they changed on their end so the numbers are dial-able?
    09-14-2011 01:23 PM
  15. boyer61's Avatar
    I kn ow it would take forever, but it works lol
    09-14-2011 05:08 PM
  16. Jude526's Avatar
    Do you have a global device? My BB was global and all my numbers had the +1
    09-21-2011 01:47 AM
  17. boyer61's Avatar
    Every android phone i had always had the +1 on it.
    09-21-2011 09:47 AM
  18. soboness5's Avatar
    Every android phone i had always had the +1 on it.
    But for some reason when trying to dial numbers like this, verizon plays a message that says the number you have dialed isn't valid...so apparently it doesn't like the country code.
    09-21-2011 11:55 AM
  19. Mortiel's Avatar
    This has been a known issue with Facebook specifically for over a year now. Not all Android contacts have +1 unless you have assisted dialing to prefix all numbers.

    It actually has to do with location setting on your Facebook profile. When I moved from Ireland to the US and changed my location to USA, all my friends with US phone numbers went from +1 to just 1. However, some people that have created legitimate USA-located Facebook pages still for some reason think they are from outside the US, which creates the error. The contact is then synced to your phone, and non-Global phones cannot call internationally-prefixed numbers. Furthermore, since Android recognizes Facebook contacts as "live" contacts, their information cannot be permanently edited.

    I have seen many cases where Facebook for HTC Sense will display the contacts correctly, where the Facebook for Android app will not.
    FrankXS likes this.
    09-21-2011 01:33 PM
  20. Jude526's Avatar
    I don't have my number on facebook. I don't recommend people doing that. Too many weird people out there
    09-21-2011 02:12 PM
  21. natehoy's Avatar
    @Jude: I'd "like" your post, but I prefer Google+, so I'll just say "+1".

    I use both Google+ and Facebook, but neither of them have my phone number, address, or real email address.
    09-21-2011 03:15 PM
  22. FrankXS's Avatar
    I don't have my number on facebook. I don't recommend people doing that. Too many weird people out there
    No kidding. And most of 'em are right here!

    -Frank
    11-03-2011 09:53 AM
LINK TO POST COPIED TO CLIPBOARD