Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Page 2 of 2 FirstFirst 12
Results 26 to 46 of 46
Like Tree2Likes
  1. #26  
    Bordonin's Avatar

    Posts
    1 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Re: how to delete email history from autofill

    Problem solved! Thanks Madsaints!
  2. #27  
    Mike7515's Avatar

    Posts
    1 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Re: how to delete email history from autofill

    Old thread, but still having the issue. I've already done the "force stop/clear contacts storage" thing, which deleted every contact on my phone. Also did the same thing with the gmail app (force stop/clear data/cache). I also went into gmail on my computer and cleared out everything I didn't want on "other contacts". I've also tried all the things suggested in this thread. Basically, I think I've tried every fix I've read about online, and I still have old/bad autofill addresses coming up in gmail.

    If it matters, I'm using a 2nd gen Moto X with android 5.0 running. I think this is a gmail app issue, and not a phone/android issue, but I can't figure out how to get rid of these annoying autofill addresses!!!

    Oh, and BTW, the funny part is that none of these autofill addresses show up on gmail if I'm using my computer. Only on my phone.
  3. #28  
    justcoolin1's Avatar

    Posts
    1 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Re: how to delete email history from autofill

    Go to contacts
    hit settings
    hit contacts
    hit contacts to display
    hit device
    and that it your done
  4. #29  
    Bondman2's Avatar

    Posts
    1 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Re: how to delete email history from autofill

    I have just discovered how to remove the unwanted email addresses in the Samsung Galaxy S3. What you need to do is go into contacts and go to under that heading you will find unassigned contacts . Tap on this and it will list all email addresses that are not in your phone contacts tap on each one and an option to delete will come repeat with the rest of them . when you go to message contacts they will be gone.
  5. #30  
    PJ Peejuk's Avatar

    Posts
    1 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Re: how to delete email history from autofill

    I can't speak for any other phone but I found on the Galaxy S4 Mini that if I clicked in the box for email addresses, then a number of addresses appears in the type box below. Hold your finger on the incorrect one for several seconds and it asks if you want to forget it from the list of added words. Just confirm and it's gone

    Incidentally I came at this problem because the email address contained an account I didn't want coming up on my phone. In fact, I don't want any email connected with the phone. I found I couldn't log out of it but had to lose the email address completely from the phone. I did this by dragging down from the top, going into settings and accounts. One on-line YouTube instruction I saw said to delete the account from there but it wasn't an option for me. I had to go into Samsung account and remove the association from there.
  6. #31  
    JimH44's Avatar

    Posts
    1 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Re: how to delete email history from autofill

    Very helpful answer. I searched for the offending address in google Contacts, found it and deleted it. Thanks
  7. #32  
    Dyke67ny's Avatar

    Posts
    12 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Re: how to delete email history from autofill

    I've tried this a half dozen times on the Samsung G3 but still, the garbage email addresses remain. Funny thing is I never wrote to some of these that pop up in the email autofill...
  8. #33  
    Dyke67ny's Avatar

    Posts
    12 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Re: how to delete email history from autofill

    I've tried what you mentioned but no luck as I can't seem to find the "Unassigned contacts." I too have the S3.
  9. #34  
    Dyke67ny's Avatar

    Posts
    12 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Re: how to delete email history from autofill

    I've tried this on my Samsung Galaxy S3 exactly as you said, but it will not clear the autofill email addresses.

    I'm using the email app that comes on the phone where you can add multiple email accounts. Have checked the accounts on the computer for these "rogue" email addresses & they are not there...
  10. #35  
    UNSCSpartan117's Avatar

    Posts
    1 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Re: how to delete email history from autofill

    Clearing Data from the Contacts in Application Manager DOES delete your contacts...... thanks for the troll move? Good thing for cloud backup.
  11. #36  
    primecut's Avatar

    Posts
    1 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Re: how to delete email history from autofill

    Excellent solution, nearly gave up searching for ways to do get rid of unwanted email addresses from drop down menu on sign-in, then I found your perfect solution thanks very much.
  12. #37  
    Cdot1983's Avatar

    Posts
    1 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Re: how to delete email history from autofill

    None of these solutions work for the S6. Support wants me to do a factory reset. Nay nay
  13. #38  
    tatowles's Avatar

    Posts
    2 Posts
    Global Posts
    10 Global Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Re: how to delete email history from autofill

    Not a winner. Did not work.
  14. #39  
    Chris Huergo's Avatar

    Posts
    1 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Re: how to delete email history from autofill

    I'm not sure if it's been mentioned, I'm not patient enough to read through everything. Have you tried to tap-hold the offending address until an option pops up to delete it?
  15. #40  
    Syed Abdussamad's Avatar

    Posts
    1 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Red face Re: how to delete email history from autofill

    go to "Mail " by tapping the Mail icon ,take care not to select Gmail
    select the "email account" 'from which you want to delete search history '
    on the top right Select for "option" generally by tapping on 3 vertical dots
    go to "settings"
    then to "General Settings"
    at the bottom, you will find "Clear Search history "

    that's it
  16. #41  
    Anna Banana1106's Avatar

    Posts
    1 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Re: how to delete email history from autofill

    I FIGURED IT OUT! !!! Yup, I sent an email to my old employer from my new employer by accident. ..I was going to find a way to figure it out!! 😅😅😅

    I can't post a screen shot but basically do this:

    The step is called "removing learned words"

    Start typing the email address you want to see removed from your autofill. After you type it, before pressing anything else, click the > which is above your keyboard (the predictive text area). A bunch of related words and the email address you just typed will be displayed. Click on the one you want removed. A message will pop up asking if you want to remove this "word" from your learned words.

    Cheers everyone! !
  17. #42  
    BFE4's Avatar

    Posts
    1 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Re: how to delete email history from autofill

    I have the S7 and always had an issue with the Samsung stock keyboard suggesting email addresses when txting. The initial set up of the phone sync'd contacts from my old phone and from email accounts of mine. Many of these were not contacts I added to my email accounts but I had just replied to them and they got saved as other contacts. I have finally cleared the issue and figured I should share the information.
    Here is what I did.
    1. go into the email accounts you have sync'd... apps>settings>accounts. Turn off Sync Contacts for all of the accounts that you do not want to not sync contacts for.
    2. go to "phone" on your screen and click on the contacts tab. go to more>settings> turn off "contacts with numbers" (this allows you to search and find all the contacts your phone has stored. With this on you will only see your contacts that have phone numbers associated)
    3. Get into your contacts on your phone. In the search bar type the address you do not want to see, or you can do what I did (I typed in .com so it brought up the email addresses, for me this was 600 contacts)
    4. Press and hold one of the contacts until the check box appears. At the top use the select all check box. Scroll through and unselect the addresses you want to keep. Once you have sorted through those press delete. Congrats you got rid of part of the problem.. there is more to do yet.
    5. go to apps>settings>language and input>samsung keyboard> scroll to the bottom select "reset settings"> select "clear personalized data" or if you want to be sure the issue clears you can also select "reset keyboard settings" (if you do this you will have to reset up your settings/preferences)

    **NOTE** If you want to get down to the actual source of the problem you will need to login to a computer and access your email accounts individually. Many of the email sites have a secondary contact list that they keep for the emails you simply reply to. You will need to clear those out if you want to avoid this in the future. Otherwise I suggest leaving "sync contacts" turned off.
  18. #43  
    jacielynnATS's Avatar

    Posts
    1 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Re: how to delete email history from autofill

    Quote Originally Posted by xrb100 View Post
    I'm a Note2 user and am having the same problem as others on this thread. I've tried all the suggestions shown here (even though I'm using a Note 2) to no avail. I'm not even using GMail or Yahoo. I have one email account tied to a GoDaddy account. The GoDaddy account is set not to save contacts! I've deleted the account on the phone twice and set it up again... every address from every sender still populats the autofill. As massive as the Android user community is, I can't believe this is such a problem for so many users. Truly pitiful. Anyone out there with a Note2 have any ideas to fix this?
    The worst is I am a tech support agent and I couldn't figure this out I ended up transferring to manufacture
  19. #44  
    Ike94598's Avatar

    Posts
    1 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Thumbs up Re: how to delete email history from autofill

    Problem is not Samsung or at least in my case. I am a Samsung Galaxy S6 user and was tired of emails or names poping up while typing.

    Some of them were addresses that I didn't even know... like random craigslist ad email addresses that I have responded to 6 months ago let's say...

    Here is the solution...

    Go to your google account
    Click contacts
    Under contacts find Other Contacts
    Delete them all!
    Restart your phone

    Problem solved. (at least mine)

    I had almost 1000 contacts like this that I have no idea how they got into my contacts.
  20. #45  
    aannesmith's Avatar

    Posts
    1 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Re: how to delete email history from autofill

    This works! Thank you. Now I can go on with the rest of my life.
  21. #46  
    androidfrustrated's Avatar

    Posts
    1 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Re: how to delete email history from autofill

    Well, none of the above solutions worked for me. I've got another promising one to try though.

    For what its worth and in case it helps anybody else, this is on a Galaxy S5. In my case, it's an AT&T version, and I suspect that might have something to do with the problem. I just switched from a regional CDMA carrier, with the "same" phone, to a GSM carrier using an unlocked AT&T version of the phone, and it is far inferior. AT&T has all sorts of superfluous, background software that the CDMA phone didn't, and the CDMA phone didn't have this problem. In both cases, I've been using the built in Samsung email app, with multiple accounts. (Otherwise, same problem as others: random email address suggestions when I start typing an email, many for people or businesses I've never even emailed.)

    Here's what I found:

    I don't think the problem actually resides in Gmail, the phone's contacts, or any sort of keyboard auto-learn function, as all of the above solutions suggest. Great if those worked for you, but they didn't for me. What I just found is that there actually seems to be a hidden app intended solely for this nefarious purpose!

    Go to: Apps / Settings / Application Manager. At this point, click the three dot menu expander. Select "show system apps." Scroll down until you find an app called "Favorite Contacts." Click "Disable."

    This "appears" to have worked for me. I can't promise because, on the way to figuring it out, I accidentally cleared my email accounts, and had to reload them. (In the app manager for the email app, I went to "storage" and hit "clear data," after "clear cache" wasn't successful at deleting the email addresses.) This might be something you want to do anyway however, because otherwise I don't know that simply disabling the favorite contacts app will remove anything.

    Hope this helps.
Page 2 of 2 FirstFirst 12

Posting Permissions