Results 1 to 4 of 4
  1. Thread Author  Thread Author    #1  
    zog1977's Avatar

    Posts
    544 Posts
    Global Posts
    614 Global Posts

    Default charging problem

    my tb wont charge past 85 percent

    i bought a new battery

    factory reset the phone

    tried multiple chargers




    what could be the problem??
  2. #2  

    Default Re: charging problem

    Did the multiple chargers also include using different cables? If you've tried different cables as well, I think you've tried just about everything. Might be time to call Verizon. There are a few other threads about the same issue, do a search and see what else was suggested. Maybe cleaning the battery contacts.
  3. #3  

    Default Re: charging problem

    I too have the same problem.. I've tried various chargers, extended batter, standard battery, car charger.
    hell I've had the thing on the charger for an entire weekend and only had the batter charge to maybe
    half if I was lucky..

    I'm wondering if it's the TB itself, possibly having issues from when the silly thing falls off it's
    kickstand while charging, maybe that did something to the terminals, or perhaps not sure
    if there is some sort of charging circuit that may be in the TB, that is gone bad.

    I'm purchasing an external charger to see if that has anything help in charging the batter.
    The other thing I have yet to do, is put my batter in my Ms TB and see how it charges.

    Very odd indeed.

    Oh, forgot to mention, that on a half charge on the extended batter, I can pull it off, make a quick call
    a few minutes, less than 15, and turn around and see the damn battery indicator is yellow or red..
    Needless to say that's truly sad on a 3200mAh battery...
  4. #4  
    irie27's Avatar

    Posts
    33 Posts
    ROM
    DasBAMF 1.6.3

    Default

    I was having a similar problem. My phone was replaced. The CSR at Verizon didn't even bother to look at the phone. I haven't had a problem with the replacement. I do remember reading about 5 months ago that other Thunderbolt users were having the same issue.

Posting Permissions

B