Results 1 to 14 of 14
  1. Thread Author  Thread Author    #1  

    Default Facebook Contacts Won't Go Away

    I have my Facebook account unsynced from my phone. In settings>account and sync it is not synced as well as on the Facebook app. If I to to send a text message and I begin to type the name if someone in my contacts it will also come up with names and numbers of people on my Facebook that I do not have on my phone. Also when one of my friends texts me (I have him in my contacts) his Facebook display name and picture shows up Everytime. This is very annoying. Does anyone know how to fix this?
  2. #2  

    Default

    There isn't one really, except to completely remove Facebook for HTC. As long as it's installed, the second you sync that's going to happen.
  3. #3  
    Hockeypuck55's Avatar

    Posts
    105 Posts
    Global Posts
    157 Global Posts
    ROM
    Stock Rooted

    Default

    If if you haven't tried this:

    Go into people, hit menu button, hit the view option, then you can select which contacts to view.
  4. #4  

    Default

    That doesn't fix the problem he's having, which is that when he starts typing in names it begins to populate with his regular contacts along with the facebook contacts that are synced in. You have to remove your account from Facebook for HTC to avoid this from happening.
    Last edited by Bailarge; 04-27-2011 at 11:11 PM. Reason: Clarification
  5. #5  
    Hockeypuck55's Avatar

    Posts
    105 Posts
    Global Posts
    157 Global Posts
    ROM
    Stock Rooted

    Default

    Quote Originally Posted by Bailarge View Post
    That doesn't fix the problem he's having, which is that when he starts typing in names it begins to populate with his regular contacts along with the facebook contacts that are synced in. You have to remove your account from Facebook for HTC to avoid this from happening.
    Nope. You can unclick Facebook and those contacts won't show up.
  6. #6  

    Default

    Quote Originally Posted by Hockeypuck55 View Post
    Nope. You can unclick Facebook and those contacts won't show up.
    I tried that (i have the same situation) and if i go to manually dial a number say 508 *** ****or whatever number the contacts still populate my option for people to call. Why people want their number on fb eludes me. But i would like to figure this out without having to uninstall fb and start it over again.

    OP: Have you figured anything out?
  7. #7  
    scott750's Avatar

    Posts
    130 Posts
    Global Posts
    224 Global Posts
    ROM
    Stock Rom / Non-Rooted

    Default

    Try un-linking your contacts with Facebook.

    Go to People -> (select contact). In upper right corner click on the "linked" button. Unchecked the "Link to Facebook for HTC"
  8. #8  

    Default

    Quote Originally Posted by gov View Post
    I tried that (i have the same situation) and if i go to manually dial a number say 508 *** ****or whatever number the contacts still populate my option for people to call. Why people want their number on fb eludes me. But i would like to figure this out without having to uninstall fb and start it over again.

    OP: Have you figured anything out?
    Nothing will work, if you sync your FB contacts you will have them show up on the Phone where you go to Dial the number. This has to do with Sense, we have dealt with this issue from the day it launched.
  9. #9  
    Cyber Warrior's Avatar
    Robots Will Kill

    Posts
    8,565 Posts
    Global Posts
    11,964 Global Posts

    Default

    Depending on which Facebook account you're using, turn off sync contacts.
    Menu>settings>accounts & sync> Facebook for HTC Sense and/or Facebook app.... turn off sync contacts.
    If you're using the Facebook app.
    Open the app>app menu>app settings>other settings... turn off sync contacts.

    If they're still showing up in you're phonebook after that, try rebooting the phone. If that doesn't work, delete the gmail account with your contacts (from Accounts & Sync) and setup the gmail account again. You might want to also delete the Facebook accounts and re-install them again.This time make sure if you add any Facebook accounts... don't sync them to your contacts.
    Thanked by:
  10. #10  

    Default

    The only way I ever fixed this was by completely removing my facebook for HTC account, then I set my syncing settings to not auto sync or anything. I signed back in... here's the problem... the second you ever hit the sync button it comes back and you are back to square one. My point? As I've been saying... you can't fix it. It's a Sense issue. If you don't mind removing Facebook for HTC for good, then go that route. Otherwise, sorry but you're out of luck unless they fix it in an update (doubtful).
  11. #11  

    Default

    Thanks Cyber Warrior that did it. One question though, what is the downfall, if any, before I delete Sense? And where do I go to re-install it? I couldn't find it in the app drawer and I forget what I did when i set it up? The reason I want to do this is because I want to change my email account that is under that account? Thanks for the info
  12. #12  

    Default Remove FB contacts

    I had this problem with my EVO. Since these are essentially similar
    phones I would assume my solution will possibly fix your problems.

    First you have to delete FB for HTC Sense. Its easy to reinstall. Next I made sure I selected the option in people to sync contacts with gmail. Next and this is the hard part, reinstall FB for Sense. It will not do anything until you log into FB. Go into accounts and sync. FB will be there you will have to sign in to sync FB. The second you sign in back out and uncheck sync contacts. You can leave everything else checked. You have to be very fast but it worked for me. I thought this was the biggest pain in the a## because I hated having all my FB contacts in my address book when all I ever needed were the gmail contacts. It may take once or twice but you will figure it out. Just make sure in people FB contacts is also unchecked.

    Afterwards you can install SyncMyPics from the market and set it to update the contacts pictures with their FB profile if you care to do that. That way you can get some of the benefits that would come with syncing FB.

    Good luck let me know if this works. It can be a bit tricky, but like I said it worked for the EVO so maybe it will work for you. I would probably disable wifi when you sync so it will take more time to actually sync to FB (which gives you more time to uncheck the contacts sync)

    I am rooted running CM7 and am happy to have sense gone. The rom and possibly gingerbread gives you the option to sync all FB contacts, none, or just the ones in your gmail contact list. Sorry for the book, good luck.
  13. #13  

    Default

    Quote Originally Posted by Cyber Warrior View Post
    Depending on which Facebook account you're using, turn off sync contacts.
    Menu>settings>accounts & sync> Facebook for HTC Sense and/or Facebook app.... turn off sync contacts.
    If you're using the Facebook app.
    Open the app>app menu>app settings>other settings... turn off sync contacts.

    If they're still showing up in you're phonebook after that, try rebooting the phone. If that doesn't work, delete the gmail account with your contacts (from Accounts & Sync) and setup the gmail account again. You might want to also delete the Facebook accounts and re-install them again.This time make sure if you add any Facebook accounts... don't sync them to your contacts.

    Thank you.Delete the Facebook accounts and re-install them again. That is definitely the most effective way.
  14. #14  

    Default

    Luckily for me, I've never used the Facebook for HTC on my phone so I do not have this problem. I went right for the app and when I set it up and it asked if I wanted to sync contacts, I told it not to. No facebook contacts show up on my phone anywhere other than the app.

Posting Permissions

B