Results 1 to 15 of 15
  1. Thread Author  Thread Author    #1  

    Default WIFI Connections

    Anyone else having issues connecting to your home WIFI with the Verizon LG G2? I can't fathom it being a router problem, nor poor connection problem as all of my other WIFI devices are humming along just fine.

    The G2 seems to cycle through the connection process. By this, I mean I watch it in the WIFI settings section to see it search. It will go through ‘connecting’, ‘obtaining the IP’, ‘saved, secured’ then seems to repeat. Not sure if it connected a few times or not, but I've seen the ‘avoided poor connection’ message under my WIFI network before.

    Only Android device in the house. My laptops, receivers, tablets and iOS devices are all up and running.

    Security on the house router is WPA/WPA2 PSK I think. On open WIFI, I get on without a hindrance.
  2. #2  

    Default Re: WIFI Connections

    I haven't had any issues at all here. In fact sometimes I forget that I have my wifi on outside of the house and it immediately notifies me of wifi networks available whenever I come close to one. I had the Galaxy Nexus before and with the 4.2.2 update I had major issues with it either not showing that wifi was connected, it wouldn't connect at all, or it wouldn't even pick up available networks.
  3. #3  

    Default Re: WIFI Connections

    Quote Originally Posted by unarmedwoody View Post
    Anyone else having issues connecting to your home WIFI with the Verizon LG G2? I can't fathom it being a router problem, nor poor connection problem as all of my other WIFI devices are humming along just fine.

    The G2 seems to cycle through the connection process. By this, I mean I watch it in the WIFI settings section to see it search. It will go through ‘connecting’, ‘obtaining the IP’, ‘saved, secured’ then seems to repeat. Not sure if it connected a few times or not, but I've seen the ‘avoided poor connection’ message under my WIFI network before.

    Only Android device in the house. My laptops, receivers, tablets and iOS devices are all up and running.

    Security on the house router is WPA/WPA2 PSK I think. On open WIFI, I get on without a hindrance.
    Many many people have had this issue with our G2 and the Samsung's... Go into your router setting and check if there is a firmware update available..That has fixed just about everyone. I also changed my channel from 6 to 11 and have not had any issues since.
  4. #4  

    Default Re: WIFI Connections

    Does your router happen to be made by D-link?
  5. #5  
    sbudaj's Avatar

    Posts
    288 Posts
    Global Posts
    648 Global Posts

    Default Re: WIFI Connections

    Re-boot your router (or power it off then on again). That will likely fix the problem.
  6. Thread Author  Thread Author    #6  

    Default Re: WIFI Connections

    I usually unplug in, let it chill for about 20 seconds and let it fire back up (I consider that rebooting).

    Logged into the 2wire, forced the reboot that way and got a software update. Back online, LG working now.

    Sometimes I find that my ignorance is bliss.
  7. #7  

    Default Re: WIFI Connections

    Hello,

    There have been some really good responses here. If none of the suggested works, please feel free to reach out to our mobile support for more troubleshooting at 1-800-793-8896. Or you may visit our website for assistance:


    ^CL
  8. #8  

    Default Re: WIFI Connections

    Quote Originally Posted by unarmedwoody View Post
    I usually unplug in, let it chill for about 20 seconds and let it fire back up (I consider that rebooting).

    Logged into the 2wire, forced the reboot that way and got a software update. Back online, LG working now.

    Sometimes I find that my ignorance is bliss.
    Glad it was the update.....

    Posted via Android Central App
  9. #9  

    Default Re: WIFI Connections

    This is exactly what was happening and I didn't realized the router needed a firmware update! Thank you, Thank you, Thank you! This resolved the problem.
  10. #10  

    Default Re: WIFI Connections

    Quote Originally Posted by LGElectronics View Post
    Hello,

    There have been some really good responses here. If none of the suggested works, please feel free to reach out to our mobile support for more troubleshooting at 1-800-793-8896. Or you may visit our website for assistance:


    ^CL
    What a joke. I tried calling them twice. First time I got disconnected and the second they told me it was because my router had more than 5 devices connected. So I guess my phone can't get wifi because I have 7 devices on it? lol I told the CSR my router supported 50 devices and he told me I was wrong and there's no router on the market that supported more than 5. That ended my confidence right there... So I'm still stuck. I've tried two routers at home and 5 different locations and never got it to connect to Wifi. The ONLY way I can get it to connect is to turn off my 3G/4G connection. If I can't figure it out soon, I'll try resetting the phone to factory conditions. This kind of stuff shouldn't happen...
  11. #11  

    Default Re: WIFI Connections

    I have the same exact phone and problem. Did you get this solved?
  12. #12  

    Default Re: WIFI Connections

    Change security to wpa2 only. I find that some devices have problems connecting to certain routers that are set for wpa/wpa2.

    Posted via Android Central App
  13. #13  

    Default Re: WIFI Connections

    I have the LG G2, although it is on AT&T, I have the same issue. It would associate however no data packets would go through. I found the fix is to disable WPS (WiFi Protected Setup) on your router. I have never used it for any devices and for some reason maybe the G2 wants to connect that way, so simple disable WPS and reboot router was all that was necessary (firmware was already up to date anyway).
  14. #14  

    Default Re: WIFI Connections

    I had the same issue. I have the AT&T LG G2 for the record. Connecting to two different WIFI routers ( My own Linksys E3200 4 feet from the phone) and the FIOS provided Actiontec. ) Both connections were listed as "avoiding poor connection". The strange thing is, it -was- connecting to my wifi, but not displaying it as so. I opened up an MPD client that connects to an MPD on my local network, not accessible unless on the wifi local net. It was working OK. Other apps, like speedtest for example would still use the cell network.

    Anyway. My fix. I toggled Airplane mode, then turned wifi on. That seemed to do it. Below is the steps that -should- have worked but didnt as well as more details about what eventually did the trick.

    Previously, I first tried disabling the "Avoid Poor Connecitons" and "Check Internet Availability" and even "Wi-Fi Optimizations" no effect.
    Toggled WIfi. No effect
    Rebooted phone. No effect
    Turned off phone for a minute, booted up. No effect
    Rebooted Router. No effect. I'll again mention the problem was happening on both of my WIFI connections at the same time out of the blue. So I knew it wasn't the router anyway.
    Forgot Network / Re-added the connection. No effect.
    For the heck of it I changed my router from Mixed to N only mode on the 5 Ghz connection. No effect.

    Then lastly I put the phone into airplane mode. Then turned on WIFI (still in airplane mode) it started coming up and connected to my WIFI. I then turned airplane mode off. I have both (WIFI and 4G) connections working again at this point.

    To be thorough I returned my router settings back to the way they were. Wifi connection is still working on the phone.

    To be more thorough. I re-enabled the "Avoid poor connection" and "Check Internet Avail" and "Wifi Optimization" settings on the phone. It still working. Airplaine mode toggle seemed to reset whatever derpiness had occurred. Hope this helps someone.

    Cheers,
    Dan

    Edit: One takeaway. If your WIfi has been working for months and then stops. Chances are its not your router setup. Dont rush to change a mess of settings and mess up the rest of your network. Especially if its still working for every other device. There are lots of suggestions to overhaul your network. In reality your phone just flaked out and needs several kicks in the pants to be not-stupid-ified.
  15. #15  

    Default Re: WIFI Connections

    This worked for me. Brilliant post. This post needs to front page. Upvote!!


    Quote Originally Posted by agentrnge View Post
    I had the same issue. I have the AT&T LG G2 for the record. Connecting to two different WIFI routers ( My own Linksys E3200 4 feet from the phone) and the FIOS provided Actiontec. ) Both connections were listed as "avoiding poor connection". The strange thing is, it -was- connecting to my wifi, but not displaying it as so. I opened up an MPD client that connects to an MPD on my local network, not accessible unless on the wifi local net. It was working OK. Other apps, like speedtest for example would still use the cell network.

    Anyway. My fix. I toggled Airplane mode, then turned wifi on. That seemed to do it. Below is the steps that -should- have worked but didnt as well as more details about what eventually did the trick.

    Previously, I first tried disabling the "Avoid Poor Connecitons" and "Check Internet Availability" and even "Wi-Fi Optimizations" no effect.
    Toggled WIfi. No effect
    Rebooted phone. No effect
    Turned off phone for a minute, booted up. No effect
    Rebooted Router. No effect. I'll again mention the problem was happening on both of my WIFI connections at the same time out of the blue. So I knew it wasn't the router anyway.
    Forgot Network / Re-added the connection. No effect.
    For the heck of it I changed my router from Mixed to N only mode on the 5 Ghz connection. No effect.

    Then lastly I put the phone into airplane mode. Then turned on WIFI (still in airplane mode) it started coming up and connected to my WIFI. I then turned airplane mode off. I have both (WIFI and 4G) connections working again at this point.

    To be thorough I returned my router settings back to the way they were. Wifi connection is still working on the phone.

    To be more thorough. I re-enabled the "Avoid poor connection" and "Check Internet Avail" and "Wifi Optimization" settings on the phone. It still working. Airplaine mode toggle seemed to reset whatever derpiness had occurred. Hope this helps someone.

    Cheers,
    Dan

    Edit: One takeaway. If your WIfi has been working for months and then stops. Chances are its not your router setup. Dont rush to change a mess of settings and mess up the rest of your network. Especially if its still working for every other device. There are lots of suggestions to overhaul your network. In reality your phone just flaked out and needs several kicks in the pants to be not-stupid-ified.

Similar Threads

  1. Is there a way to make 4G icon go when on WiFi?
    By Lightshield in forum Verizon LG G2
    Replies: 12
    Last Post: 11-15-2013, 07:39 PM
  2. Facebook update broke Blinkfeed connection?
    By tall_geek in forum HTC One
    Replies: 8
    Last Post: 10-09-2013, 11:32 PM
  3. Replies: 7
    Last Post: 09-27-2013, 11:50 AM
  4. Texting over wifi with my number (recent convert from the iphone)
    By Kenneth Loebenberg in forum General Help and How To
    Replies: 2
    Last Post: 09-25-2013, 06:31 AM
  5. Replies: 0
    Last Post: 09-24-2013, 02:58 PM

Posting Permissions

B