Results 1 to 9 of 9
Like Tree1Likes
  • 1 Post By ncbell13
  1. Thread Author  Thread Author    #1  

    Default Verizon LG G2 Google contacts won't sync

    My Google contacts refuse to sync. Every time I try, I immediately get the exclamation-mark icon.

    This has only started happening in the past day. I bought the phone on Jan. 24. When I bought it, the VZW guy copied all my contacts from my old phone, and for some reason, this resulted in hundreds of duplicate contacts. I lived with it until yesterday, when I went into my Google contacts both via PC and on the phone and joined those that needed joining and deleted those I no longer needed. Now, everything else in Google syncs, but contacts do not. I've tried rebooting the phone; no luck. Suggestions? Thanks.

    Don't know if this is relevant, but all the pages/threads here and other sites I've Googled refer to going to Settings/Accounts & Sync. There is no "Accounts & Sync" on G2 like there was on my old phone. Just Settings => Accounts.
  2. #2  

    Default Re: Verizon LG G2 Google contacts won't sync

    Welcome to Android Central! This kind of thing can occur occasionally, if there's an issue with the Google server. It will often clear up on its own within a day, so consider waiting another day or so and see if it persists.

    The Settings page where you can see the sync details is usually Settings>Accounts-Google>[your Google account]. You will see a list of all Google apps, and a check mark next to the ones that are set to sync. It will also show the last time a successful sync occurred.

    Sometimes it may help to actually remove your Google account (in that same Settings>Accounts-Google menu) and then add it back.
  3. #3  

    Default Re: Verizon LG G2 Google contacts won't sync

    I've seen the same thing on mine for a few months--just the exclamation point and the message that my contacts haven't synced since 31 Dec. But that really isn't the case. They do, in fact, sync. I added a contact on my phone and changed a few others, and they showed up in Google contacts on my computer.

    Is this what you're talking about?
  4. #4  

    Default Re: Verizon LG G2 Google contacts won't sync

    This happens to mine often, not sure why though. To fix it, I clear the data from Contacts and Contacts Storage in Application Manager then go back into contacts and it starts to resync.
  5. #5  

    Default Re: Verizon LG G2 Google contacts won't sync

    Just be careful that you clear data from Google's contact app and not Verizon's. I actually did this a while back and managed to erase all my phone contacts. I never did recover them. Pretty dumb, I know.
    Last edited by SpikeHouston; 02-19-2014 at 10:13 PM.
  6. #6  
    ncbell13's Avatar

    Posts
    1 Posts
    Global Posts
    2 Global Posts

    Default Re: Verizon LG G2 Google contacts won't sync

    This app fixed my problem when nothing else would:
    shadowsjc likes this.
  7. #7  

    Default Re: Verizon LG G2 Google contacts won't sync

    I've used that same app. Contact sync works perfectly since I ran it once.

    Posted via Android Central App
  8. #8  

    Default Re: Verizon LG G2 Google contacts won't sync

    Same here with Contacts Sync Fix.

    Sent from my Nexus 7 using AC Forums mobile app
  9. #9  

    Default Re: Verizon LG G2 Google contacts won't sync

    I also see that message, but my contacts sync fine. My Motorola Razr MAXX also had that exact same problem, so I'd venture to say
    it's an Android OS issue and not a problem with a particular phone model.

Similar Threads

  1. Replies: 30
    Last Post: Today, 03:30 AM
  2. Rooted my Virgin LG Optimus F3
    By CHELKO in forum LG Optimus Series
    Replies: 5
    Last Post: 03-07-2014, 05:58 PM
  3. LG G2: Should I take the plunge?
    By Illustrator Joe in forum LG G2
    Replies: 55
    Last Post: 02-18-2014, 07:14 AM
  4. Replies: 1
    Last Post: 02-16-2014, 09:24 AM
  5. Search contacts by company not working??
    By pmurphy3304 in forum Sprint HTC One
    Replies: 0
    Last Post: 02-14-2014, 12:27 PM

Posting Permissions

B