Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 3 of 3
  1. Thread Author  Thread Author    #1  

    Default LG G2 WiFi problems STILL persisting after update!!

    I posted about three weeks ago about my peculiar WiFi problem with my G2 where it would shut off and snap right back on seconds later....CONSTANTLY. I found a workaround that actually worked, by turning airplane mode on and WiFi on at the same time, but it was bittersweet because the WiFi worked, but I couldn't send/receive messages or generally use my data at all.

    Someone commented that the new update would most likely fix this, but sadly, it's still persisting. I'd say even more than before!!!

    I've been contemplating a factory reset, but I want to know first if that would truly cure this problem.

    I'm at a complete loss here. Someone please help me!

    (Also, on a completely separate note, is there any way to run the android OS that runs on Samsung galaxy phones? I love that OS wayyyy more than KitKat) thanks.

    Posted via Android Central App
  2. #2  

    Default Re: LG G2 WiFi problems STILL persisting after update!!

    First, I really recommend getting together with Verizon for a replacement. Second, Samsung uses a user interface or graphical overlay named TouchWiz. LG doesn't really have a name for theirs but KitKat is the operating system. Samsung uses KitKat as well. There is no way to run TouchWiz on a non-Samsung phone. Best you can do is root and ROM, but I'd recommend a replacement first and foremost.
  3. #3  

    Default Re: LG G2 WiFi problems STILL persisting after update!!

    Quote Originally Posted by InboundPotato View Post
    I posted about three weeks ago about my peculiar WiFi problem with my G2 where it would shut off and snap right back on seconds later....CONSTANTLY. I found a workaround that actually worked, by turning airplane mode on and WiFi on at the same time, but it was bittersweet because the WiFi worked, but I couldn't send/receive messages or generally use my data at all.

    Someone commented that the new update would most likely fix this, but sadly, it's still persisting. I'd say even more than before!!!

    I've been contemplating a factory reset, but I want to know first if that would truly cure this problem.

    I'm at a complete loss here. Someone please help me!

    (Also, on a completely separate note, is there any way to run the android OS that runs on Samsung galaxy phones? I love that OS wayyyy more than KitKat) thanks.

    Posted via Android Central App
    Have you done a FDR? I would do one and not restore any apps, accounts, or any settings and test it, if that is good then it is something you did, if it's not consider a warranty replacement.

Similar Threads

  1. 4.4.2 Now running on my GN 10.1 (2014 edition) (wifi only version)
    By schulzjt in forum Samsung Galaxy Note 10.1 (2014)
    Replies: 30
    Last Post: 05-04-2014, 01:57 PM
  2. After a week with the Nexus 7 I am sending it back
    By petvas72 in forum Google Nexus 7 Tablet (2013)
    Replies: 48
    Last Post: 05-04-2014, 09:04 AM
  3. "Problem Loading Widget" Nova Launcher
    By corn4ahead in forum Verizon LG G2
    Replies: 2
    Last Post: 04-24-2014, 10:41 AM
  4. New nexus 5 owner = Love the Phone vs iPhone, S5, G2, etc
    By life4eva in forum Google Nexus 5
    Replies: 3
    Last Post: 04-24-2014, 08:55 AM
  5. OTA updates with root?
    By pin0y_bear in forum Samsung Galaxy S5
    Replies: 2
    Last Post: 04-23-2014, 05:58 PM

Posting Permissions