Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 7 of 7
  1. Thread Author  Thread Author    #1  

    Default S3 running terrible! Please recommend fixes

    This seems to happen to all my android products and its frustrating.

    The navigation doesn't work. I have tried downloading it and deleting it. Still wont work like it should. I checked all the screws and they were tight on the phone.

    Since the new software update (kit kat?), it is running INCREDIBLY slow. I can barely stand it.

    What are my options for fixing the navigation situation?

    What can I do to speed my S3 for daily functions (closing and opening apps ect)
  2. #2  

    Default Re: S3 running terrible! Please recommend fixes

    Wrong forum unfortunately...you're in the note 3 forum here, not the s 3

    Posted via Android Central App
  3. #3  

    Default Re: S3 running terrible! Please recommend fixes

    Quote Originally Posted by blaze45 View Post
    This seems to happen to all my android products and its frustrating.

    The navigation doesn't work. I have tried downloading it and deleting it. Still wont work like it should. I checked all the screws and they were tight on the phone.

    Since the new software update (kit kat?), it is running INCREDIBLY slow. I can barely stand it.

    What are my options for fixing the navigation situation?

    What can I do to speed my S3 for daily functions (closing and opening apps ect)
    I doubt this will fix all your problems on your phone but go into the playstore and download clean master you might have a lot of junk on your phone that needs cleaning....

    sent from my Nexus 7 using tapatalk pro..
  4. #4  

    Default Re: S3 running terrible! Please recommend fixes

    And also how do you have Kit Kat on your S3. There is no 4.4 update for the S3, which means you have to be rooted.
  5. #5  
    UJ95x's Avatar

    Posts
    6,626 Posts
    Global Posts
    6,770 Global Posts
    ROM
    Slim Kat 4.4.2 Build 3

    Default Re: S3 running terrible! Please recommend fixes

    Quote Originally Posted by z06mike View Post
    And also how do you have Kit Kat on your S3. There is no 4.4 update for the S3, which means you have to be rooted.
    He asked if it was Kit Kat, so I'm assuming he wasn't sure which the latest update was.

    Posted via Android Central App
    "We live in a society exquisitely dependent on science and technology, in which hardly anyone knows anything about science and technology." - Carl Sagan
  6. #6  
    UJ95x's Avatar

    Posts
    6,626 Posts
    Global Posts
    6,770 Global Posts
    ROM
    Slim Kat 4.4.2 Build 3

    Default Re: S3 running terrible! Please recommend fixes

    Quote Originally Posted by blaze45 View Post
    This seems to happen to all my android products and its frustrating.

    The navigation doesn't work. I have tried downloading it and deleting it. Still wont work like it should. I checked all the screws and they were tight on the phone.

    Since the new software update (kit kat?), it is running INCREDIBLY slow. I can barely stand it.

    What are my options for fixing the navigation situation?

    What can I do to speed my S3 for daily functions (closing and opening apps ect)
    Boot into recovery (Hold volume up, home and power) and clear the system cache.
    If that doesn't work I'd recommend a factory reset. Should be done after any major update anyway

    Posted via Android Central App
    "We live in a society exquisitely dependent on science and technology, in which hardly anyone knows anything about science and technology." - Carl Sagan
  7. #7  

    Default Re: S3 running terrible! Please recommend fixes

    Quote Originally Posted by UJ95x View Post
    He asked if it was Kit Kat, so I'm assuming he wasn't sure which the latest update was.

    Posted via Android Central App
    Ah my bad! I don't know how I missed that.

Similar Threads

  1. Verizon S3 volume issues
    By ryanbart in forum Verizon Galaxy S3
    Replies: 1
    Last Post: 01-24-2014, 12:27 PM
  2. New Moto G user - needs basic help please
    By furkin in forum Moto G
    Replies: 5
    Last Post: 01-17-2014, 06:10 PM
  3. Samsung Galaxy S3 no network choices
    By craiggrubbs in forum Samsung Galaxy S3
    Replies: 0
    Last Post: 01-17-2014, 02:05 PM
  4. S3 keeps reconnecting to wifi router after 4.3 update !!!!
    By baljeet bassi in forum Samsung Galaxy S3 I9300
    Replies: 0
    Last Post: 01-17-2014, 01:20 PM
  5. 4.3 Update on S3 Randomly Putting Phone in Vibrate Mode
    By JoePaLives in forum Android 4.1 / 4.2 / 4.3 Jelly Bean
    Replies: 0
    Last Post: 01-17-2014, 10:49 AM

Posting Permissions