1. Jdt0109's Avatar
    I updated my s4 for verizon last week and it seemed to fix any lag or any issue I had. But after the update my signal strength seems to be weaker. Anyone in the same boat?
    07-15-2013 02:02 PM
  2. Vondutch67's Avatar
    Yes, I have had the exact same experience: Lag down and so is my phone's overall radio performance. This update was/is a bummer for me.
    SoCalBIGmike likes this.
    07-16-2013 08:37 AM
  3. fatboy97's Avatar
    Forums typically have a lot of problems being posted, but most like this do not say anything about what people have attempted to do to fix these issues... or have you tried nothing? Did you call Verizon? Did you reboot your device? Did you do a Factory Reset? Did you do nothing, but post a complaint here?

    Personally, I read this and did not post the first time since I did not have any issues with this update... and I'm sure most of the people that have viewed this thread have not seen any issues with their signal/radio.
    johnriii likes this.
    07-16-2013 10:18 AM
  4. Live2ride883's Avatar
    Forums typically have a lot of problems being posted, but most like this do not say anything about what people have attempted to do to fix these issues... or have you tried nothing? Did you call Verizon? Did you reboot your device? Did you do a Factory Reset? Did you do nothing, but post a complaint here?

    Personally, I read this and did not post the first time since I did not have any issues with this update... and I'm sure most of the people that have viewed this thread have not seen any issues with their signal/radio.
    Updating now, so I'll find out soon...
    07-16-2013 02:19 PM
  5. badjujumatt's Avatar
    I got the update today. I am experiencing lag, text messages are lagging on send, cannot connect to Facebook, etc. Also per the other thread, I do not have the wifi toggle in my pull down menu. Several restarts have not corrected the issue, going to try a battery pull. I really do not want to do a factory reset. My superfast new phone is slowing down every week.....
    07-16-2013 02:39 PM
  6. Averix's Avatar
    I got the update today. I am experiencing lag, text messages are lagging on send, cannot connect to Facebook, etc. Also per the other thread, I do not have the wifi toggle in my pull down menu. Several restarts have not corrected the issue, going to try a battery pull. I really do not want to do a factory reset. My superfast new phone is slowing down every week.....
    The worst part of this update seems to be the delta between the great experience some users are having and the crap experience others are having. Seems like such a wide spectrum of behavior. Since it's all sort of subjective, I guess it is tough to quantify everyone's experience.
    SoCalBIGmike likes this.
    07-16-2013 02:43 PM
  7. badjujumatt's Avatar
    Battery pull complete. Weatherbug wont update, the wiget wont work, still have connection issues with apps.....come on wtf verizon.
    07-16-2013 02:53 PM
  8. Mongrols's Avatar
    I had the same issue when I first bought the s4. Go into settings, more networks, mobil networks, then network mode. Make sure LTE/CDMA is checked not global. I did a factory reset after update. Got wifi toggle and all apps work smooth now.
    07-16-2013 07:00 PM
  9. Jdt0109's Avatar
    So did the update put my s4 on global mode? When I went to settings, more settings, mobile nwtworks I am running on global. Do I need to switch to LTE/CDMA?
    07-17-2013 03:41 PM
  10. Mongrols's Avatar
    Yes. It def worked for me
    07-17-2013 03:56 PM
  11. techgeek32#WN's Avatar
    You all really need to do a hard reset. I know that it is a real pain to setup everything from scratch, but you will continue to have some of these problems until you do a factory reset.
    fatboy97 and SoCalBIGmike like this.
    07-17-2013 09:11 PM
  12. fatboy97's Avatar
    You all really need to do a hard reset. I know that it is a real pain to setup everything from scratch, but you will continue to have some of these problems until you do a factory reset.
    Totally agree!!!
    07-18-2013 09:50 AM

Similar Threads

  1. SAMSUNG S4 GT-I9505 Bluetooth/Car Stereo Pausing Issue
    By Reedy84 in forum General News & Discussion
    Replies: 2
    Last Post: 12-24-2014, 05:31 AM
  2. After owning a Note 2, what's your next phone gonna be?
    By the1m.polo in forum Samsung Galaxy Note 2
    Replies: 30
    Last Post: 07-18-2013, 09:19 PM
  3. Sprint / Samsung S4 Now Updating 7/15/13
    By RockLight in forum General News & Discussion
    Replies: 3
    Last Post: 07-15-2013, 08:15 PM
  4. PRL Update?
    By wpavlik2 in forum T-Mobile HTC One
    Replies: 2
    Last Post: 07-15-2013, 07:20 PM
  5. Typing bug with update?
    By starbuckk in forum Samsung Galaxy S4
    Replies: 2
    Last Post: 07-15-2013, 05:09 PM
LINK TO POST COPIED TO CLIPBOARD