1. wootang00's Avatar
    Hello,

    Is anyone else experiencing this problem of sending picture messages with the S4?
    My phone will just have a circle constantly next to the picture at times.
    The only way it will send after that is restarting the phone. But sometimes that wont work either..

    It seems to be a given if we are on WIFI, it wont send a picture message either.
    But for my phone, even if i'm off wifi it does not work at times.. its not consistent..

    Anyone else having this problem?
    07-23-2013 02:24 AM
  2. takehiro12's Avatar
    I'm only having the problem on Wi-Fi, as soon as I enable mobile data it sends.
    DarXang likes this.
    07-23-2013 09:19 AM
  3. tytlyf's Avatar
    I don't believe you can send MMS over wifi. Enable your mobile data network and that should do it. Same goes for receiving MMS messages.
    07-23-2013 09:40 AM
  4. alissaj's Avatar
    Hi..I just got my galaxy s4 a month ago..I haven't had issues sending MMS to other people until a day ago. My MMS would send..the circle wasn't continuously loading..my text went through, but the recipient never received. Is this something to do with my phone? The recipient has the same exact phone as me and my pictures would send to other people no problem and they received them. I was researching possible reasons as I read below..I turned off my wifi..enabled my data usage..but don't think anything has changed. Anyone have a problem having the other person receive pictures? ...like I said..nothing popped up saying my file was too big or that the message didn't go through..it shows sent on my end.

    Please help!!

    Thanks,,
    09-18-2013 06:08 PM
  5. Julie Ann Handwerk's Avatar
    Hi..I just got my galaxy s4 a month ago..I haven't had issues sending MMS to other people until a day ago. My MMS would send..the circle wasn't continuously loading..my text went through, but the recipient never received. Is this something to do with my phone? The recipient has the same exact phone as me and my pictures would send to other people no problem and they received them. I was researching possible reasons as I read below..I turned off my wifi..enabled my data usage..but don't think anything has changed. Anyone have a problem having the other person receive pictures? ...like I said..nothing popped up saying my file was too big or that the message didn't go through..it shows sent on my end.

    Please help!!

    Thanks,,
    09-22-2013 07:15 AM
  6. Julie Ann Handwerk's Avatar
    Me too just bought the 4 2 months ago and already cant send pict .messages it has to be the phone cuz I hear this from so many people already.ill be taking it back to be looked at tomorrow morning. Its a shame to spend all this much money and it d I nt wirk properly already
    09-22-2013 07:18 AM
  7. jmarks9282's Avatar
    Just bought an S4 two days ago and this problem has stumped me until today!
    Go to settings, click on wifi, click the bottom left button next to the home button (one of the light up buttons) to bring up another menu, click Advanced, "check for Internet service" should be checked. This allows for the phone to toggle between wifi and 4G as needed. Very importantly, re-boot your phone and all should be well! Not sure why you have to reboot but my problem wasn't fixed until I rebooted!
    Spread the word!
    Jeffrey
    Husker Z and lv2bsilly like this.
    09-24-2013 11:39 PM
  8. Husker Z's Avatar
    Just bought an S4 two days ago and this problem has stumped me until today!
    Go to settings, click on wifi, click the bottom left button next to the home button (one of the light up buttons) to bring up another menu, click Advanced, "check for Internet service" should be checked. This allows for the phone to toggle between wifi and 4G as needed. Very importantly, re-boot your phone and all should be well! Not sure why you have to reboot but my problem wasn't fixed until I rebooted!
    Spread the word!
    Jeffrey
    Trying this now, hopefully you are right, I have the same issue, won't send any sort of MMS over any WiFi.

    Thanks.

    Update, this works!!

    Thanks again!
    09-25-2013 08:29 AM
  9. cameronmangast's Avatar
    This did not work for me!
    lv2bsilly likes this.
    09-27-2013 07:57 PM
  10. djm1947's Avatar
    This did not work for me!
    Try this. Credit goes to someone else, I just do not remember where I saw it. I have used it two or three times when pics would not send:
    Be sure to have the check for Internet mentioned above completed.

    Go to settings< more< application manager< all

    Scroll down to the Messaging icon, disable, clear data, enable

    Then go to your app drawer and drag the Messaging icon to your home screen.

    Your messages should still be there and pics should send again.

    Sent from my SCH-I545 using Tapatalk 4
    10-03-2013 10:33 PM
  11. Ramsin Michael's Avatar
    Try this. Credit goes to someone else, I just do not remember where I saw it. I have used it two or three times when pics would not send:
    Be sure to have the check for Internet mentioned above completed.

    Go to settings< more< application manager< all

    Scroll down to the Messaging icon, disable, clear data, enable

    Then go to your app drawer and drag the Messaging icon to your home screen.

    Your messages should still be there and pics should send again.

    Sent from my SCH-I545 using Tapatalk 4
    This worked perfectly for rooted sprint galaxy s4. That you so much. I didn't have to do anything with the icon just clear the cache and data
    09-23-2014 05:34 PM
  12. BriJae's Avatar
    Does anyone know.how to increase the number of MMS pics in a text message? I'm only able to send 2 at a time any more it says to try sending via email

    Posted via the Android Central App
    01-27-2015 06:48 PM
  13. lealaken's Avatar
    I had this problem on my Galaxy S4 with two different carriers and I was on the phone more times than I can remember trying to fix it....but I finally found someone who was able to fix the problem. This is what fixed mine: Remove the battery WHILE THE PHONE IS STILL ON, leave it out for about 5 minutes, and replace the battery. Turn the phone back on and then try sending a MMS pic message to YOURSELF. Just send the pic message to your own phone number. Once it sends successfully (hopefully it will) try sending to others. This worked for me and I really hope it helps someone else. This issue frustrated me for well over a year. And if it starts messing up again, just do this again. Another VERY IMPORTANT thing to know: If you are using a lower cost cell network (anything other than the big guys like Verizon, AT&T, Sprint, T-Mobile) you HAVE to turn off WiFi in order to send pic MMS messages!!!! And of course, make sure your mobile data is turned on.
    01-08-2016 11:30 AM

Similar Threads

  1. Galaxy Perks?
    By Truwire in forum Samsung Galaxy Tab 3
    Replies: 16
    Last Post: 04-29-2014, 04:01 PM
  2. Any good roms for galaxy s3?
    By Yes Im That Guy in forum AT&T Galaxy S III Rooting, ROM's, and Hack's
    Replies: 11
    Last Post: 08-09-2013, 07:47 PM
  3. how to import images from NIKON DSLR-Galaxy note 8.0
    By manatsuki in forum Samsung Galaxy Note 8.0
    Replies: 6
    Last Post: 07-26-2013, 03:02 PM
  4. Q about Contact Names in S4
    By BTSMGL in forum Samsung Galaxy S4
    Replies: 0
    Last Post: 07-23-2013, 01:30 AM
  5. Rooting my HTC Sensation with my MacBook Pro
    By Juliet72 in forum Sensation Rooting, ROM's and Hacks
    Replies: 0
    Last Post: 07-22-2013, 11:43 PM
LINK TO POST COPIED TO CLIPBOARD