Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 23 of 23
Like Tree4Likes
  • 4 Post By 847AlexC
  1. Thread Author  Thread Author    #1  

    Default Problem with SMS Galaxy S4 with International SIM Card

    Hello!

    I am using my Galaxy S4 while living in Costa Rica and recently replaced my Verizon SIM with one from a local carrier. The transition was seamless and I'm able to access voice and data with no problems. However, sending text messages is proving to be extremely frustrating because each time I receive a message from a local number (regardless of whether or not I have this number saved in my phone) it always comes in with the country code first (+506 for CR). When I try to reply to those messages I receive a "Failed" sign immediately after sending.

    I can only successfully send texts if I open a new message box and type in the contact name or number so it appears without the +506 country code. Again, all of the contacts in my phone don't even have the +506 included in their contact info. So the issue is, my phone is automatically including the country code in received messages even though I'm on the local network. I guess it's much like it used to be when you couldn't dial your neighbor's house with the area code included, it had to be just the last 7 numbers.

    I spoke to Verizon and the woman who helped me could not think of any solution other than to set my Current Country to Costa Rica (which it already was), and to turn Assisted Dialing off (it was previously turned on). This did not fix the issue. The only thing she thought could be causing it was that a 3rd party app (I have Google Voice/Talkatone), or something like Facebook, was running in the background and causing this to happen.

    Has this happened to anyone else? I would greatly appreciate any information you could provide, as it is getting very annoying having to take several extra steps just to send a text! Thanks in advance!

    Cheers,
    CK
  2. #2  

    Default Re: Problem with SMS Galaxy S4 with International SIM Card

    My wife is in Germany right now and replaced a U.S. T-Mobile SIM with a card from a local German carrier.
    She just reported the problem to me last night. This happened during her last trip as well. I have yet to figure out a solution for this.
    The last time I think we narrowed it down to the issue that the '+' sign before the country code is not recognized by the local carrier as a generic stand-in for the otherwise always different country code prefix (e.g. European countries typically use '00' as a prefix vs the US uses '011').
    One idea I want to try out later with her is to modify the actual contact's phone numbers to include the proper country code prefix.
    I'll update this thread with my findings.
  3. #3  

    Default Re: Problem with SMS Galaxy S4 with International SIM Card

    same here, a friend of mine from texas, us bought a samsung galaxy s4 verizon and send to me here in philippines. he said its unlocked one like what the guy told from verizon told him, when I started using it and insert a local simcard here which is Globe telecom, I chosed gsm network and very happy that it recognized the sim and I tried to call my friends and it works smoothly but the frustrating side is I cant reply to them. I wonder why, I tried to send without country code (+63 here) it works twice but everytime I closed the sms app and open it again to send a new message to the same number (message thread) it fails again. its kinda frustrating hope someone can figure it out. thanks because I thought I was the only one who having problem about it, im still searching I'll be happy to share some ideas if ever.
  4. #4  

    Default Re: Problem with SMS Galaxy S4 with International SIM Card

    I believe I have found a solution to this problem.

    I had a similar issue. I work in Azerbaijan, but keep my US Verizon Samsung Note 3 and swap SIM cards when I travel. I too was having the issue of not having my outbound text messages received, unless I removed the country code and prefix. However, as this is how my contacts were stored and how the inbound call-ID labelled them, this was very frustrating and time-consuming.

    In the end, the solution is to utilize the Assisted dialing feature, with some modifications (phone dialer>settings button>call settings>assisted dialing [tap to edit]). When I chose the country for the assisted dialing, it correctly selected my country code as 994. However, in order to make my texts work I had to manually add in the "+" sign. now the phone recognizes the "+994" that is in all of the contacts and inbound phone numbers. texts now seem to works as they should. Also, be sure to turn the assisted dialing on.

    Hope this helps all of the other travelers out there.

    -Alex
  5. #5  

    Default Re: Problem with SMS Galaxy S4 with International SIM Card

    Last guy is a genius. Vodafone nor a Verizon. Nor samsung was able to help me but the manually adding the + works. Just go to phone - menu - settings - assisted dial- choose the country your in and the country code will populate then manually add a plus sign. Works beautifully . Thanks !
  6. #6  

    Default Re: Problem with SMS Galaxy S4 with International SIM Card

    Thankssss A lot...........................................
  7. #7  

    Default Re: Problem with SMS Galaxy S4 with International SIM Card

    Hi - I have the same problem and it sounds like the Assisted Dialing thing could be a solution for me, but can you please explain exactly WHICH of the manual settings to adjust, and to what? Specifically,
    Country Code (I live in Papua New Guinea so our CC is 675; I assume I just write this)
    IDD prefix (we use either 00 or +; does it matter which one I write?)
    NDD (we don't use any local prefix like 0 - do I just leave it blank?)
    City/area code (we don't use any - do I just leave it blank?)
    National number length (it's 8 so I assume I write this)

    Thanks!
    -Boris
  8. #8  

    Default Re: Problem with SMS Galaxy S4 with International SIM Card

    I have to bump this bc i had the same issue with my vzw note 4 that I'm using in Germany. Texting was becoming extremely annoying and even the phone center where I got my Sim couldn't help. You are a genius! I'm going to go back to the phone center to spread the word on this fix because I guess they get it a lot.
  9. #9  

    Default Re: Problem with SMS Galaxy S4 with International SIM Card

    great solution thank you sir
  10. #10  

    Default Re: Problem with SMS Galaxy S4 with International SIM Card

    I was very annoyed with this issue bcoz i got unlocked verizon note 3 and this issue really bother me.
    I just add + sign in assisted dail option and its resolves my issue.
    thanks for thr great solution
  11. #11  

    Default Re: Problem with SMS Galaxy S4 with International SIM Card

    Quote Originally Posted by 847AlexC View Post
    I believe I have found a solution to this problem.

    I had a similar issue. I work in Azerbaijan, but keep my US Verizon Samsung Note 3 and swap SIM cards when I travel. I too was having the issue of not having my outbound text messages received, unless I removed the country code and prefix. However, as this is how my contacts were stored and how the inbound call-ID labelled them, this was very frustrating and time-consuming.

    In the end, the solution is to utilize the Assisted dialing feature, with some modifications (phone dialer>settings button>call settings>assisted dialing [tap to edit]). When I chose the country for the assisted dialing, it correctly selected my country code as 994. However, in order to make my texts work I had to manually add in the "+" sign. now the phone recognizes the "+994" that is in all of the contacts and inbound phone numbers. texts now seem to works as they should. Also, be sure to turn the assisted dialing on.

    Hope this helps all of the other travelers out there.

    -Alex
    Thanks mate

    Just fixed my note 4 sms problem with your finding

    There is 2 ways
    You can either change country and add + symbol in front of country code, or keep any country and just change city/area code with correct country code, both method works, after that you can even disable assisted dialing option
  12. #12  

    Default Re: Problem with SMS Galaxy S4 with International SIM Card

    Maybe I'm not understanding this; could use some help.

    I am in the US. On my Verizon S4 Phone, menu, Settings, Call, Assisted dialing (which is on), I set Country code to +1.

    But I still can't send texts on T-Mobile.
  13. #13  
    Sgooter's Avatar

    Posts
    172 Posts
    Global Posts
    222 Global Posts

    Default Re: Problem with SMS Galaxy S4 with International SIM Card

    Quote Originally Posted by toolworker View Post
    Maybe I'm not understanding this; could use some help.
    I am in the US. On my Verizon S4 Phone, menu, Settings, Call, Assisted dialing (which is on), I set Country code to +1.
    But I still can't send texts on T-Mobile.
    I don't think the +1 setting will remedy your problem, since you're in the U.S. using a Verizon phone.
    Are you using the APN settings for T-Mobile?
  14. #14  

    Default Re: Problem with SMS Galaxy S4 with International SIM Card

    Quote Originally Posted by Sgooter View Post
    I don't think the +1 setting will remedy your problem, since you're in the U.S. using a Verizon phone.
    Are you using the APN settings for T-Mobile?
    Yes.

    Further to this - I was able to send texts from the Verizon S4 running Lollipop while roaming in the Caribbean on a T-Mobile SIM card.

    In the U.S., a workaround is to text and cc a second recipient (I use my landline phone number) which as I understand it forces the message to MMS which works OK.
  15. #15  
    Sgooter's Avatar

    Posts
    172 Posts
    Global Posts
    222 Global Posts

    Default Re: Problem with SMS Galaxy S4 with International SIM Card

    Interesting...are you using the stock messaging app or the Verizon msg app?
  16. #16  

    Default Re: Problem with SMS Galaxy S4 with International SIM Card

    Quote Originally Posted by Sgooter View Post
    Interesting...are you using the stock messaging app or the Verizon msg app?
    Whatever the phone was set up with. It's called Messaging and the icon is a lined yellow sheet of paper sticking out the top of a white envelope.
  17. #17  

    Default Re: Problem with SMS Galaxy S4 with International SIM Card

    BTW I filed a complaint here with the FCC. Maybe if they hear enough about it, they'll ask Verizon what's going on, and that might shake something loose.

    Verizon's policy is that their phones are unlocked and they told me the phone is unlocked. But as far as SMS goes, it's not.

    It's easy to file a complaint. I suggest that if you do so you use the word "locked" in your complaint.
  18. #18  
    Sgooter's Avatar

    Posts
    172 Posts
    Global Posts
    222 Global Posts

    Default Re: Problem with SMS Galaxy S4 with International SIM Card

    From your description, you are using the stock Android messaging app.
    I believe your SMS problem has nothing to do with your phone being locked or unlocked. If your phone is indeed a Verizon-branded GS4, then I'm confident your phone is unlocked.
    I suggest you re-check your Preferred Network Mode setting; it should be set on LTE/GSM/UMTS or Global. It should not be set to LTE/CDMA.
    Path is: Settings - More Networks - Mobile Networks - Network Mode, then Preferred Network Mode.

    BTW, a few months ago I filed a consumer complaint to the FCC about Sprint's deception and refusal to cooperate in unlocking a Sprint-branded GS4. In essence, my complaint was unsuccessful. Sprint claims they are unable to unlock the phone, yet they factually told me that the 6-digit MSL code they gave me would unlock it, even though they know, and later sheepishly admitted to me, that the MSL code will not unlock it.
  19. #19  
    Sgooter's Avatar

    Posts
    172 Posts
    Global Posts
    222 Global Posts

    Default Re: Problem with SMS Galaxy S4 with International SIM Card

    If setting your phone's Preferred Network Mode to LTE/GSM/UMTS does not fix the T-Mobile texting problem, then try setting the phone to Global.
    If the texting problem is still not working after switching to Global, then leave it in Global mode, but change the Country Code setting to 1 instead of +1.
    My belief is that your texting problem is a settings problem, and not a SIM nor unlocked/locked phone problem.
  20. #20  

    Default Re: Problem with SMS Galaxy S4 with International SIM Card

    Thanks for your interest. The phone has to be set to Global or GSM to work with T-Mobile. And I've seen the +1 => 1 fix suggested in other threads. I did try your suggestions again, and none of them work.

    There are a lot of threads on this. It is a known problem with Verizon G4s and the Lollipop update running on 4G.
  21. #21  
    Sgooter's Avatar

    Posts
    172 Posts
    Global Posts
    222 Global Posts

    Default Re: Problem with SMS Galaxy S4 with International SIM Card

    Sorry to hear my suggestions didn't work.
    Although I'm currently on contract with Verizon, about 6 weeks ago (as a test) I was able to insert someone's active Cricket SIM into my unlocked Veriz Lollipop GS4 and apply the Cricket APN settings. Everything that was important to me worked fine on Cricket (AT&T GSM). On Cricket, my GS4 does not receive 4G LTE, but it does get 3G HSPA+, and that's fine for my needs. All other functions worked fine: SMS, MMS, Internet, Email, Phone, Voicemail, etc. So, I'm surprised that your Verizon GS4 is not working OK on T-Mobile (GSM), in particular for SMS.
    If I learn of a true fix for your problem, I'll certainly post it here; please do the same if you're able to fix it. Good luck til then.
  22. #22  

    Default Re: Problem with SMS Galaxy S4 with International SIM Card

    The SMS issue only arises with a 4G connection, so you wouldn't see it if you don't get 4G. And it might be peculiar to T-Mobile; I don't see references to AT&T in a quick search. And it doesn't affect MMS.
  23. #23  

    Default Re: Problem with SMS Galaxy S4 with International SIM Card

    Nightmare. I can't believe an Android phone would ship with such a bug. Bought phone at Best Buy, traveled to Europe, bought a local SIM card. All my Google contacts have + (country code) in front of them. I can dial numbers direct, but without the Plus Sign (+). I can't dial anything in my address book. Researched it and painfully so, I found a third party app (prefixer) that does the trick after trying a few. You basically want to add "00" in front of the +.

    It's simple enough, but I don't care for the fact that it's not native to the phone. Here is the configuration below - best of luck

    Problem with SMS Galaxy S4 with International SIM Card-screenshot_20160505-152145.jpg

Similar Threads

  1. S4 Proximity sensor issue
    By David Cutler in forum Samsung Galaxy S4 Google Edition
    Replies: 34
    Last Post: 07-19-2016, 05:04 PM
  2. Got a used Note II from Ebay to use with Straight Talk
    By Medicineman in forum AT&T Galaxy Note 2
    Replies: 5
    Last Post: 01-25-2014, 02:22 PM
  3. HELP with going from GB to ICS on my Optimus V (AOKP Quattrimus)
    By Deepseeker25 in forum Virgin Mobile Optimus V
    Replies: 6
    Last Post: 09-15-2013, 02:41 PM

Posting Permissions