On my Galaxy S4 I have tried to clear the auto fill. I have use 2 History Eraser Apps from the Google Play Store HistoryEraser & HISTORY ERASER. I have told both to clear the auto fill and cache and Clipboard. I have also gone into system setting and done the same. I have some other apps that I thought might help also but can seem to find anything in them to clear it out. AppMgr III, Advanced Task Manager Pro, & SystemPanel.

I have gone in to the default browser and Chrome and done the same on both. Gone in to privacy settings and don it there. I have told Google to delete search history. But if I try to enter a search it still tries to auto fill and suggestions from past search and web sites I have entered. If I try to send a text it shows the same info there also.

How can I get my system to completely delete this info so nothing is entered when I start typing?