Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 6 of 6
  1. Thread Author  Thread Author    #1  

    Default WiFi Low Signal Issue

    Hello all,

    I have had my GS4 a little over a year now and so far have really enjoyed the phone. However within the last day or two I have been experiencing WiFi problems which I have never had before. When standing right next to my TP-Link WDR3600 I have good signal, but when I walk 20 feet away, the signal drops to 0-1 bars. All other electronic devices in my house have 3-5 bars of WiFi regardless of where I stand in my house. My phone used to have great WiFi coverage, and now it sucks.

    When these issues arose I thought maybe I should update my phone from 4.3 to 4.4, however that did not fix anything. So far I have tried factory resetting my phone twice as well as clearing the cache. Nothing has worked. I know this is not a problem with my router as I am experiencing the problems on my WiFi at work and at a friends house.

    Any insight would be great. Thank you
  2. #2  

    Default Re: WiFi Low Signal Issue

    My story is the same is yours except I have been running 4.4 since it was available. I noticed the problem 2-3 days ago. It seemed to be resolved yesterday for about 6 hrs, but then right back to 0-1 bar of wifi signal. I have no idea on a solution.
  3. #3  

    Default Re: WiFi Low Signal Issue

    So I seem to have fixed the problem. I did a search for the wifi antenna location on the S4 (if you are looking at the back of the device it is located just below the top left screw) to see if it was a hardware issue. The website suggested "cleaning" the antenna so I merely rubbed a few times with my t-shirt. BOOM wifi signal back to normal. I haven't been out of the house to test it else wear , but it seems to be working fine now.

    Hope this helps!
  4. Thread Author  Thread Author    #4  

    Default Re: WiFi Low Signal Issue

    Thank you for the reply. I will try this out ASAP and let you konw how it goes. Just one quick question.

    Did you remove the whole back cover as shown in the pictures below? Or were you able to just pop off the little plastic antenna cover which is shown in picture 1?

    WiFi Low Signal Issue-img_3221.jpg

    WiFi Low Signal Issue-img_3225.jpg

    WiFi Low Signal Issue-img_3226.jpg
  5. #5  

    Default Re: WiFi Low Signal Issue

    I ONLY took off the battery cover. I just rubbed the little plastic antenna area that is in the box in the first pic. Just to stress, I did not remove anything other that the battery cover.
  6. #6  

    Default Re: WiFi Low Signal Issue

    Sounds a little bit like magic. The truth might be that your antenna connector has loose contact. The antenna connector (pic 2) is a spring contact, which in my case was pressed down and had no contact. You have to remove the "midframe" (google for an unmounting guide)! Then slightly pull up the spring contact for the wifi antenna until it looks like the other spring contacts.

Similar Threads

  1. Replies: 36
    Last Post: 12-31-2014, 11:21 AM
  2. Replies: 8
    Last Post: 09-10-2014, 10:18 AM
  3. Wifi calling Error - Need Help
    By F8ker8 in forum HTC One M8
    Replies: 3
    Last Post: 08-19-2014, 09:24 PM
  4. wifi password recovery
    By bbmjack in forum Samsung Galaxy S5 Rooting, ROMs & Hacks
    Replies: 1
    Last Post: 08-12-2014, 05:41 PM
  5. Weird Group Messaging Issue
    By oldmuttonhead in forum Samsung Galaxy S4
    Replies: 0
    Last Post: 08-12-2014, 01:19 PM

Posting Permissions