Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 9 of 9
  1. Thread Author  Thread Author    #1  
    RaeFlynne's Avatar

    Posts
    27 Posts
    ROM
    IHO BacksideROM 08/30

    Default Semi bricked? [Resolved!]

    Well, lets see here...

    I've got the optimus V running the 8/30 build of IHO, and I was running the CWM 3.0.1.4 (Or whatever) recovery.

    I was trying to install the recovery listed on IHO page (Blarf's recovery) through Mmarz's ROMtools. I tried two or three times with no change at all. After clearing some stuff off my SD card, and making sure everything else was in order, I ran ROMtools again, and it seemed to work at first. Then my phone booted into the Fastboot blue screen error that I've seen talked about in other threads in this forum.

    So, I've been putzing around trying to fix it, but I've run into some weird issues. When I try to flash a new recovery, I get an error saying the directory or file could not be found, which is odd, since I was typing it correctly. I could navigate to the directory and find the file just fine, but couldn't for the life of me get it to flash.
    (Note here, I tried putting the file in both /sdcard/vrecovery.img and in /system/vrecovery.img, and neither worked)

    So then I tried the Fastbootroot.bat file, and Fastboot couldn't find the device, which, again, is odd. Hmm...
    Anybody have some suggestions here?

    (Note: My phone works just fine, so I'm not stressing over this TOO hard, but it's a little uncomfortable knowing that if something dies, I won't be able to fix it until I take care of this...)
  2. #2  
    jdcnosse's Avatar

    Posts
    515 Posts
    Global Posts
    516 Global Posts
    ROM
    modified BACKside

    Default Re: Semi bricked? Iunno...

    If your phone can boot, then what I would try is flashing the recovery through Terminal on your phone.

    Open it up, make sure you're root, navigate to wherever your recovery.img file is and then type (where recovery.img is your recovery file):

    Code:
    flash_image recovery recovery.img
    and if that works then you're golden (hint to reboot into recovery after that, just type "reboot recovery")

    if not...well either you don't have flash_image on your phone (it's around here somewhere), or your recovery.img file is borked and I'd try re-downloading it.

    Otherwise maybe you messed up your recovery partition...
  3. #3  

    Default Re: Semi bricked? Iunno...

    Quote Originally Posted by jdcnosse View Post
    If your phone can boot, then what I would try is flashing the recovery through Terminal on your phone.

    Open it up, make sure you're root, navigate to wherever your recovery.img file is and then type (where recovery.img is your recovery file):

    Code:
    flash_image recovery recovery.img
    and if that works then you're golden (hint to reboot into recovery after that, just type "reboot recovery")

    if not...well either you don't have flash_image on your phone (it's around here somewhere), or your recovery.img file is borked and I'd try re-downloading it.

    Otherwise maybe you messed up your recovery partition...
    what he said but

    su
    flash_image recovery /sdcard/"name of recovery".img
    reboot recovery
    Using VM optimus V
  4. Thread Author  Thread Author    #4  
    RaeFlynne's Avatar

    Posts
    27 Posts
    ROM
    IHO BacksideROM 08/30

    Default Re: Semi bricked? Iunno...

    I tried that as well, actually.

    I got the same error. "Cannot locate directory or file"

    Which was incredibly odd, considering I was IN the directory, looking at the file! XD

    And I've tried a couple different recovery files.
    I'll try a fresh copy of flash_image tomorrow, when I feel like dealing with it.
  5. #5  
    jdcnosse's Avatar

    Posts
    515 Posts
    Global Posts
    516 Global Posts
    ROM
    modified BACKside

    Default

    Quote Originally Posted by camf3xu View Post
    what he said but

    su
    flash_image recovery /sdcard/"name of recovery".img
    reboot recovery
    Haha whoops, guess I forgot to mention that part...thanks!
  6. Thread Author  Thread Author    #6  
    RaeFlynne's Avatar

    Posts
    27 Posts
    ROM
    IHO BacksideROM 08/30

    Default Re: Semi bricked? Iunno...

    Hmm... Curiouser and curiouser...

    It seems that the problem I'm having is with my drivers, but even reinstalling them doesn't seem to do the trick...

    Whenever I try to do anything through ADB fastboot, I get the "Waiting for Device" forever bit.
    Perhaps I'll try again after I restart my computer next...
  7. Thread Author  Thread Author    #7  
    RaeFlynne's Avatar

    Posts
    27 Posts
    ROM
    IHO BacksideROM 08/30

    Default Re: Semi bricked? Iunno...

    ASDF-

    Okay. So I've found a couple different drivers for my phone, but it continues to derp itself forever.

    When I plug it in after installing the drivers, I get the Windows installing drivers window, and I get a list of devices. Six devices, four are unidentified, and two are the LGE Android Platform Composite USB Device, and the USB Mass Storage device.

    These two drivers are marked as "Ready to Use" but the four unidentified devices just sit there and do nothing.
    Argh.
    [EDIT] As soon as I posted this, three of the unidentified drivers installed, but one did not
  8. Thread Author  Thread Author    #8  
    RaeFlynne's Avatar

    Posts
    27 Posts
    ROM
    IHO BacksideROM 08/30

    Default Re: Semi bricked? Iunno...

    Alright. So, it seems that there's a driver missing for "Android" which is what the device is named when in the Fastboot screen.

    Anybody have some helpful advice here? I've got literally no clue at this point, but I feel like if I can just get this driver, I can fix my phone. >_<

    OH. Also, I've found out that what I might need to do is

    fastboot erase recovery

    Then push a new recovery in. I plan to push CWM back in, but at the moment the entire recovery is broken.
  9. Thread Author  Thread Author    #9  
    RaeFlynne's Avatar

    Posts
    27 Posts
    ROM
    IHO BacksideROM 08/30

    Default Re: Semi bricked? Iunno...

    AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA-

    I FIXED IT!

    YES!

    YES!
    *Screams from the highest mountaintop!*

    This entire time, I was trying to run
    flash_image recovery /sdcard/vrecovery.img

    When I REALLY needed to run
    flash_image recovery /mnt/sdcard/vrecovery.img


    YES AAAAAAAAAAAH!

Posting Permissions