1. larrytxeast's Avatar
    I have the LG Optimus V. I have searched here & elsewhere first before posting here.

    The phone mistakenly "sprung back" 1 hour thinking it was daylight savings time, when it reality it's not for another week. I am in the Houston time zone. I have hunted EVERYWHERE trying to see where I can "force-feed" it to the right time, or disable DST etc, I just can't find that option anywhere. I really don't want to hobble around with the wrong time for an entire week with no option to change it. How do I do so?
    10-30-2011 11:19 AM
  2. polyhedral's Avatar
    Hello people.

    I'm having the same problem today, with the same phone and the same carrier.

    There is no options to change time zone or time itself on our phones, to my knowledge at least.
    10-30-2011 12:07 PM
  3. polyhedral's Avatar
    Try rebooting....

    fixed it for myself...
    lmao
    10-30-2011 12:18 PM
  4. miqronaut's Avatar
    My Optimus V on Virgin Mobile did the same thing this morning. It corrected itself at 11am CST (correction: noon CST, 11am LGST).
    hongdb likes this.
    10-30-2011 12:27 PM
  5. RyanJKremer's Avatar
    Ditto on the OptimusV. Made getting the family ready for church a real treat with one hour less to work with.

    The interesting thing is- my weather and time widget had the correct time.

    Sent from my LG-VM670 using Tapatalk. Suckit.
    10-30-2011 12:30 PM
  6. polyhedral's Avatar
    My Optimus V on Virgin Mobile did the same thing this morning. It corrected itself at 11am CST.
    Oh, maybe that was what fixed mine then.
    10-30-2011 12:36 PM
  7. jdcnosse's Avatar
    As far as I know, on froyo you can't change the time, it's set by the carrier. However I did see a spot in the IHO settings to manually set the clock, (at least I thought I did) but I'm not running IHO so someone else will have to confirm this for me.
    10-30-2011 12:44 PM
  8. wagonburner's Avatar
    I had the same problem happen to me too played with the settings and that didn't help but when I rebooted everything went back to normal.
    10-30-2011 12:44 PM
  9. AzraelsKiss's Avatar
    As far as I know, on froyo you can't change the time, it's set by the carrier. However I did see a spot in the IHO settings to manually set the clock, (at least I thought I did) but I'm not running IHO so someone else will have to confirm this for me.
    You are correct... In CM7, you go to:
    Settings > Date & time
    uncheck Automatic, then you can set any date or time you want.

    It's a pitty that the stock ROM doesn't offer this feature considering Sprint doesn't care enough to make sure all their towers are set with the correct DST settings.

    ~Azrael's Kiss~
    10-30-2011 02:17 PM
  10. Two Sense's Avatar
    The interesting thing is- my weather and time widget had the correct time.
    I think that happens because they update from their own time server separate from the phone network. (But don't quote me on that one! lol)
    10-30-2011 05:40 PM
  11. Kelemvor33's Avatar
    So this is interesting. MY Optimus V (Virgin) had the wrong time so I rebooted and it fixed it. Then I just checked my wife's Optimus S (Sprint) and it also had the wrong time so I rebooted it as well.

    I know Virgin uses the Sprint network but it seems strange both would have the wrong time. hmm. I hope it changes next weekend like it's supposed to.
    10-31-2011 07:25 AM
  12. mngl1500's Avatar
    Well fsck me. Mine changed and I use it as my alarm clock and I did not notice on Monday morning.
    10-31-2011 08:56 AM
  13. mjs2011's Avatar
    this whole situation was pretty hilarious, imo.

    there was a half hour window yesterday where i truly did not know what time it really was. i ended up having to call someone to find out.
    10-31-2011 09:07 AM
  14. Anonymo's Avatar
    this whole situation was pretty hilarious, imo.

    there was a half hour window yesterday where i truly did not know what time it really was. i ended up having to call someone to find out.
    I just Google "time"
    10-31-2011 01:37 PM
  15. jdcnosse's Avatar
    Or set something that didn't update and base it off that. Like when I'm traveling across the county I use my iPod to keep track of which time zone I'm in
    10-31-2011 05:49 PM
  16. quackn8r's Avatar
    Rebooting does set the time correctly. That means you have to reboot the phone 4 times a year. twice when the during spring forward and twice when you fall back. Are we saying that LG does not have a firmware update that corrects the DST settings to the correct days in the US? (Thank you United States Government)
    11-03-2011 05:49 PM
  17. jdcnosse's Avatar
    Mine is correct. So it's possible just certain locations have this flaw, or it's possible that only a batch of OVs have the flaw (like those that have the new OV with the OS screen, our those running a VM PRL instead of a Sprint PRL

    @quackn8r neither LG or VM have a way to update our phones once they're out of the factory. The technology isn't there on VM's side and LG borked the update package thing. But it is 2011, and the change to daylight savings time happened in 2007, so this should be fixed.
    11-03-2011 06:12 PM
  18. sperry76's Avatar
    this is second time ive had this problem within 2 weeks. 6 days ahead & 6 hrs behind correct time. last time the turn it off & back on worked. this time NADA!!!! Ive had this phone for 6months & never any trouble til now, except once in while it would freeze up. Im bout ready to throw this phone out in the street.
    12-29-2011 11:45 PM
  19. je2000's Avatar
    Joined this forum specifically for this issue.

    They have not fixed this issue. This is exactly 1 year later, 1 week before DST switchover. Here I am at work. My phone says 5:55 AM. Everyone is asking if I overslept. I have no idea what they're talking about. All clocks at work are saying 6:55 AM. I think it's them screwing with me.

    I watch the phone switch to 6am. 1 second later, I watched it jump 1 hour ahead to 7am, "fixing" itself.

    Thank you Virgin Mobile. I have an Optimus Slider android version 2.3.4.

    Anyone else have this happen again this year? I am in Austin, TX. Normally I would have started a new thread but I think ressurecting this one was more appropriate.
    10-28-2012 07:21 AM
  20. RianaZaire's Avatar
    I had the same problem this morning. Virgin mobile network, LG Optimus Slider. Hasn't changed back on its own yet - getting ready to reboot
    10-28-2012 10:19 AM
  21. adamhos's Avatar
    Isnt dst next week?

    Sent from my LG-VM670 using Android Central Forums
    10-28-2012 11:57 AM
  22. serialrage's Avatar
    My phone did the same thing this morning, wasn't a big deal quick reboot of the phone fixes it.
    10-28-2012 01:21 PM
  23. mmtowns's Avatar
    You are correct... In CM7, you go to:
    Settings > Date & time
    uncheck Automatic, then you can set any date or time you want.

    It's a pitty that the stock ROM doesn't offer this feature considering Sprint doesn't care enough to make sure all their towers are set with the correct DST settings.

    ~Azrael's Kiss~
    I had the same issue and solution (CM7) unchecking automatic. Later, rebooted and it worked on automatic again.
    10-28-2012 03:43 PM
  24. je2000's Avatar
    It's a big deal when you're an hour late because of it. DST changed in 2007, 5 years ago.

    First world problems, I know. Traditional alarm clark bought.

    I didn't need a reboot, I literally watched it correct itself automatically. Though I have the slider, so I don't know how much that matters.
    10-29-2012 08:23 AM
  25. CatyScarlett's Avatar
    But mine doesn't have "automatic", how do i change the time? on my ipod touch i can change it SO easily and whenever i want with no trouble!
    07-05-2013 12:01 AM
LINK TO POST COPIED TO CLIPBOARD