Page 1 of 2 12 LastLast
Results 1 to 25 of 44
  1. Thread Author  Thread Author    #1  

    Default Beta version of Connection Checker - App to 'fix' 3G problem

    The 3G problems on my Optimus V spurred me to write this network monitoring utility; I've named it Connection Checker. Beta testers and feedback are both appreciated.

    Essentially it is a service that runs in the background and actively monitors your network connection. If it detects that your Wifi connection isn't working, it'll turn off Wifi and fall back to mobile connectivity (Wifi is re-enabled after some time). If your mobile connection can't pass data, you get a notification and airplane mode is toggled.

    For the last two weeks I've been running this and had no ill effects on my battery, and have had vastly improved network connectivity. The UI is still a work in progress, but it is getting close.

    Things to note:
    * The log doesn't automatically refresh
    * Does not start on boot
    * The icons are microphones!

    By downloading this software you understand this is experimental software. As the author, I am not liable for any problems resulting from the software's use on your device.

    Initial beta release v1.0.1


    Changelog for v1.0.2


    * Tested on Android 2.1, and it is now installable there
    * Fixed tab icons
    * Log screen now updates when an event happens
    * Added status of service to log page
    * Added more events to the log, and removed toasts
    * Made notifications clear on click and open the log
    * Moved "start on app launch" option to Advanced
    * Added "start on boot" option to start app when booting device
    * Several bugfixes and improvements that are not visible to the user

    The public release is now at v1.0.8


    Market link for the free version:


    Follow this App in the new thread.
    Last edited by Lunacy1134; 05-07-2011 at 01:49 PM. Reason: Update version
    Thanked by:
    ejlmd 
  2. #2  

    Default

    Cool app. Will it be in the android market so it is easier to keep track of updates??

    Sent from my LG Optimus V using Tapatalk
  3. Thread Author  Thread Author    #3  

    Default

    Quote Originally Posted by ebnight View Post
    Cool app. Will it be in the android market so it is easier to keep track of updates??
    Yes - I'm going to put it in the market after doing a little more beta testing.

    Thanks!
  4. #4  
    Takenover83's Avatar

    Posts
    507 Posts
    ROM
    Changes to Often

    Default

    Wifi is re-enabled after some time
    Can you explain this some more? If I have it disabled, will the script re-enable it?
    SugarSync (5GB Cloud) Referral Link. - We each get 500MB extra.
    Guide to Play MP4's from the Cloud. Guide to Free VOIP using Google Voice and Groove IP.
  5. Thread Author  Thread Author    #5  

    Default

    Quote Originally Posted by Takenover83 View Post
    Can you explain this some more? If I have it disabled, will the script re-enable it?
    Wifi will only be re-enabled if ConnectionChecker disabled it.

    I've been considering changing that, and just letting the program re-enable wifi. If I make this change it'll be a configurable option.
  6. #6  

    Default

    Thanks! While my connection lately has been pretty solid I'm still going to test this out. Thanks for your work.


    Sent from my VM670 using Tapatalk
  7. #7  
    Hugh Johnson's Avatar

    Posts
    83 Posts
    ROM
    Aphrodite

    Default

    Sounds like a good idea.

    I'm going to use Startup Manager to launch it at boot.
  8. #8  

    Default

    OK downloaded and running. Questions: if no 3G data, going to airplane mode? Doesn't that stop regular phone and texting from working? I have heard and seen that the battery runs down quickly when searching for 3G-how about just disabling 3G and trying again after a few moments as opposed to airplane mode.
  9. Thread Author  Thread Author    #9  

    Default

    Quote Originally Posted by 1oddmanout View Post
    if no 3G data, going to airplane mode? Doesn't that stop regular phone and texting from working?
    Great Question! I ran into that problem in my very first version. This was fixed by making sure Connection Checker doesn't do anything if you have a phone connection, but do not have a data connection. (they are not the same!)

    I have heard and seen that the battery runs down quickly when searching for 3G-how about just disabling 3G and trying again after a few moments as opposed to airplane mode.
    Well - keep in mind, this program does nothing when "searching for 3G". It only acts when 3G DATA appears up and doesn't work.

    Three things to note:
    • I'm going to make the action on "3G DATA down" configurable. You should be able to specify if it toggles airplane mode, toggles 3G, or just gives a notification.
    • On my phone (Optimus V), just toggling 3G didn't reliably bring my 3G connection back.
    • After two weeks, battery usage has not changed one bit for me, and I run it every minute, not the regular 5 minute default.
  10. #10  

    Default

    Very cool. Thanks for making this.

    Sent from my LG Optimus V using Tapatalk
  11. Thread Author  Thread Author    #11  

    Default

    For those people running ConnectionChecker - Are you seeing fewer network problems? What are your findings and thoughts?

    BTW - Updated version in first post.

    Changelog for v1.0.2

    * Tested on Android 2.1, and it is now installable there
    * Fixed tab icons
    * Log screen now updates when an event happens
    * Added status of service to log page
    * Added more events to the log, and removed toasts
    * Made notifications clear on click and open the log
    * Moved "start on app launch" option to Advanced
    * Added "start on boot" option to start app when booting device
    * Several bugfixes and improvements that are not visible to the user
  12. #12  

    Default

    back at work and 3G down most of afternoon. great reports from the app. i think it helped to restore connections, but battery wore down pretty fast (i really think from trying to find a 3G connection). will turn off 3G tomorrow all day.
  13. #13  

    Default

    Get 404 error on 1.0.2 download. Does 1.0.1 automatically update?
  14. Thread Author  Thread Author    #14  

    Default

    Quote Originally Posted by 1oddmanout View Post
    Get 404 error on 1.0.2 download. Does 1.0.1 automatically update?
    Whoops - I had paused Dropbox so it wasn't uploaded

    All set now!
  15. #15  

    Default

    OK installed 1.0.2. will try it out. thanks for the effort.
  16. Thread Author  Thread Author    #16  

    Default

    Quote Originally Posted by 1oddmanout View Post
    OK installed 1.0.2. will try it out. thanks for the effort.
    Not a problem - I am very appreciative of your feedback!
  17. #17  

    Default

    Every time I open the app the log gets a new entry that says "service started"...isn't is supposed to be running in the background?

    EDIT: I can see the service is running so the log message seems to be erroneous. Should be "service already running" perhaps?
  18. Thread Author  Thread Author    #18  

    Default

    Quote Originally Posted by Bigtuna00 View Post
    Every time I open the app the log gets a new entry that says "service started"...isn't is supposed to be running in the background?
    Good catch! This was a bug in v1.0.1, that was fixed in v1.0.2.

    The service is running in the background, but when launching the app the service was created again. Don't worry, only one service is actually running. To address this in v1.0.2 the service is only started when launching the app if it isn't already running.

    If you can, try v1.0.2, hopefully that fixes the issue for you.
  19. #19  

    Default

    Quote Originally Posted by Lunacy1134 View Post
    Good catch! This was a bug in v1.0.1, that was fixed in v1.0.2.

    The service is running in the background, but when launching the app the service was created again. Don't worry, only one service is actually running. To address this in v1.0.2 the service is only started when launching the app if it isn't already running.

    If you can, try v1.0.2, hopefully that fixes the issue for you.
    I'm actually running v1.0.2, I never installed 1.0.1.

    (also you might want to reorganize the first post a bit, put the newest updates first, not last)
  20. Thread Author  Thread Author    #20  

    Default

    Quote Originally Posted by Bigtuna00 View Post
    I'm actually running v1.0.2, I never installed 1.0.1.

    (also you might want to reorganize the first post a bit, put the newest updates first, not last)
    OK! I think the problem is in the way I'm keeping track of if the service is running. I'll have to switch it to grabbing it from the process tree. What I'm seeing is that the first time running the app after a long time, it'll think the service isn't running and try to restart. But if I open/close the application the "Starting service" log message doesn't keep showing up.

    Regarding the first post - Yeah, it is a mess, I'll clean it up at some point.
  21. #21  

    Default

    Quote Originally Posted by Lunacy1134 View Post
    But if I open/close the application the "Starting service" log message doesn't keep showing up.
    Weird. I just opened and closed the app 3 times, 2 seconds apart. I get 3 new log entries. To be clear when I say Open I'm clicking on a Homescreen icon and when I say close I'm using the Back button.

    This is all on a stock Optimus V.
  22. Thread Author  Thread Author    #22  

    Default

    Quote Originally Posted by Bigtuna00 View Post
    Weird. I just opened and closed the app 3 times, 2 seconds apart. I get 3 new log entries. To be clear when I say Open I'm clicking on a Homescreen icon and when I say close I'm using the Back button.

    This is all on a stock Optimus V.
    Yeah - That is what I'm doing as well. I just tried it on a 2.2 emulator so I don't think that is the issue. Do you have this "Service Running" text on your screen, like in this screenshot?

  23. #23  

    Default

    Quote Originally Posted by Lunacy1134 View Post
    Yeah - That is what I'm doing as well. I just tried it on a 2.2 emulator so I don't think that is the issue. Do you have this "Service Running" text on your screen, like in this screenshot?
    No I do not. I just double-checked Settings | Applications and it definitely says version 1.0.2 too.
  24. #24  

    Default

    Any chance this will be updated or is it secretly a back-door and you're collecting all my personal info?

    (the second part was a joke! )
  25. #25  

    Default No More Data Problems

    If you all want to stop you data problems ,call Virgin Mobile when they answer let them know you have called before and they have tried everything. Ask to speak to a "Live Adviser" tell them you have purchased an Lg Optimus ANDROID phone and have had problem surffing the web.Virgin has never had an android phone and there is code on sprint to set to android 3g. All other phone at Virgin Mobile are not android. Mine has not drop data while in service area for over one month since done. Hope this helps ??
Page 1 of 2 12 LastLast

Posting Permissions

B