1. preppystud's Avatar
    when i use the optical mouse, sometimes the light in the usb mouse will suddenly disappear. then i won't be able to use the mouse again even after plug it in the usb port again.

    at first, i thought that maybe my optical mouse is an old one, so it may not be compatible with the chromebook.

    then i tried it with another optical mouse, when i plug it in, it still doesn't show the light under the mouse. it will work if i restart the chromebook.

    one time, i unplugged the usb mouse, then plugged it in again. it stopped working. it doesn't happen all the time though.

    after i restart the chromebook, the mouse will work again. it has happened probably everyday when i use it.

    today, i tried to plug in a usb external hard drive, after the mouse stopped working, somehow the chromebook can still recognize the external hard drive.

    this is a refurbished chromebook. is there something wrong with this usb port? i already updated the chromebook to the latest version.
    03-30-2021 03:15 AM
  2. B. Diddy's Avatar
    Do you have a USB-C to USB-A adapter? If so, try plugging the mouse into the USB-C port and see if the problem still happens.
    03-30-2021 11:22 AM
  3. preppystud's Avatar
    i am now using another mouse, i haven't had any problems so far. so i am guessing that it is that particular mouse's problem. when i used it with the chromebook, it stops working daily.
    04-01-2021 01:32 PM
  4. B. Diddy's Avatar
    What brand and model is the problematic mouse? If it's really old, there might be some incompatibility.
    04-01-2021 06:15 PM
  5. preppystud's Avatar
    microsoft comfort optical mouse 3000. it has this extra magnifier function. maybe that is why it is causing the problem.

    i tried to plug it in again, it instantly destroyed the usb port. because when i plug in the other optical mouse that i was using, it also stopped working. then i had to restart again.

    somehow this mouse caused the chromebook system to malfunction?
    04-02-2021 12:34 AM
  6. B. Diddy's Avatar
    I looked it up -- that's a sixteen year old device! Whatever's happening, it probably has to do with incompatibility, so I'd rely on some other mouse.
    04-02-2021 12:42 AM

Similar Threads

  1. Forgot my sd card on my phone
    By Benjamin Marchand in forum Ask a Question
    Replies: 13
    Last Post: 04-01-2021, 07:19 AM
  2. Pixel deals in the UK
    By Kizzy Catwoman in forum General News & Discussion
    Replies: 2
    Last Post: 03-31-2021, 09:17 PM
  3. Phone vibrates on resuming and entering lock mode
    By ameneses54 in forum General Help and How To
    Replies: 5
    Last Post: 03-31-2021, 10:34 AM
  4. Facebook app and Play services using data while on WiFi?
    By mitcha14 in forum General Help and How To
    Replies: 2
    Last Post: 03-28-2021, 10:24 PM
  5. Replies: 0
    Last Post: 03-28-2021, 01:56 PM