1. Forgewizard's Avatar
    Was tickled pink when I successfully replaced my fractured LCD screen. Started taking the table back to work again. Forgot to charge it one night, figured, no big deal, I'd pick up a spare charger for the office from Radio Shack. They've been instrumental in finding MANY aftermarket/replacement chargers for a multitude of my electronic devices ( I'm a gadget freak).

    The sales "tech" rep tried multiple adapters but couldn't find exactly the right one. She found one that slipped into the A/C dock port, but was a snidge loose. Plugged in the other end and the device did NOT register it was charging. I didn't think anything of it - just decided I needed to order a charger online. Turned off the A100, went to work.

    Got home plugged in MY charger - device did not register a charge! What? Turned it on. Plugged it in, *blink* it went black! grrr. Thought maybe my charger was no good. Ordered 2 from online. Waited a week. tied both of them. *blink* the device goes black every time it gets a charger plugged in!

    Figured girl had burned out my A/C port. Ordered one. Waited a week for it to arrive. Installed it. Plugged in charger. *Blink* its black again! Dug online for any other folks reporting similar trouble. Only thing close was for those that weren't registering a charger at all. Their solution was to unplug and replug the battery. Did that. Still doesn't charge.

    Battery is at 33% charge. AM not able to use device. Already tried a factory reset - which stinks because now I will have to re-enter all my apps & data of course that weren't stored on the sd card.

    Is there some internal fuse on the battery that may have been fried by an incorrect adapter being plugged in? Is this fuse user accessible by any chance? has anyone else with anAcer A100 experienced a similar problem?

    For the time being I have ordered an Acer Docking station which is supposed to charge through the 40 pin connector. Is there a 40 pin connector charger available? Does anyone with lots more experience know if the 40 pin connector is proprietary to Acer or generic? If the docking station doesn't work, all I can do next is try a new battery. If that doesn't work I don't know what else to do, do you?

    Contact with Acer wasn't much help. Of course they had me do afactory reset - which I already have done once, now twice - once via software, once via the reset pinhole. Since that didn't work they said only recourse would be to send the device in, but before I send it I need to prepay for the diagnostics and repair to the tune of 200.00! WHAT? I can buy a brand new Samsung device for LESS than 200.00! Hopefully the docking station will work and if it doesn't then the battery is suspect. geez! 200.00 UP FRONT! IThe device didn't cost that brand new! And ecologists wonder why we have become a disposable society!
    05-19-2013 10:15 PM
  2. Forgewizard's Avatar
    This has been a roller coaster ride! Replaced the a/c docking jack port. Didn't fix issue. Purchased a docking station. Didn't fix issue. Touched base with our friends at XDA forums, suggestion made to disconnect battery, connect charger and see if device works. That would isolate battery issue from charging circuit issue. Device worked with battery connected, did NOT work when battery was disconnected but charger was plugged in. did not work from charging port or docking station with battery removed. This behavior indicated a bad charging circuit on the mother board.

    Replaced motherboard. Plug in charger and have begun experiencing erratic charging led indications and behavior. A100 starts only if plugged in, then will show 3% battery charging LED blinks orange. Turn off device while plugged in, disconnect then reconnect charger and device begins accepting charge. LED solid orange.Left it alone overnight. LED is blue in morning. Battery indicates 100%. Disconnect from charger. Turn off device but it will not restart unless it is plugged in to charger! Plugged it back in, got the device to connect and upgrade to ICS (apparently was an older original motherboard). Shut down, turned back on several times during upgrade process. Remained plugged in as instructed. When upgrade successful message showed I disconnected charger and device showed 100% battery , then a few seconds later went to 0% and a beep sounded. Put A100 on docking station, LED is blinking orange again, battery icon says charging - well at least the lightning bolt is there. Any ideas from any corner?
    05-24-2013 11:06 AM
  3. Forgewizard's Avatar
    Our friends at XDA proboards forum helped too. Replacement motherboard was defective, vendor authorized return and replacement. Installed, reassembled and voila! Acer A100 is alive again!

    Sent from my A100 using AC Forums mobile app
    06-13-2013 10:08 AM

Similar Threads

  1. Replies: 11
    Last Post: 12-25-2014, 05:58 PM
  2. Pandora (Data?) Shuts off When Screen is Off
    By Eddog4DROID in forum AT&T Samsung Infuse
    Replies: 2
    Last Post: 06-01-2011, 05:47 PM
  3. wifi not working when bluetooth is connected
    By mrbro0ks in forum AT&T Inspire 4G
    Replies: 0
    Last Post: 05-17-2011, 06:07 PM
  4. 3G stays active when Wifi is connected
    By drewmg in forum Motorola Droid X
    Replies: 23
    Last Post: 11-06-2010, 06:47 AM
  5. When charger is plugged in...
    By chriscoleman in forum Motorola Droid 2
    Replies: 4
    Last Post: 08-14-2010, 08:30 PM