1. str8outahbg's Avatar
    Hey guys i just bought this new tablet and it is password protected so it requires a hard reset to be able to use it. Ive tried that step and it keeps giving me an android logo with
    12-16-2011 09:01 PM
  2. scarryman04's Avatar
    if its new return it and get a new one
    12-16-2011 11:30 PM
  3. jhowle9475's Avatar
    That's what I would do,, it obviously is used and someone obviously returned it.
    12-25-2011 10:12 AM
  4. Moscow Desire's Avatar
    When you do a hard reset it can sometimes take 10 or 15 minutes to re-install the software.

    Sorry OP, but your original post looked incomplete, so am not quite sure what you were going to add.

    But like the others say, return it for an exchange, unless you bought it off e-bay or Amazon. That might take awhile. Or if it's a non-returnable item.

    In the chance somebody did indeed own it, and tried "modding it", you can, with pwr off, hold vol- and press and hold PWR. After several seconds, you may see some text in the upper right corner, then release both buttons. This should boot into a custom recovery menu. If it does, then indeed it is a pre-owned device that somebody tried installing custom software on.
    12-25-2011 10:45 AM
  5. Dustin Goodale's Avatar
    I have a Acer a500 and game froze up so I shut it off and turned back on and now it's staying on the Acer screen or Android screen, tried recovery mode but it gives me Android man with red caution symbol, what can I do. Plz email me at Dgoodale88@Yahoo.com thanx
    07-05-2013 01:42 PM
  6. eshone's Avatar
    I'm having this exact same problem. Is there a tech-savvier person out there who might be able to me out?

    08-16-2013 01:42 PM