1. steve kim's Avatar
    I accidentally deleted rom on my kindle fire. From TWRP screen, when I attempt to reboot the system it says, "No OS Installed!". Anyone brick their kindle this way? Is there any way I can fix this problem?
    12-05-2012 12:30 AM
  2. muiriddin's Avatar
    You probably posted this in the wrong section, since I don't think the Kindle Fire HD's or the Kindle Fire 2 are running TWRP yet. Can you confirm that you are using the original kindle fire and not one of the three new ones that were just released?

    If you do have the original kindle fire and it already has TWRP and FIRE FIRE FIRE on it all you need to do is download the rom you formerly had on your system, and the proper google applications for that rom and then flash them onto the device. The TWRP recovery software does have the ability to mount your device to a computer so once you've downloaded the rom and gapps you can simply copy it to the device (after checking the downloads with the md5 sum), do a factory reset, wipe the system, cache and dalvik and then install the rom followed by the gapps and reboot. Be careful and make a backup if you still have any important data on the tablet!

    I have an original kindle fire running hashcode's rom which has been very stable and the only thing that doesn't work is the location capability (which for that tablet isn't important to me).
    [ROM-AOSP] Stock Jelly Bean 4.1.2_r1 for the Kindle Fire [10-10] - xda-developers

    If you have further questions or need more detail I can potentially do that when I'm home and have the table in front of me.
    12-07-2012 07:54 AM
  3. Cidergirl's Avatar
    Do you know why suddenly my 9 month old Kindle Fire ( purchased in the States ) won't boot up ? I swipe the ornage arrow but no response and thescreen just fades. I've tried fully charging it but no luck. this is probably a very basic query to you so I'm hoping you can help as I use this for me e-mails etc. when I travel. Thanks.
    12-08-2012 06:14 AM
  4. muiriddin's Avatar
    Have you tried rebooting it? If you hold the power button for a long time it should power down. Then you can power it back up and see if that allows you to then log in to your fire.
    12-10-2012 03:19 PM
  5. Quysngoc Pham's Avatar
    Need help !
    I've completely wiped my Kindle Fire (used TWRP) but without backup! So now I could not put any file to install a new OS. Please help me to solve it !! Great tks !
    04-24-2013 12:39 AM
  6. Quysngoc Pham's Avatar
    Haha, connect KF to PC then use Mount in TWRP can copy files (from [ROM-AOSP] Stock Jelly Bean 4.2.2_r1 for the Kindle Fire [02-12 4.2.2_r1] - xda-developers ) and install the newest version!!! Haha LOVE TECHNOLOGY AND YOUR INTRODUCTION !!!! Have a good time !!!
    05-03-2013 05:53 AM
  7. dvinzant's Avatar
    If you get stuck like that again we have a free tool at the bottom of our website that will restore your Kindle Fire back to factory condition again. All you need is Fastboot or TWRP installed and our software download the proper rom and takes it from there. You can find our free software at the bottom of our website. You can find our website by googling n2aos. Did I mention it was free? :-)

    Dave V
    06-25-2013 02:03 AM
  8. KenKK's Avatar

    I am trying to help a friend out with his kindle. When he powers up I get teh "kindlefire" (fire is orange) then he gets a message
    "Provisioning Fail"

    You mentioned something about a program that would let in restore or similar being at the bottom of the page.
    I could not find it. Could you offer more info so I can help my friend.

    06-25-2013 11:33 AM
  9. KenKK's Avatar
    I see my mistake on the location now. I did the google and found the free program but it appears
    not to be for the kindle fire HD.

    are there anyways to restore the kindle fire HD?

    thanks all

    06-25-2013 12:26 PM
  10. dvinzant's Avatar
    Sorry Ken, I did not know you needed one for the HD. At the moment our r2s does not recognize the HD models but that will change within a week or two.

    edit: and also just realized I was in the HD forums. I'll make sure to update this thread when the software is ready.
    06-26-2013 10:15 PM
  11. misssure's Avatar
    I'm trying to fix my friend's child's Kindle Fire. It started off with pressing a letter and it would input another key instead. Now it will turn on but it is stuck on the main swipe screen. Needless to say who know WHAT this child has viewed or DL'd on her Kindle. I've already tried the hard reboot (holding down the button) for 20 sec but still nothing. Trying to help my crazy broke friend, thanks!
    08-07-2013 08:56 AM
  12. dvinzant's Avatar
    Head on over to n2aos.com and click on our live help. We can get you going again.

    Also, for everyone else, we've now launched N2Aos for the Kindle Fire HD 7" and 8.9"

    The Restore2Stock application (bottom of homepage) has been updated to include the HD models as well.
    08-09-2013 12:49 AM
  13. Zack Tomphson's Avatar
    Can u show a video of how to recover a deleted rom? Please and thank u

    - - - Updated - - -

    Can u show a video of how to recover a deleted rom? Please and thank u
    10-01-2013 11:47 PM
  14. Terry Walley's Avatar
    I accidentally deleted my my rom when i was flashing a recovery. I have twrp installed. The problem is i cant get my computer to recognize the Kindle to put a rom on the sd. i see kindle in the device manager but when i try to install a driver windows cant find one. so when i mount twrp it doesnt show on my com. thanks for the help if you can give any
    10-18-2013 02:38 PM

Similar Threads

  1. Nexus S will not boot up.
    By Gilroid in forum T-Mobile Nexus S
    Replies: 5
    Last Post: 08-17-2012, 10:30 AM
  2. Phone will not boot up, please help me!
    By OnlyPatty in forum LG Optimus S
    Replies: 9
    Last Post: 11-20-2011, 02:21 PM
  3. Evo Will Not Boot Up!! AT ALL!!
    By blutuu in forum HTC EVO 4G
    Replies: 8
    Last Post: 03-04-2011, 01:13 AM
  4. Will not boot past motorola trademark
    By Mr.Miagi in forum Motorola Droid Rooting, ROMs and Hacks
    Replies: 8
    Last Post: 04-21-2010, 03:06 AM
  5. Droid become nonresponsive, will not boot
    By j7469 in forum Motorola Droid
    Replies: 5
    Last Post: 01-04-2010, 09:53 PM