1. fixedit's Avatar
    My Fire was fine one evening and then stuck in the loop that says "Kindle Fire" and wouldn't do anything else the next morning. I tried charging the Fire, no change. I let it completely die and recharged, still no change. Then I read somewhere (that I can't find again) to let the Fire completely run out of charge, then charge it through your computer instead of a wall outlet. I plugged it into my laptop and about five hours later it suddenly turned on by itself, but with only 2% charge. I then plugged it into the wall outlet and let it finish charging. It has worked fine for a few days now. I hope this helps someone else... BTW, that was the first time I had connected the fire to any computer.
    02-15-2015 11:52 AM

Similar Threads

  1. Replies: 1
    Last Post: 02-15-2015, 11:38 PM
  2. Replies: 1
    Last Post: 02-15-2015, 11:36 PM
  3. Why isn't my Sim card being detected on my Lenovo s850?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 02-15-2015, 02:33 PM
  4. Replies: 1
    Last Post: 02-15-2015, 08:22 AM
LINK TO POST COPIED TO CLIPBOARD