1. names_are_useless's Avatar
    So I recently got an Amazon Fire 7" Tablet during the Amazon Summer Sale (only $50!). After buying it, I didn't realize it came with the awful FireOS version of Android. I want Android on there, but I've found there's a lot of steps behind it.

    In order to do this, I'm told I need to root my Android and use the CyanogenMod. Well, I seem to be unable to root my tablet.

    Here is what I've done so far:
    1. I've been following the steps in this Youtube video:


    I've been able to follow this video up to 5:49 (I have open-gapps, cm-12.1 and SuperSU on an SD card on my fire tablet). Now the Amazon Fire Tablet Tool I have has different options then the one in the video:

    There is no TWRP option. According to this site, I need to have my Amazon Fire rooted. So next ...

    2. I go to option 6 to root my tablet. Now initially, my Tablet was v5.3.1, but after following this video:

    I've been able to downgrade Amazon to 5.1.2. And so I select 5.1.2 and have Kingroot installed on my tablet.

    3. Now that Kingroot is on the tablet, I've tried it several times ... and to no success. It keeps coming up with the message "try the desktop version." And so I've gone to install the desktop version ... which only a Chinese version seems to exist (Kingroot v3.2).

    4. So I have the tablet hooked up to my PC, and run the Kingroot application. It looks to recognize the tablet connected to the PC ... but after several tries, it will stop with a QR Code appearing:


    5. I've scanned the QR code with my tablet (I guess that's what Kingroot wants me to do?), and I get the following URL: http://weixin.qq.com/q/mnXlDiblNFtNkgiYUVu-

    Its a blank page, and my tablet still isn't rooted (FlashFire application, which the s-config site says I will need to run, needs root access in order to install CyanogenMod). If anyone here could help me, please do. Maybe just someone who can read Chinese ...
    08-07-2016 08:04 AM
  2. Golfdriver97's Avatar
    Welcome to the forums. Watching the YT video now.

    Edit: If you select option #4, does that reboot you to TWRP?
    08-07-2016 08:27 AM
  3. names_are_useless's Avatar
    Welcome to the forums. Watching the YT video now.

    Edit: If you select option #4, does that reboot you to TWRP?
    Thank you for answering, and sorry for the late reply, was on vacation and getting back to this now.

    So clicking option 4 in Amazon Fire Tablet Tool, and then option 1 to Boot to TWRP, I see the following on my tablet:
    Code:
    => FASTBOOT mode...
    And I see the following in the Amazon Fire Tablet Tool:
    Code:
    NOTE this will not work unless your fastboot drivers are installed
    [*] see option 1 ADB Driver install.
    [*] Once the screen is black and says fastboot in the corner
    [*] press any key to continue the script.
    Then I click to execute the script, but receive the following:
    Code:
    downloading 'boot.img'...
    OKAY [  0.262s]
    booting...
    FAILED (remote: unknown command)
    finished. total time: 0.278s
    --------------------------------------------------------------------------------
    [*] TWRP Recovery is booting please wait.
    --------------------------------------------------------------------------------
    Press any key to continue . . .
    Then back on the tablet screen I see this frozen on the screen:
    Code:
    USB Transferring...
    USB Transmission OK   Time: 251ms   Vel:31511KB/s
    And in Amazon Fire Tablet Tool, it has restarted. For my Fire Tablet, I had to do a hard restart since nothing was happening.

    What should I be doing next? Kingroot still coming back with the same message as in the OP.
    08-19-2016 04:46 PM
  4. names_are_useless's Avatar
    Actually, scratch the above post: my tablet went back to version 5.3.1 (an obvious reason as to why TWRP isn't working), and I tried to ADB sideload the older version of Fire OS ... but it bricked this time. I have to send it back to Amazon and get a replacement.

    Any idea why sideloading the same .bin file (fire-OS-5.1.2-update-kindle-global-37.5.4.2_user_542168620.bin) would cause it to brick, when before it was fine?
    08-19-2016 06:24 PM

Similar Threads

  1. Replies: 6
    Last Post: 08-20-2016, 06:26 PM
  2. Replies: 0
    Last Post: 08-07-2016, 02:31 AM
  3. I need help removing pictures on songs in the audio files
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 08-06-2016, 11:34 PM
  4. Replies: 1
    Last Post: 08-06-2016, 11:16 PM
  5. What app is needed to play stored music
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 08-06-2016, 07:26 PM
LINK TO POST COPIED TO CLIPBOARD