1. imnevergoingtousethis's Avatar
    I tried installing a different launcher (GO LauncherEX) and my fire froze up and showed nothing but a black screen after i had changed GO Launcher to the preferred launcher. I held the power button, shut down my kindle, but after turning it back on, I never get past the sparkling 'kindle fire' text.My computer doesnt recognize it as any device so i cant re-install the OS. I have no idea what to do . Suggestions?
    11-23-2011 04:34 PM
  2. WillysJeepMan's Avatar
    That happened to me too. What version did you install? I accidentally installed an old version (1.3 or 1.6... can't remember). 2.51 is the latest version in the Amazon App Store.

    When you attach the Fire to a PC, does it appear as a drive letter? If not, then it might be toast. If you get a drive letter, then you may need to do what I had to do... (on my PC) install Java JDK, Android SDK (w/USB driver package), and use ADB to remotely delete the .apk for launcher. I'll dig out the link that I used....

    I followed the instructions here to root the device: http://reviewhorizon.com/2011/11/how...eloading-apps/

    ...then I used adb to delete the file.

    I feel for ya man. I had the Fire exactly 2 days when it happened... I thought it was destined for the brickyard.
    11-23-2011 08:16 PM
  3. imnevergoingtousethis's Avatar
    I had planned on rooting my device but ran into problems getting my kindle to use the correct driver. My device never showed up under my adb devices, so i tried to manually direct it to the right driver (adb_usb.ini), but every time I try XP tells me that it has nothing to do with my hardware and doesnt give me the option to run it anyways.After my failure I tried downloading a launcher directly from my device, and had the problem. I cant access any part of my kindle without this. Anyone have any ideas?
    11-23-2011 10:10 PM
  4. WillysJeepMan's Avatar
    Visit the link that I posted. It will show you which files to update to get the Fire recognized in XP. I had the same problem and that link helped resolve it.
    11-23-2011 10:22 PM
  5. imnevergoingtousethis's Avatar
    I downloaded the google usb driver already. not sure if that was what you were referring to...
    11-23-2011 10:57 PM
  6. Kuroth's Avatar
    This Link below was the best video I found on how to do all this and it worked great.. I had never rooted anything in my life but once I found this I did it.. Its a little long but worth watching if your not really sure what your doing like I was..

    [v2] How to Root the Kindle Fire and Install the Android Market (PC Version) - YouTube
    11-24-2011 10:22 AM
  7. imnevergoingtousethis's Avatar
    How did you remotely delete the file using adb? I was able to correctly install the driver but now i cant figure out how to uninstall the golauncher file.
    11-24-2011 07:01 PM
  8. stoneworrior's Avatar
    Edit: Sorry I just re read the post. Are you still stuck on the boot screen? If so ignore the following and please verify. Future help will require a little more detail so sorry if someone doesn't get back to you tonight. I myself am about to dive into Thanksgiving dinner and half a case of beer so between the Tryptophan and hops I may not be viable for the next 12 hours or so.

    How did you remotely delete the file using adb? I was able to correctly install the driver but now i cant figure out how to uninstall the golauncher file.
    If you are having a hard time finding it in the GUI you can use terminal emulator. But first try and use Root explorer and look under Data. If you cannot find it Use terminal emulator https://market.android.com/details?i...cm9pZHRlcm0iXQ..

    Open Terminal and type su enter, next type ls enter, here you should see a list, in this list menu one of them should be data. Type cd data enter. Now type ls enter. Now in this menu one of them should read app. Now type cd app enter. Now type ls enter this should have a list of the non system applications.
    In this list about 1/3 of the way down you should find the go launcher apk, this is how it reads...


    as long as you can find it in this file the next thing is to type

    rm com.gau.go.launcherex-1.apk then hit enter.

    This should removed the apk from the Fire although you may need to manually remove the icon from the app drawer. If this makes your head swim then don't try it you may really mess something up but if you are good at following directions this will do it.
    11-24-2011 08:20 PM
  9. imnevergoingtousethis's Avatar
    If my kindle would get past the boot screen then this would be fantastic!
    11-24-2011 08:47 PM
  10. stoneworrior's Avatar
    If my kindle would get past the boot screen then this would be fantastic!
    Give this a try....


    Sent from my Kindle Fire using Tapatalk
    11-25-2011 12:48 AM
  11. lucky1379's Avatar
    I installed go launcher ex on my kindle and now it won't go past the booting that says kindle fire. Anyone know how to fix? My computer will not install the driver either
    11-30-2011 10:42 AM
  12. lucky1379's Avatar
    was wondering if you knew how to get my kindle out of boot screen that flashes kindle fire? I downloaded go launcher ex and now it won't do anything
    11-30-2011 10:48 AM
  13. nando209jsd's Avatar
    ineed help my kidle f i stuck to bu myn hpend wen i was trying to root it can some une helpp me plees
    05-29-2012 09:28 PM
  14. neutopian's Avatar
    For what it's worth, I had this happen and was able to recover, without going back to factory state, by playing with the Kindle Fire Utility..

    [Root][TWRP][FFF][CWM]Kindle Fire Utility v0.9.6 (5/09/12) - xda-developers

    I had deleted launcher.apk, oops, big mistake. My computer couldn't recognize it, and the utility couldn't either.. But it turns out that there is a tiny moment in the boot-loop where the tool can talk to the Kindle, and after a whole lot of attempting to reset the boot state and unplugging/plugging the usb cable, the Kindle booted into a state where ADB got the softkey bar to load, from there I could launch Favorites, from there I was able to get to the Play store, from there I got to Titanium Backup and restored the missing launcher.apk..

    And all was well! Your mileage may vary, I never want to experience this again.
    12-08-2012 07:31 PM