1. giggalz41's Avatar
    got my fire on christmas...i did initially have troubles getting it connected to our home wifi ...once i finally did i had no troubles until yesterday...anytime the screen is shut off my wifi is disconnected...every so often it wont connect until i reset it...it never did this until yesterday...anyone else having this issue??? i dont know if this is related or not...but the last two nights i believe i was using my fire while my laptop was up and running..to come back with an alert saying that my ip address was being used elsewhere as well..could this be connected with the fire???
    12-28-2011 03:56 PM
  2. GSDer's Avatar
    Well, you haven't provided enough information to help figure out what's really going on, so I have more questions than answers. But perhaps something will ring a bell and steer you in the right direction.
    1. You don't mention if you were the one that set up your router - if so, you'd know whether you have DHCP enabled for the clients or if you assigned static IP addresses for them.
    2. Even if you enabled DHCP, if you didn't allow a large enough pool of addresses, your devices would end up fighting for the available ones - basically, whichever device happened to be turned on first that day would get the available address. If you put it to sleep it would think it had address 'A' but meanwhile you turn on a different device and the router assigns address 'A' to it.
    3. You don't mention what the problem was when you originally set up the Kindle - that problem may not really be solved.
    Sorry to seem obtuse, but it can be rather complicated, so it's hard to tell where to start in helping solve your problem.

    Sent from my Sinclair ZX-80 using Tapatalk
    12-29-2011 01:14 AM
  3. jfitzy88's Avatar
    I had the same problem and it started yesterday and only in the morning at that.

    But this. . .
    2. Even if you enabled DHCP, if you didn't allow a large enough pool of addresses, your devices would end up fighting for the available ones - basically, whichever device happened to be turned on first that day would get the available address. If you put it to sleep it would think it had address 'A' but meanwhile you turn on a different device and the router assigns address 'A' to it.
    . . .seems logical too.
    12-29-2011 02:25 AM
  4. giggalz41's Avatar
    maybe but i guess i didnt know anyone needed all of that....when i got it and tried starting up it said it couldnt read the ip address or connect...it finally did...after a few tries..i had to reset the router...i was chatting with the company last night..either he didnt understand my question or i didnt say it correctly...someone mentioned that there can only be 5 connections on our router...which is what i asked...they said up to 32....we dont have that many..but if we are all connected via cell phone laptops kindles and tablets..various times of the day...its about maybe 10 or so if all connected at once...but not 32....we arent on static ip..i asked about that..he wasnt totally clear and i asked if it would help me..he said no...i left it at that..he probably had no clue what a kindle fire actually was..we are the ones that set up the router.. which was a year ago ..last christmas....we had some problems...and so we were on the phone a lot with them..and i finally got more help the last phone call made to them...we had to do some tweaking manually with the setup...not sure why...


    Well, you haven't provided enough information to help figure out what's really going on, so I have more questions than answers. But perhaps something will ring a bell and steer you in the right direction.
    1. You don't mention if you were the one that set up your router - if so, you'd know whether you have DHCP enabled for the clients or if you assigned static IP addresses for them.
    2. Even if you enabled DHCP, if you didn't allow a large enough pool of addresses, your devices would end up fighting for the available ones - basically, whichever device happened to be turned on first that day would get the available address. If you put it to sleep it would think it had address 'A' but meanwhile you turn on a different device and the router assigns address 'A' to it.
    3. You don't mention what the problem was when you originally set up the Kindle - that problem may not really be solved.
    Sorry to seem obtuse, but it can be rather complicated, so it's hard to tell where to start in helping solve your problem.

    Sent from my Sinclair ZX-80 using Tapatalk
    12-29-2011 01:28 PM
  5. GSDer's Avatar
    Well, it would be very strange if your router only supported 5 wireless clients. It may only have a small number of wired LAN ports on the back, but most routers made in the last few years will support a large number of wireless clients. However, the more clients you have connected at the same time, the less bandwidth each one has, so the slower they'd all be.
    10 devices total shouldn't be a problem assuming that they're not always all on at the same time.
    This isn't meant to be a long term solution, but the darn security settings can often cause problems, particularly when certain devices only support specific settings. A good test (and only a test) would be to:
    1. reset the router to factory configuration
    2. Enable wireless, but do not set up WEP or WPA (leave it Open)
    3. Fire up all the wireless devices and see if they can all connect to the router (play with them a bit to see what the network speed is like)
    4. If that all worked, pick the least common denominator for band/security (for example, a Nintendo DS might only support Wireless G, and only WPA)
    5. Re-enable the simplest security and start adding all the devices back one-at-a-time
    If that works you can shoot for a higher level of security (WPA2 for example) and see what kind of luck you have.
    Hope some of this makes sense and helps.

    Sent from my Sinclair ZX-80 using Tapatalk
    12-30-2011 12:52 AM
  6. giggalz41's Avatar
    no all 10 wouldnt be at once..

    i chatted with amazon..they had no clue...(i was quite upset after my first phone call with them telling me this is suppose to happen)...the guy i chatted with online seemed willing to help but had no idea what the issue is...no one else that i know received this has this issue..its almost 3am..i will have to carefully read your reply and try..i've read it a few times and kinda get confused with turning on and off different devices...i updated the firmware last night...and changed the SSID name..i had no clue it would change everything and all of us who use it would have to connect to something totally different...BUT i do remember the guy on amazon asking me if i had WPA or WEP ...i have wpa....i'm a little afraid of messing with to much..we had major problems getting it connected and staying connected for the first month we got wifi...

    i'm sure none of this had any point...and i know it doesnt answer anything that you've told me to do..lol but i'm acknowledging that i've read it at least...

    Well, it would be very strange if your router only supported 5 wireless clients. It may only have a small number of wired LAN ports on the back, but most routers made in the last few years will support a large number of wireless clients. However, the more clients you have connected at the same time, the less bandwidth each one has, so the slower they'd all be.
    10 devices total shouldn't be a problem assuming that they're not always all on at the same time.
    This isn't meant to be a long term solution, but the darn security settings can often cause problems, particularly when certain devices only support specific settings. A good test (and only a test) would be to:
    1. reset the router to factory configuration
    2. Enable wireless, but do not set up WEP or WPA (leave it Open)
    3. Fire up all the wireless devices and see if they can all connect to the router (play with them a bit to see what the network speed is like)
    4. If that all worked, pick the least common denominator for band/security (for example, a Nintendo DS might only support Wireless G, and only WPA)
    5. Re-enable the simplest security and start adding all the devices back one-at-a-time
    If that works you can shoot for a higher level of security (WPA2 for example) and see what kind of luck you have.
    Hope some of this makes sense and helps.

    Sent from my Sinclair ZX-80 using Tapatalk
    12-30-2011 02:51 AM
  7. edwelch4's Avatar
    @giggalz
    I am having the same issue as my fires will lose connection to the router and then will not reconnect until I reset the router...I have other WIFI enabled devices and do not have this issue ...only on the Fires. I run Uverse and have the 2Wire router.

    Did you happen to resolve this issue?
    01-06-2012 08:50 AM
  8. sblood86's Avatar
    Haven't had any issues myself but I have a thought...

    The IP conflict is almost certainly the issue, when you reset the router the IP pool is reset as well. Pretty much all routers have a default config to use DHCP and they will set a IP range of over 200 addresses.
    Unless you have changed the router settings I'm leaning towards yourPC as the cause.

    The static IP that your ISP said you did not have was the wan or internet IP. The laptop could still be connecting with a static IP.

    Two options to try to check that assuming you are in windows.

    The first is to go to the control panel and pull up your wireless network connection status window. There is an option in status on one of the 2 tabs, should say details. You will be able to see if DHCP is enabled.

    The shortcut is to just reset the TCP protocols. This will make the PC set all it's settings to run of DHCP, catch is if you are using assigned DNS or IP for something those will be lost (can't imagine why the PC would need a static IP.

    From a command prompt (if in vista or 7 open as administrator) and run the following.
    Code:
    netsh i i r r
    netsh winsock reset
    Than restart the PC, I have to at least mention there is a chance that it won't reconnect to the wireless after that. If so just go through the windows wireless connection steps (select network, enter key) and it should be back.

    Theory here is that the PC had a static IP set for a different network using the same IP ranges/gateway settings (more common than you might think).

    Good luck!
    01-06-2012 03:07 PM
LINK TO POST COPIED TO CLIPBOARD