1. Cats15's Avatar
    Does anyone know why I can't watch shows from fox,Cbs,or Nbc on my fire? It says that I am not running the latest adobe flash. When I try to install it doesn't work. I thought the kindle fire supported flash. Any info would be greatly appreciated

    Sent from my Kindle Fire using Tapatalk
    01-07-2012 02:01 PM
  2. GBH2's Avatar
    When you tried to install through the video link it is trying to install a "desktop" version of flash that is why it failed.

    The kindle has something like Flash 10.1 or 10.3 and it won't let you update it from the Amazon App Store.

    I installed Flash Player 11 from the Android Market and tested the Videos from Fox TV and they work now.

    So, if you do not have access to Google's Android Market (I rooted and installed Google Services Framework and Android Market) you will need to find an apk for Flash Player 11 and sideload it onto your Kindle Fire.
    01-07-2012 03:43 PM
LINK TO POST COPIED TO CLIPBOARD