1. Hovik818's Avatar
    My Brother must have messed with his system files in TWRP and wiped it all out. The damn thing is bricked and every time I clicked factory restore it does nothing as there are no files....

    I can't seem to find a solution to this, I really need help in order to fix this.

    Edit: Apparently I can fix all this if I can obtain a restore from someone. I can't find one online. If someone can upload one it would really mean a lot.
    03-29-2012 03:06 AM
  2. tmn72tx's Avatar
    Hovik818, have you tried this utility already?

    Kindle Fire Utility v0.9.3 (2/4/12) - xda-developers and [INDEX] Kindle Fire Development *FULL LIST* - 23.03.2012 - - xda-developers

    This Utility too: http://forum.xda-developers.com/show....php?t=1428428

    I would suggest strongly reading through some of these posts, and checking for posts on bricked kindle fires. The issue you are running into has been encountered a lot, and you will find a lot of help with those previous posts.

    If you feel like you just need the stock Kindle Fire software, look under the 6.3 post that was just sent in, you will find the link to the software there, but once you have the Kindle rooted, I'm not sure that you can just do a factory restore.

    Good luck with getting it back up and running!
    03-29-2012 04:52 AM
  3. Hovik818's Avatar
    I have looked into all that. Actually those forums say my only other way to so this is if I obtain a factory cable to push stock rom to it. I can't do factory restore cause there are no system files to execute the shell from. Its literally a brick.

    Edit: I found the only fix, it was for me to flash CM7. Now I just need to find Stock Rom.

    Sent from my Galaxy Nexus using Tapatalk
    03-29-2012 10:25 AM
  4. hello.someone's Avatar
    Please help...so I had my kindle rooted and was trying to install the android market (google play). I previously installed google frameworks or what ever its called, so I didn't worry about that. I went here: Download Google Play Store 3.5.16 APK With Tons Of Bug Fixes And Improvements | Redmond Pie and downloaded the apk directly onto my kindle fire. I used file expert to go to system/app and mounted it to Read/Write. Then I copied the apk into the folder. Next, I changed the permissions to Owner - Read/Write, Group - Read, Others - Read. I went into the folder to install the apk, and then file expert crashed. I didn't think it was a big deal, but then it crashed again. Before I knew it, settings crashed, then the home and bar with notifications and times crashes are well. I decided to try to reboot my kindle. When I turned it on, I got a yellow triangle. It said to press the power button, and I did. After a few seconds, it started to turn on again. It's been two hours and the kindle hasn't turned on yet. I tried turning of the kindle again by pressing and holding the power button, but when I tried to turn it on again, the yellow triangle showed up again. Without me doing anything, it continued on to the the boot up screen. And its been stuck like this...it won't turn on...please help me!
    04-14-2012 06:25 PM
  5. tmn72tx's Avatar
    It sounds like you are stuck in fast boot. Use the Kindle Fire utility and switch it back to normal. You will find the utility and instructions on the XDA Developers forum. See my previous post in this thread for some of the links.

    The good news, as long as you're getting the yellow triangle, you should be able to recover from this.
    04-14-2012 08:39 PM
  6. charlibob's Avatar
    The so called factory cable works for some bricked problems, where the triangle just sits there forever no matter what. Helped me out of one jam. You can build one yourself, I did, or order the Motorola Factory Cable from Amazon for around $10. Probably worth it considering how much of a pain it was to rework the connector. Here is a link to the info:
    Kindle Fire Bricked! Know How Android Brains
    04-15-2012 01:41 PM
  7. philb#AC's Avatar
    I did the same, I just kept toying with it and got it working. I did so much, other than giving up, that I don't exactly know how I fixed it. Once I did, with Google market/play I backed it up with twrp. Have fun, you can do it.
    04-17-2012 06:15 AM
  8. Amekharekhi's Avatar
    i have the same problem. I've tried using kindle fire utility however all options keep telling that it cant detect my device or waiting for device. is there any other to bypass the yellow triangle (fastboot) logo and get the device to boot externally?
    07-25-2013 12:45 PM
LINK TO POST COPIED TO CLIPBOARD