1. kevinwska's Avatar
    I got my Mom a Kindle Fire for Christmas and everything works fine except I can't get the Appstore to work correctly; it simply won't load. The Shop loads, the Newsstand loads, all the eBooks load and I've even got the games to load. But when I click on just apps and then Shop, nothing comes up. The page sits there blank and then even the spaces left for the New Releases, Best Sellers, etc disappear and leave me with a blank page.

    I've tried the following:
    -Looked through the troubleshooting link and reinstalled appstore with the link provided there
    -Cleared out Cache and App Data (several times)
    -Reset the WiFi connection on the Kindle several times
    -Did a full reboot of the Kindle (held down the power button for 30 seconds)

    Kindle Specs:
    Version: 10.2.4
    "Apps" Version: 1.0 (listed under installed Applications)
    Appstore Version: (listed under Installed Applications and Amazon Applications)

    Any help would be awesome. If not I'll be calling Amazon CS later.
    12-27-2012 10:21 AM
  2. Labrina Young's Avatar
    Hey I'm going through the same thing if u find a answer let me know I will do the same....!
    01-01-2013 02:43 PM
  3. kevinwska's Avatar
    Well after a lot of tech support and several call backs set up (they would call me on days to give me updates). I finally just made them send me a new one, it worked for one hour and then the same problem occurred. This may be the worst piece of tech I have ever bought and some of the worst customer service. I feel like at this point they are just making me go in circles until they find a reason to not send me any more replacements or a refund.
    01-14-2013 08:00 PM
  4. BigJobBilly's Avatar
    I can't help you fix it, but I can empathize. This is one of a series of glitches I've found with my KFHD. It would seem that Amazon still has a ways to go before it can compete with the iPad (and perhaps other tablets?)
    01-22-2013 02:09 PM
  5. maddy johnson's Avatar
    what do I do to fix it so I can get on the appstore and be able to download apps onto my kindle fire
    10-15-2013 07:18 PM
  6. syconn01's Avatar
    I have the same problem. My amazon connection has been ropey and now it's stopped altogether. I can access the internet but when I try to go on amazon it says I've no internet connection. I've also lost love film a couple of times. Had a KFHD since Christmas and had no problems until last month.
    10-24-2013 02:39 PM
  7. Solman15's Avatar
    My son's Kindle had the same issue. After some research I found that the clock was not set correctly. Hence the Kindle wasn't able to sync with the clock on the Amazon server. I changed the clock setup to automatic and it was able to utilize Appstore.
    12-11-2013 06:50 PM
  8. crackedshel's Avatar
    Thank you for that hint. I was having the same kind of problems and had not had time to do any research. I had noticed the time was off but did not set it to Automatic. With that change, everything connected again, including my gmail. Much appreciated.
    12-17-2013 03:38 PM

Similar Threads

  1. Replies: 7
    Last Post: 04-24-2013, 11:29 PM
  2. Amazon Appstore won't Install
    By bobvanjr in forum HTC EVO 4G
    Replies: 2
    Last Post: 10-18-2011, 09:44 PM
  3. Need Help trying to view a document that won't load properly.
    By adamblaby18 in forum ASUS EeePad Transformer
    Replies: 0
    Last Post: 10-02-2011, 06:35 PM
  4. NEED HELP w BRICKED Optimus V - C-Mod frozen, CM7 Won't load
    By AlexandruBG in forum Virgin Mobile Optimus V
    Replies: 7
    Last Post: 09-23-2011, 05:14 PM
  5. Android won't load past Logo! HELP!
    By carmen89 in forum T-Mobile myTouch 3G
    Replies: 3
    Last Post: 12-28-2009, 07:52 PM