1. procrasinator's Avatar
    Hi everyone!

    I rooted my fire a few months ago and at first it was working just fine.

    For the past week though it shows it is not registered. I have Amazon Prime but I can't borrow books or videos because it's not registered. Amazon.com shows it's registered to me..
    I went to the settings on it and tried to deregister and reregister. Now it shows it registered to me in the settings but it won't give me a Kindle email address to send books to.

    Also, if I launch the Kindle launcher and go to Books it shows it's still not registered.

    Any idea how to fix this?

    06-21-2013 12:30 PM
  2. gg8350's Avatar
    [I] have the same issue on my rooted KF. Did you ever find an answer? Or a workaround? I have OTA Rootkeeper but when I temporarily unroot, I still can't get book functions to work.
    11-04-2013 02:12 AM

Similar Threads

  1. got my phone rooted but now it wont load
    By djdj17 in forum New to the Forums? Introduce Yourself Here!
    Replies: 1
    Last Post: 11-10-2011, 10:22 AM
  2. Just rooted, but now have a Nandroid issue
    By tfrank10 in forum Thunderbolt Rooting, ROMs, and Hacks
    Replies: 14
    Last Post: 08-01-2011, 06:07 PM
  3. Captivate is Rooted but now will not connect to Software Update
    By vailjo91#WP in forum AT&T Captivate Rooting, ROMs, and Hacks
    Replies: 4
    Last Post: 11-18-2010, 09:26 AM
  4. Replies: 13
    Last Post: 06-13-2010, 08:59 AM
  5. Done my homework on root, but a couple of questions
    By Machael in forum HTC Hero Rooting, ROMs, and Hacks
    Replies: 6
    Last Post: 05-17-2010, 12:02 PM