09-04-2013 07:01 AM
28 12
  1. anon(5140585)'s Avatar
    So i rooted a friends KF several times and reverted back to stock several time. This time however, I have an issue. I place the Amazon 6.3.2 update.zip onto the scard root, went into TWRP and wiped all caches. When I click INSTALL it locates the update.zip and I swipe to install, then it gives an error that it cannot update. That is all it does! if I reboot, it stays on the Blue KINDLE FIRE logo. Can anyone help me get back to factory???? I don't care which method, but my computer (win7 32-bit) will only recognize the KF when I mount the SD card within TWRP. So what are my options here?

    Note: Ihave also tried earlier versions of Amazon's software and CM7 (which was on it before wanting to restore)
    08-26-2013 11:35 AM
  2. Scott Kenyon's Avatar
    Push the factory rom onto the device and flash it. See if that one kicks out an error. It shouldn't.
    08-26-2013 11:47 AM
  3. anon(5140585)'s Avatar
    Push the factory rom onto the device and flash it. See if that one kicks out an error. It shouldn't.
    Please explain? I had the Amazon factory ROM on the sd and it didnt work.

    No OS, using TWRP-img_0081-1-.jpg
    08-26-2013 12:02 PM
  4. Scott Kenyon's Avatar
    I had something similar occur on my HTC One. I formatted system and flashed. As scary as that is, it worked. If you don't have another option, and the device is bricked, try it. Only ever do this as a last resort.
    The error you are having is the product line of the build.prop file. Formatting system will remove all remnants of the old OS from the device.

    [WARN]It's probably a very bad idea to power down the device after formatting your system partition! After the format, immediately flash the factory rom![/WARN]
    08-26-2013 12:18 PM
  5. anon(5140585)'s Avatar
    I did format the SD, how do I format the KF when I can't access any settings? Through TWRP???
    08-26-2013 12:26 PM
  6. Scott Kenyon's Avatar
    Yes. Make sure you push the stock rom onto the SD again if you've formatted it.
    08-26-2013 12:28 PM
  7. anon(5140585)'s Avatar
    Would formatting the KF remove TWRP?
    08-26-2013 01:58 PM
  8. Scott Kenyon's Avatar
    It didn't for me, and shouldn't for you. It should only format the system. I didn't reboot before installing the new rom, so I don't know if that would or wouldn't.
    08-26-2013 02:06 PM
  9. anon(5140585)'s Avatar
    it didn't. I tried everything, and i still get the same error from the photo above.
    08-26-2013 02:08 PM
  10. Scott Kenyon's Avatar
    Alright, it won't be easy, I suppose. You're going to need to edit the zip with your computer. Find the update_zip and comment out the assert command that you're failing on. You should be able to flash the rom then.
    Aparently the problem is with TWRP. In updated versions, the name should be "otter" instead of "blaze". I could explain how to change that, but it's really not worth either of our time. It's easier to comment out the assert.

    Edit: What would also work and be a lot easier is to flash an older version of TWRP and use that to install the rom. Find a flashable version of, install that and flash the rom.
    08-26-2013 02:19 PM
  11. anon(5140585)'s Avatar
    I have done that earlier by googling different things. Every program I run outputs this error:

    exec '/system/bin/sh' failed: no such directory

    any thoughts on that? because I can enter adb and fastboot but nothing will write to the KF
    08-26-2013 02:28 PM
  12. Scott Kenyon's Avatar
    I have done that earlier by googling different things. Every program I run outputs this error:

    exec '/system/bin/sh' failed: no such directory

    any thoughts on that? because I can enter adb and fastboot but nothing will write to the KF
    Is that error coming up on install or when you try to enter an adb shell? I'd expect that with an adb shell, not so much with a rom.
    08-26-2013 02:32 PM
  13. anon(5140585)'s Avatar
    adb shell.
    08-26-2013 02:41 PM
  14. Scott Kenyon's Avatar
    New tools for unbricking a Kindle Fire - Liliputing

    Try the second option presented here. It should fix your partitions for you if commenting out the assert did not work. That's another likely problem.
    08-26-2013 02:42 PM
  15. anon(5140585)'s Avatar
    no luck, same system/bin/sh kickback
    08-26-2013 03:34 PM
  16. Scott Kenyon's Avatar
    I'll have to think about it a bit then. It's surely recoverable, but Kindle devices are far from my specialty. I'll think it over and post when I have a worthwhile idea for you, and in the meantime I'm going to share this thread with my peers and see if they have any ideas. It's entirely possible I missed something stupid.
    08-26-2013 04:27 PM
  17. anon(5140585)'s Avatar
    So after tinkering for about 6 hours, It finally took an update. The NEW ISSUE, it is stuck at the Kindle Fire logo! I am now searching for a fix for that. I tried KFU, but again it outputs the system/bin/sh no directory error.

    No OS, using TWRP-no.png
    08-26-2013 09:37 PM
  18. Scott Kenyon's Avatar
    Mount /system/ if it's not mounted. How did you get it to flash an update?
    08-27-2013 08:24 AM
  19. anon(5140585)'s Avatar
    how do I mount/system? Through adb?

    I tried a lot of methods last night, but I had TWRP 2.5 installed which wouldn't flash anything. I used a utility which put of FFF and TWRP 2.2 and then flash the stock KF rom. After it is said updated, it stayed at the "verifying" stage for about 20 minutes before rebooting. It rebooted and now stuck at logo. I can access through adb, but can't root and can't do anything while the system/bin error exists.
    08-27-2013 10:43 AM
  20. Scott Kenyon's Avatar
    Mount it in twrp. Mount menu, select system and ensure it's mounted.
    08-27-2013 11:08 AM
  21. anon(5140585)'s Avatar
    I no longer have access to TWRP, only see the logo screen
    08-27-2013 11:13 AM
  22. Scott Kenyon's Avatar
    Use adb to reflash twrp, or have you tried that?
    08-27-2013 12:56 PM
  23. anon(5140585)'s Avatar
    I have tried that. ADB is online, but cannot root and cannot install anything. The only option that I can see is the adapter from BlackHat
    08-27-2013 01:16 PM
  24. Scott Kenyon's Avatar
    I take it you've also tried to flash the rom via adb? I wouldn't expect this to work, but you never know. If you can use the tools you have to fix the partition, you may be able to force the stock rom back on there. Again, I'm no Kindle expert or anything so I'm not sure and running out of options. I'll research this a lot more when I get time and see what I can come up with as possible alternatives.
    08-27-2013 02:52 PM
  25. anon(5140585)'s Avatar
    I have tried to flash through ADB, but again... nothing works because nothing can find the system/bin directory. I am trying to search for a fix to restore the partition that holds the OS, which from what I found, is the system/bin area. I looked at SoupKit, and I am currently downloading uBuntu and make my laptop a dual boot. SoupKit requires uBuntu. This is frustrating, but I appreciate your help and time.
    08-27-2013 03:07 PM
28 12

Similar Threads

  1. Can the Nexus 7 use Skype with video?
    By Charles Baker1 in forum Google Nexus 7 Tablet (2013)
    Replies: 10
    Last Post: 11-17-2013, 03:21 AM
  2. Bought Used Galaxy Nexus with 4.0.1 It won't update.
    By Christopher Massaad in forum Google / Samsung Galaxy Nexus
    Replies: 5
    Last Post: 08-27-2013, 10:12 AM
  3. Pattern unlock log - was my phone used?
    By regmysoft in forum Legacy Android & Other OS's
    Replies: 3
    Last Post: 08-26-2013, 03:53 AM
  4. No Kernel Loop Support On Jelly Bean 4.3
    By Algorhythm511 in forum Google Nexus 7 (2013) Rooting, ROMs, & Hacks
    Replies: 0
    Last Post: 08-25-2013, 08:34 PM