1. hakdaddy's Avatar
    Was on the beta programme for last few months with no issues however updated last night to official Android 12 and my device has lost 5G coverage. Ive travelled to several parts of London since updating and have received no 5G signal. Stuck on 4G, spoke to my network who have told me there is no issues with the signal at any areas I've been in.

    Not sure what to do, don't want to wipe the phone as I'm too busy and using an eSim which will be a massive headache, not sure a phone wipe will make any difference.

    Anyone else having 5G coverage issues after the android 12 update?
    10-20-2021 12:57 PM
  2. hallux's Avatar
    Try doing a network reset. It's in Settings > System > Reset Options You want the one to reset WiFi Mobile and Bluetooth. Yes, you'll need to reconfigure your WiFi networks and re-pair with Bluetooth devices.

    I had similar problems with my 4a 5G over the summer (not on any beta, it just had trouble pulling proper mobile network signals) and doing this reset has restored the phone to function as I expect it to.
    J Dubbs likes this.
    10-20-2021 02:33 PM
  3. swebb's Avatar
    Was on the beta programme for last few months with no issues however updated last night to official Android 12 and my device has lost 5G coverage. Ive travelled to several parts of London since updating and have received no 5G signal. Stuck on 4G, spoke to my network who have told me there is no issues with the signal at any areas I've been in.

    Not sure what to do, don't want to wipe the phone as I'm too busy and using an eSim which will be a massive headache, not sure a phone wipe will make any difference.

    Anyone else having 5G coverage issues after the android 12 update?
    Are you sure you really had 5G coverage? I say this because my indicator showed 5G quite often when I knew I wasn't in a 5G area, verified by various signal apps. I think the logic used (Google P5 phone) was over optimistic. Possibly this was corrected in Android 12.

    Try a speed test to see what speeds you're getting. If you're certain you should be getting 5G, then do the network reset.
    10-21-2021 07:56 AM
  4. livetovacation60's Avatar
    I have a similar problem. Had a really great 5G connect on my 5a until I updated to Android 12. Went through a network reset, and then since I had some other issues I reset the phone. After that 5G showed up again for an hour or so and that's been it. My LTE connect is pretty fast and I'm mostly on wifi so it's not a huge concern for me right now. My carrier is Mint Mobile which of course uses TMO.
    11-09-2021 05:00 AM
  5. beantownsouth's Avatar
    I have a similar problem. Had a really great 5G connect on my 5a until I updated to Android 12. Went through a network reset, and then since I had some other issues I reset the phone. After that 5G showed up again for an hour or so and that's been it. My LTE connect is pretty fast and I'm mostly on wifi so it's not a huge concern for me right now. My carrier is Mint Mobile which of course uses TMO.
    Since Mint Mobile is an MVNO could they be switching you to 4G LTE due to network traffic? We're on TMO and have a P5 and a P5a5g and we both are on the 5G side of the TMO network in our house. I too am usually on our wifi. Turn off wifi and it goes right to the 5G nation wide network. Rarely do I see 4G LTE.
    11-09-2021 10:37 AM
  6. livetovacation60's Avatar
    I thought about that but I don't thing so. After I had reset the phone I saw a glimpse again of 5G but it was short lived. I've googled this issue but haven't found much. In regard to my LTE connect from home I'm getting 150-200 MPS. When I turn off wifi it reads LTE whether I'm on 5G or not. Did not have this problem before the update.
    11-09-2021 03:28 PM
  7. livetovacation60's Avatar
    I finally did figure out my problem. When battery saver enabled no 5G, when disabled no issues. Was wondering if this was the norm maybe?
    11-11-2021 12:51 PM

Similar Threads

  1. New Update-Oct 20
    By jlangner in forum Samsung Galaxy Watch 4
    Replies: 29
    Last Post: 10-25-2021, 08:56 PM
  2. Phone history not updating
    By Fisherguy 01 in forum Ask a Question
    Replies: 6
    Last Post: 10-22-2021, 08:50 PM
  3. 2 Updates?
    By ROE_HUNTER in forum Samsung Galaxy Fold
    Replies: 2
    Last Post: 10-22-2021, 08:25 AM
  4. Why Blue Dot on my Contact name
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 10-20-2021, 05:34 PM
  5. iPhone 12 (Pro, Pro Max etc) for the Google 6 Pro - anyone doing this?
    By Dan_B1979 in forum Google Pixel 6 & Pixel 6 Pro
    Replies: 1
    Last Post: 10-20-2021, 12:17 PM
LINK TO POST COPIED TO CLIPBOARD