1. Crunchwantsfood's Avatar
    Hi everyone, good forum. I have been running around trying to find a solution to this problem but everything I have tried so far has not worked. Hoping you can help, here is the info:

    Samsung Galaxy i9100 aka SG2
    Not rooted
    No custom ROMS or any schenanigans
    Android 2.3.5 Gingerbread

    The phone seems to work fine as a device in that it takes pictures, I can view them, I can use my notepad, read the BBC news, check the weather, Gmail and such. I met a friend and tried to enter the contact on my phone and it froze, then generated "the process android.process.acore has stopped unexpectedly. Please try again".

    So, while I can tap in a number and call, I can't add it as a new contact whatever way I try. Also now I scroll through my contacts and look at the names, but when I tap a name to open, it wont show me any info at all. It just hangs and then gives me the error message.

    I have tried:

    - Turning off and on again ---> NO
    - Backing up the contacts, deleting contacts, turn off/on, restore contacts ---> NO
    - Backing up the contacts, deleting contacts, settings-applications-running services-contacts-clear data ---> NO
    - Backing up the contacts, deleting contacts, settings-applications-running services-contacts storage-clear data ---> NO
    - Clear contacts data AND clear contacts storage data ---> NO
    - Removing Outlook, BBC Weather, Anagram game (the only game on the device) ---> NO
    - Entering recovery mode and clearing the cache ---> NO
    - Resetting ProcessTW ---> NO
    - Stopping Gmail, Skype, Viber, Whatsapp sync ---> NO
    - Talking politely to my phone and asking it to be nice to me ---> NO
    - Yelling obscenities at it ---> NO

    As far as I can see, I have factory reset as the last option, which seems drastic. I'm not even sure of the reset passwords or where the phone documents are. Also, I don't want to brick the device trying to flash the memory, even though it has served me well for very close to 3 years, unless that is also the last option.

    If anyone has any ideas, please let me know step by step. I have been all over the net looking for ideas and none have worked for me. I saw somewhere that facebook caused this issue with many, but I don't use facebook and don't have the app on my phone. I have also NOT recently installed any new app for some time. Probably the last app I installed was the anagram app, which was about 2 weeks ago. Having removed it, the error continues.

    To be clear, the message does NOT repeatedly pop up no matter what I do with the phone. The error message ONLY pops up when I try to add a contact or view contact information.

    I have to go out for about an hour or so, but I will be leaving this open on my computer to respond to any kind soul willing to help diagnose this problem.

    Thanks guys.
    05-09-2014 01:01 PM
  2. Crunchwantsfood's Avatar
    No ideas?
    Have I put this in the right section?
    05-10-2014 06:24 PM
  3. Vagelis Nastos's Avatar
    I had the same problem today I have a Galaxy S+.
    I restored my phone to factory default and everything worked fine untill I restalled some of the applications that I used before the factory default. The problem reappeared again, I restored my mobile again and I reinstalled the applications one by one. The application that caused the problem is "Viber". I uninstalled viber and my phone works fine.
    So if you have viber installed try to unistall it, if not might be an other application that use contacts.

    I hope this helps
    05-11-2014 11:13 AM
  4. Crunchwantsfood's Avatar
    Thank you Vagelis Nastos.

    I did have Viber installed. It pretty has been since day one and no recent updates. Anyway, I uninstalled it and now I can view my contacts and contact info. However, I still can NOT add a new contact without it generating the same error.

    Did the problem remain resolved for you?

    Any other ideas Vagelis or anyone?
    05-11-2014 03:50 PM
  5. Vagelis Nastos's Avatar

    I am not sure if I had problem adding contacts when viber was installed.
    Now I have no problem adding contacts.

    First try to restart the phone after unistalling viber if you haven't done it get.
    If this do not solve the problem I suggest you to try unistalling any application/account that sharing/sync contacts (e.g. facebook, exchange).
    Leave only the google account and if it works ok try adding the accounts one by one.
    05-11-2014 04:30 PM
  6. Crunchwantsfood's Avatar
    I did restart, but still get the error.

    No facebook or anything like that, but I do have whatsapp and wechat. I will save the conversations and everything, uninstall, then restart. Wechat has a password for this kind of thing, so I will try to remember that first so I don't lose much.

    I will report back once I have done that, but in the meantime if you or anyone else has any other ideas, please do post.

    Thanks again Vagelis!
    05-11-2014 05:58 PM
  7. Ber Gies's Avatar
    I have a samsung S2 with factory configuration and 2.3.5. I have the same problem with adding a new contact and also with some of the contacts. I did one factory reset which solved the problem, but after re-installing my apps - it happened again. Now - after removing Whatsapp - the problem immediately disappeared.
    WHATSAPP is definitely what caused the problem in my phone!

    05-12-2014 10:05 AM
  8. Crunchwantsfood's Avatar
    Reporting back.

    I have removed Viber, Whatsapp and Wechat from my phone and now it works fine. I can view, edit and add new contact information. What I don't understand is why this sudden error cropped up. There have been no updates for any of these recently and all worked without incident side by side for years.

    I just tried to re-add Viber and it worked well for about ten mins and I got the error again. So I have removed it and am going to try and re-add whatsapp.

    If anyone can shed light on why we are getting these errors please do advise. Thanks!
    05-12-2014 11:17 AM
  9. Crunchwantsfood's Avatar
    Final update.

    Whatsapp and wechat are working without any problems at all.
    Viber is the problem, and I have no idea why.
    Everything else works well together, it is literally the second I install Viber when things go wonky. I've tried to install it without other apps, but it seems Viber is the root cause here, and not a combination of crossed purposes. Such a shame because Viber was quite an important and useful tool. I could still be wrong, so if someone out there has a better solution (one that would let me re-install Viber) then I would love to hear it!

    Please post here or PM if you have any other ideas.
    I will continue to follow the forum and thread.
    A big thanks to everyone who read and especially to Vagelis and Ber!

    Issue resolved.
    Viber was causing the error.
    05-12-2014 02:44 PM
  10. Vagelis Nastos's Avatar

    This is Viber's answer for the problem

    "The issue described might be caused by the fact that Viber is not supported on your platform, Viber’s minimum requirement for android is OS 2.3.6.
    For a full list of supported devices and platforms, please follow the link: http://support.viber.com/customer/po...s#.U3Hyt_ldXrM
    05-13-2014 06:07 AM
  11. Crunchwantsfood's Avatar
    Hi Vagelis,

    Thanks for the info and link. I never knew that about Viber, but then it functioned without a single error for almost 3 years on my SG2 2.3.5 phone. No recent updates or anything (I only permit manual updates, never automatic dl), so I don't know why it suddenly started kicking these errors up.
    05-13-2014 09:33 AM
  12. Pol Oodzskz's Avatar
    I have this thing only when i try to add a contact.
    I have no viber, unistalled whatsapp and fb, clear contact and contact storage....to no avail
    05-13-2014 01:19 PM
  13. Samir Mulasalihovic's Avatar
    I had this problem for past several days and found this forum which helped resolve it.
    I also have an old android version unsupported in Viber, but after I settled on disconnecting Viber from synchronizing contacts on the phone everything worked fine, including Viber.

    You find the configuration in Viber, Settings, General, Synchronize contacts.
    05-14-2014 04:22 AM
  14. Gabn's Avatar
    Same problem with a Galaxy Ace. I don't have viber, only whatsapp. The problem disappear uninstalling whatsapp.. but.. I want whatsapp....
    05-14-2014 07:15 AM
  15. carlose9105's Avatar

    I'm experimenting the same issue. But I just tried the possible solutions, the ones described on this forum and others, and I came to the conclusion that WhatsApp sync account is making that problem. I just disable the background sync process and I can edit, view, add contacts on my phone.
    05-14-2014 03:03 PM
  16. Gabn's Avatar
    The problem is the new google play services uptade (9 may). Uninstalling the app directly (google play service) SOLVE the PROBLEM permanently.
    05-14-2014 03:56 PM
  17. Crunchwantsfood's Avatar
    Hi all, back online after a few days holiday.

    Pol - have you tried all the steps I mentioned in my original post?

    Samir - that's good to know. I will give that a try despite being on a version of android (2.3.5) that doesn't support Viber and report back. Good tip. Thanks.

    Gabn - how did you determine that Google Play services were to blame? I thought google play was pretty much a necessity for android life, so I never even considered uninstalling that.
    05-19-2014 07:19 AM
  18. flowercris's Avatar
    Hi all, back online after a few days holiday.

    Pol - have you tried all the steps I mentioned in my original post?

    Samir - that's good to know. I will give that a try despite being on a version of android (2.3.5) that doesn't support Viber and report back. Good tip. Thanks.

    Gabn - how did you determine that Google Play services were to blame? I thought google play was pretty much a necessity for android life, so I never even considered uninstalling that.
    06-09-2014 03:18 PM
  19. flowercris's Avatar
    Hello , I had the exact same problem couldn't access my contacts nor add a new one. And I tried most of the actions you proposed with no results.
    Before full reset of the phone I was able to solve the problem without removing any app.
    As Viber seemed to be the issue I entered Settings-Privacy and cleared Collect Analytics Data.
    Voila! My contacts are back again!!
    My phone is a Samsung Ace plus.
    06-09-2014 03:35 PM
  20. flowercris's Avatar
    Hi, I've been using my phone without any problems I can use Viber, Whatsapp, Line, access my contacts but.... now I can't add a new contact, the "android.processs.message" appears again! Any suggestions, please!
    06-10-2014 10:21 AM
  21. Crunchwantsfood's Avatar
    Hi Flowercris,

    Have you tried ALL of the steps I listed in my original post? Including clearing the cache on boot? I made sure to do that on every restart after I implemented ANY changes.

    If none of those steps work, then it really is about uninstalling one of the "messaging" apps you have installed one at a time, rebooting after each one, to see which was causing the error. For me it was Viber, so I would suggest starting with that. I was reluctant to uninstall apps I used daily, and I still miss using it, but having a working phone trumps any app.

    Make sure you backup your contacts with something like "superbackup" and emailing yourself the contacts file. Your google account will automatically have your contacts so many would say don't bother doing this... but with an error on your phone I would think it prudent to make sure you have a second backup.

    Post your results.
    06-11-2014 02:20 PM

Similar Threads

  1. [Apk][Android][Juego][Gratis] Flying Egg
    By AntonioSuarez19 in forum Android Games
    Replies: 1
    Last Post: 02-22-2015, 07:29 AM
  2. Replies: 10
    Last Post: 05-10-2014, 08:21 PM
  3. Slate 21 crashes with Firefox or Chrome
    By Tomas Alberto Ramirez Andujar in forum Android 4.1 / 4.2 / 4.3 Jelly Bean
    Replies: 1
    Last Post: 05-09-2014, 03:00 PM
  4. Hdmi cord not working with phone after reset
    By Gabriel Tagnani in forum Samsung Galaxy S4
    Replies: 0
    Last Post: 05-09-2014, 11:26 AM
  5. Need publish help me free my app
    By Cang Do in forum Google Play Store
    Replies: 0
    Last Post: 05-09-2014, 11:17 AM