View Poll Results: Did disabling "Auto-Rotate screen" fix your battery issue?

6. You may not vote on this poll
  • Yes

    1 16.67%
  • No

    5 83.33%
  1. anon(851732)'s Avatar
    Guys, this issue seems to be caused by the "Auto-Rotate screen" setting being enabled under the Display settings.

    Some proof of this is by viewing CPU usage using OS Monitor. With "Auto-Rotate screen" enabled and the phone idle, CPU usage of "Android System" will remain anywhere between 25% to 30% (while the phone is idle) and apparently prevents the Nexus S from going into a deep sleep, which of course will be draining the battery faster. By disabling "Auto-Rotate screen", the CPU usage of "Android System" drops to between 0% and 4%. Re-enabling "Auto-Rotate screen" caused "Android System" to consistently jump between 25% and 30%. So I keep "Auto-Rotate screen" disabled now. Try this out as I had the same issue and my battery now lasts longer with it disabled. Download "OS Monitor" and see for yourselves. It MUST be a bug that is hopefully fixed in 4.1.1.

    I hope this works for you! Please let me know

    07-11-2012 11:36 AM
  2. Destoration's Avatar
    Thats weird on my nexus the cpu sits around 2% when just running os monitor. Disabling auto-rotate didn't really change it. Maybe you have another process sucking the cpu?
    07-11-2012 11:56 AM
  3. anon(851732)'s Avatar
    Do you have the Galaxy Nexus or the Nexus S?

    I am running 4.0.4 on Nexus S.

    It's tough trying to identify the battery drain issue as so many people seem to be experiencing it...
    07-11-2012 11:59 AM
  4. anon(851732)'s Avatar
    And it is definitely 100% the "Android System" process consistently running between 25% to 30% even when idle, but ONLY when "Auto-Rotate screen" is enabled. With it disabled, it goes straight down to between 0% and 4%.
    07-11-2012 12:01 PM
  5. ghatala's Avatar
    Have a moto droid 4 and no difference with switching auto rotate. System in about 30% and display is 23%. I get about 27 hours of battery with ICS
    09-21-2012 03:44 PM
  6. itsmeyousuf's Avatar
    my GS3 says Please notice your phone battery is overheated how can i stop this.
    09-24-2012 02:39 PM
  7. ElSteve9's Avatar
    I've got a Photon Q. I noticed my battery goes 92% to my screen. I tried your trick. I'll report back if it works!

    09-25-2012 05:47 PM
  8. jerryread's Avatar
    People say the ram is there to be used but this will surely use more battery. I find uccw will sometimes be a hogger so dont know why some apps seem to randomly have been using battery in standby or how accurate a stock battery monitor is .Anyway, i have same problem as After ICS update with phone taking 55 seconds to shutdown. This cant be good - what is running that cant stop on shutdown?
    I think cache cleaner messed things up some how.
    09-27-2012 12:53 AM
  9. crkeehn's Avatar
    I have heard of others complaining about battery drain with ICS, others that have the same hardware I do (Samsung Galaxy Tab 8.9). I find that the app I am running has more effect on battery usage than any sort of system housekeeping. After nearly 12 hours since I last charged my device, I still have 87% of the battery capacity. The screen has been the heavy user with 64% usage.

    When I play a graphic intensive game like Bubble Shoot, I'll see my battery power go fairly quickly but that is more a factor of my playing the game for an extended period of time, I find it very addictive.
    10-03-2012 03:48 PM
  10. gquiring's Avatar
    I tried OS Monitor on my SG3 with screen rotate on/off and it does not change my CPU usage which sits around 3% for Android system.
    10-05-2012 10:28 PM
  11. jsarino's Avatar
    My Android system sits around 3-5% with auto-rotate screen enabled (Galaxy S2 Skyrocket).
    11-05-2012 01:53 PM