1. svictor's Avatar
    Hey,
    I can't update my S3 to Jelly Bean because when i enter "software update" in the phone settings it says "software is up to date".And when i try using Kies it shows me this "Your device's current firmware is not supported to update firmware via Kies"
    Current firmware version: PDA:LH1/PHONE:LH1/CSC:LH1(THR)".
    What should i do?
    09-09-2013 04:03 AM
  2. Susan Dennick's Avatar
    My Galaxy 10.1 had updated some time ago to JB skipping ICS entirely. I didn't like JB initially, but after a couple of days, I was fine with it. I froze totally last week and had to go to factory reset. After the reset, I had ICS and, as you, in settings I am "up to date," which seemed ridiculous since I had had JB? I got on to Samsung 'cause I wanted JB back and had an online chat with a rep, who informed me there is no way I can get JB now. My 10.1 (2 yrs old) will now only support ICS.

    For what it's worth, I am now so happy with ICS, that I am thrilled that I had to do the reset and can't get JB. I find it much easier to use. Hope you experience the same. Sometimes these upgrades are more trouble than they're worth.
    09-17-2013 05:43 PM
  3. Golfdriver97's Avatar
    My Galaxy 10.1 had updated some time ago to JB skipping ICS entirely. I didn't like JB initially, but after a couple of days, I was fine with it. I froze totally last week and had to go to factory reset. After the reset, I had ICS and, as you, in settings I am "up to date," which seemed ridiculous since I had had JB? I got on to Samsung 'cause I wanted JB back and had an online chat with a rep, who informed me there is no way I can get JB now. My 10.1 (2 yrs old) will now only support ICS.

    For what it's worth, I am now so happy with ICS, that I am thrilled that I had to do the reset and can't get JB. I find it much easier to use. Hope you experience the same. Sometimes these upgrades are more trouble than they're worth.
    Welcome to the forums!

    Hey,
    I can't update my S3 to Jelly Bean because when i enter "software update" in the phone settings it says "software is up to date".And when i try using Kies it shows me this "Your device's current firmware is not supported to update firmware via Kies"
    Current firmware version: PDA:LH1/PHONE:LH1/CSC:LH1(THR)".
    What should i do?
    Welcome to the forums!
    What carrier are you on?
    09-17-2013 08:53 PM

Similar Threads

  1. Lenovo ThinkPad Tablet update
    By JenRich in forum Lenovo Android Tablet Discussion
    Replies: 1
    Last Post: 10-23-2013, 01:24 PM
  2. what are my chances?
    By myIphone4s in forum Samsung Galaxy S4
    Replies: 8
    Last Post: 09-18-2013, 12:07 PM
  3. What's the best advice on when to recharge your Nexus 7?
    By douglerner in forum Google Nexus 7 Tablet (2013)
    Replies: 8
    Last Post: 09-12-2013, 09:59 AM
  4. What to do with previous device
    By like2angle in forum Motorola Droid MAXX
    Replies: 7
    Last Post: 09-09-2013, 01:54 PM
LINK TO POST COPIED TO CLIPBOARD