1. Isaac Imm's Avatar
    As the title, says, My phone says that it is "connected to 11FX......... (i don't remember the name)" but when i try to open Facebook or Play or Twitter, it doesn't load! I tried lots of things, but I still can't connect! Help!
    11-29-2013 02:44 PM
  2. VDub2174's Avatar
    What sort of things did you try already so we don't give you suggestions that you already tried?
    11-29-2013 02:47 PM
  3. Isaac Imm's Avatar
    like turing wifi on then off, restarting the phone, forgeting the connection then reconnecting, etc.
    11-29-2013 04:14 PM
  4. VDub2174's Avatar
    Have you tried resetting the router maybe?
    11-29-2013 04:27 PM
  5. Isaac Imm's Avatar
    my computer works perfectly...
    11-29-2013 04:35 PM

Similar Threads

  1. Galaxy Note 8.0: Is there an easy way to root my device without using a computer?
    By owensch1 in forum Samsung Galaxy Note 8.0 Tablet
    Replies: 6
    Last Post: 06-07-2014, 06:49 PM
  2. WiFi dropping after 4.4 upgrade
    By grafx1 in forum Google Nexus 7 Tablet (2012)
    Replies: 4
    Last Post: 12-05-2013, 08:22 PM
  3. Replies: 81
    Last Post: 12-05-2013, 11:00 AM
  4. Nexus 5 from best buy, is it unlocked for overseas use?
    By Sam Keyte in forum Google Nexus 5
    Replies: 6
    Last Post: 11-29-2013, 06:27 PM
  5. Verizon Galaxy Nexus - Can you receive animated gifs via MMS?
    By yosteve in forum Verizon Galaxy Nexus
    Replies: 0
    Last Post: 11-29-2013, 12:46 PM
LINK TO POST COPIED TO CLIPBOARD