1. MonkeyDot's Avatar
    Hi, I created this thread after looking around for a solution for 2 hours.
    My GPS basically isn't working. The icon in the notification bar is empty, not blinking or full. When I pull it down it says searching for GPS signal, but never ends.
    This happens in every app using gps.
    I have a Galaxy Nexus on 4.2.2
    It's also not a hardware issue, some time ago (maybe before I updated to 4.2.1) it was working.
    Help? This is really really frustrating me.
    02-13-2013 08:09 PM
  2. Carlitos Diaz's Avatar
    Same problem here on nexus 4 after 4.2.2 update.
    02-14-2013 05:07 PM
  3. rs232pro's Avatar
    Add me to the list! I sent my Nexus 4 back in because I was sure it was a hardware issue. It was doing this:
    The gps icon wouldn't even show up unless I went into locations settings, disabled and then re-enabled location services.
    Now, the icon is empty and I don't get a lock at all.
    It sounds like some people don't have the problem.
    I ordered one for my wife and hers has the same initial problem I had.
    02-25-2013 02:10 PM
  4. rs232pro's Avatar
    Are you still having the problem MonkeyDot?
    02-25-2013 02:17 PM
  5. Bazmati's Avatar
    I received my phone on Tuesday and after setting it up, the 4.2.2 update had downloaded, so I installed it straight away. The following day, I tried using GPS for the first time and I got the same symptoms described in this post. I was going to return it as faulty, but it looks like it may be worth hanging on for a fix I suppose. I'm sure that Google must have been told about this already, surely?
    03-01-2013 02:03 PM
  6. Bazmati's Avatar
    Update: I downloaded the GPS Test application from the Play Store and selected the Update AGPS option from the settings screen and GPS sprung into life. Before doing this, GPS had never worked on my phone. Now works all the time. Hope this works for you guys too
    03-04-2013 01:21 PM
  7. drosan1's Avatar
    finally found the fix after searching the web for over a month. The fix is so simple, its almost stupid. Guess, its MapQuest.
    Check out the solution
    Solved Searching for GPS Issue on Nexus 4 or Android Phones | AskStudent
    06-30-2013 02:04 PM

Similar Threads

  1. Google Maps GPS problems
    By Fairbanks in forum Verizon Fascinate
    Replies: 47
    Last Post: 03-15-2011, 06:53 PM
  2. GPS problem
    By southpawmedic#IM in forum Incredible Rooting, ROMs, and Hacks
    Replies: 0
    Last Post: 08-07-2010, 09:46 AM
  3. vibrant gps problem?
    By CarliCruise in forum General Help and How To
    Replies: 2
    Last Post: 07-29-2010, 08:38 AM
  4. GPS problems, even after fix
    By thenameisgabe in forum AT&T Captivate
    Replies: 8
    Last Post: 07-26-2010, 07:45 AM
  5. gps problems
    By PRNmeds in forum Motorola Droid Rooting, ROMs and Hacks
    Replies: 0
    Last Post: 03-23-2010, 01:37 AM