1. Samuel Moren's Avatar
    I have a strange issue that is happening with ALL of the Android phones that are in my house or even friends that come here from time to time, I will try to describe it in as much detail as I can.

    I can easily get an android device connected to the network, either using the WPS push button or by entering the shared key. As long as the device stays within range of the router and the wifi is not turned off on the device for any reason there is no problem.

    The instant that the device is shut off, the wifi is turned off or the device leaves the wifi range AND THEN RETURNS within range or the device is turned back on or wifi is restored on the phone it will not connect. It will show "saved, ...blah blah wep...blah blah info". No matter what I do it will not connect. I have tried tapping on the connection and then pressing connect and it says acquiring IP and then goes back to saved. I have tried removing the connection and re-adding it, same thing...just says saved but wont connect. It also shows a great signal strength (I am sitting here in the same room as the router).

    So of course the first thing I figured was it had to be the router. I went back to the cable company and made them swap out my router. I do not have any other option then the Arris model that they provide, it provides the cable modem for internet and the telephony for the home phone. I also can not afford to go buy a different wireless router/access point so I need to fix the issue I am having here.

    I am currently using WPA2-PSK security mode with AES encryption. I have tried every channel from 1 through 11 and auto with the same effect, currently it is back on auto. I have not tried any other security mode. Although I am not dumb when it comes to networking and computers, I am in no way an expert when it comes to networking, especially wireless networking.

    So this is about all the information I can think of to offer. If you think you can help me and would like me to provide more information just ask. Please do not tell me to go buy a new router/modem/access point though, I have no money and can not do that. I have seen this same exact issue all over the web today, have spent over 9 hours searching Google and reading forum posts but have not seen anything that resembles a fix, just a lot of speculation and bits of troubleshooting (most of it I have tried).

    Thanks in advance for any help you all can offer!!

    03-07-2013 07:09 PM
  2. Andrew Merritt's Avatar
    This is no way a fix but ever since my HTC one X upgraded to jelly bean I have the exact same issue. It's fine while its in range but when I leave and come back I cannot connect. My phone seems to think my router has too low of a link speed to connect to. I usually have to restart my router to get it working again. It's terribly aggravating, I have yet to find a more permanent fix. I think this is a flaw in the OS and not a problem with your particular brand of router.
    03-11-2013 11:34 AM
  3. Samuel Moren's Avatar
    Yep it is happening to a lot of people and there does not seem to have a fix.

    Sent from my Galaxy Nexus using Tapatalk 2
    03-11-2013 01:17 PM
  4. meyerweb#CB's Avatar
    In your router settings, do you have the SSID hidden? I'm having this problem with my home APs when the SSID is hidden, but oddly enough not the AP at work, which also has a hidden SSID.

    At home, I can generally get it to recognize the AP if I go into settings and turn WiFi off and back on, or if I long press the WiFi AP name in the phone's setting, tap modify network configuration, then save (without updating anything).
    03-12-2013 11:10 PM
  5. Raja Gopalan's Avatar
    Here is what fixed it on my Android/Cyanogen machine. It is related to Google Locations:
    On the main screen, swipe down to select the Gear icon (Settings)
    Select Wifi and make sure it is On
    Select the 3 vertical dots on top right
    Select Advanced
    Turn OFF "Scanning Always Available"

    This resolved the problem for me
    11-18-2015 10:53 AM

Similar Threads

  1. wifi wont connect to secure router
    By Sabban in forum Verizon Fascinate
    Replies: 9
    Last Post: 12-04-2011, 10:41 AM
  2. Wifi connected to network, but wont load
    By iridealittlebike in forum LG Optimus S
    Replies: 2
    Last Post: 05-15-2011, 09:20 PM
  3. My Wifi Wont connect need help.
    By jrgonz454 in forum Samsung Galaxy Tab
    Replies: 2
    Last Post: 04-21-2011, 03:51 PM
  4. Replies: 9
    Last Post: 09-24-2010, 05:49 PM
  5. Full 3G + wifi but no connection
    By alosenster in forum Motorola Droid X
    Replies: 2
    Last Post: 09-13-2010, 09:53 AM