1. Sunneh's Avatar
    I just updated my xperia Go to 4.1.2, but now i don't have acces to internet (not even mms) via mobile data. When i turn it on nothing happens. I was playing around with settings but nothing helps. When tryin gto google anything it says :Cant search the web because there is no network connection.



    However i dont have any problems with network when using wifi.


    Any idea how to solve this?
    05-13-2013 09:24 AM
  2. patruns's Avatar
    How did you update the phone?
    05-13-2013 10:24 AM
  3. Sunneh's Avatar
    with sony pc companion
    05-13-2013 11:18 AM
  4. patruns's Avatar
    Can you make calls? Could you try a friend's SIM card in your phone to see if that works? This seems more related to your cell account. You do not mention your carrier. Also try enabling and then disabling airplane mode.
    05-13-2013 02:51 PM
  5. Sunneh's Avatar
    I dont have any problems with calls

    It worked without any problems on 2.3.7, but now on 4.2 it just doesnt.


    (pic of 2.3.7)

    I treid turning on and off phone, and airplane mode. Still nothing.
    Here is another picture of my settings.



    My carrier is SiMobil (Slovenia).

    Tried my sisters SIM (different carrier), doesnt work either.
    05-13-2013 04:02 PM
  6. gtbarry's Avatar
    Go to the Access Points Names and take 2-3 screenshots to make sure you know what your settings are now. Even though they don't appear to be working.

    Then, in Access Points, "Reset to Default". Then reboot your phone after.

    If that does not work. You will probably have to speak to your carrier. It sounds like you have the wrong APN info.
    05-13-2013 06:15 PM
  7. Sunneh's Avatar
    Problem solved. Had to download network settings.
    Thanky you everyone for help.
    05-14-2013 08:08 AM
  8. Arun Nalwade's Avatar
    i am facing the same problem mobile data doesnt work for my samsung grand mobile .
    tried restart , reset to default of settings... plz help..
    how to download network settings??
    07-22-2013 01:45 AM
  9. Tepi Pay's Avatar
    I just updated my xperia Go to 4.1.2, but now i don't have acces to internet (not even mms) via mobile data. When i turn it on nothing happens. I was playing around with settings but nothing helps. When tryin gto google anything it says :Cant search the web because there is no network connection.

    http://shrani.si/f/3H/WZ/3d9NtUDf/sc...-05-13-15-.png

    However i dont have any problems with network when using wifi.


    Any idea how to solve this?
    11-06-2013 10:58 PM
  10. Lowri Herbs's Avatar
    I can't seem to work mine either. I have a HTC Chinese phone that I got off the internet. I have rung my Tesco mobile holders and they told me my data has been enabled, but I still cannot get onto my Tesco data internet connection. I am basically paying 20 a month for calls and texts, but I want my internet. Can anyone help?! I'm going to end up crying, man. Thank you
    03-12-2014 12:50 PM
  11. Itu Talukdar's Avatar
    Same prblm is going with my phone... if sumbody can help plz....
    10-21-2015 11:48 PM
  12. jani bentley's Avatar
    How did you update the phone?
    11-02-2015 03:27 AM
  13. YangZinger's Avatar
    Hey um i am trying to get my mobile data to work it was fine yesterday up until my phone died and when i plugged it in let it get to 20% and turned it back on the mobile data wasn't working can u guys plz help me. oh and my phone is AT&T LGE LGL15G and it is also a tracfone so plz help.
    11-17-2015 02:37 PM
  14. BBoy Hathaway's Avatar
    I just updated my xperia Go to 4.1.2, but now i don't have acces to internet (not even mms) via mobile data. When i turn it on nothing happens. I was playing around with settings but nothing helps. When tryin gto google anything it says :Cant search the web because there is no network connection.

    http://shrani.si/f/3H/WZ/3d9NtUDf/sc...-05-13-15-.png

    However i dont have any problems with network when using wifi.


    Any idea how to solve this?
    11-01-2016 09:28 AM
  15. Skaterboy1's Avatar
    Yea I need help my data only works if I send a multimedia message other than that it doesn't work.
    Mukesh kumar30 likes this.
    03-12-2017 05:19 PM
  16. Yasmin03's Avatar
    Problem solved. Had to download network settings.
    Thanky you everyone for help.
    how do you download networ settings?tell me pls
    06-15-2017 11:43 PM

Similar Threads

  1. Replies: 17
    Last Post: 12-14-2011, 12:11 AM
  2. Superfast doesn't work with wifi tether
    By Froalskiner#WN in forum Verizon Fascinate Rooting, ROMs, and Hacks
    Replies: 3
    Last Post: 11-27-2010, 11:52 PM
  3. WiFi and Location Tracking doesn't work
    By magnificence in forum General Help and How To
    Replies: 2
    Last Post: 09-20-2010, 10:57 AM
  4. HeWho DOES have working wifi?
    By Stang68 in forum Motorola Droid X
    Replies: 36
    Last Post: 07-18-2010, 05:32 PM
  5. Wifi does not work
    By alphabets in forum Motorola Droid
    Replies: 7
    Last Post: 01-04-2010, 10:50 AM
LINK TO POST COPIED TO CLIPBOARD