1. Oddwin's Avatar
    Okay,

    I have been searching all morning for an answer to this question. And I can't seem to find a definitive one.

    I "just" got my S2 back from warranty work being done yesterday "June 13th" and everything looked 100% different. I did some looking around and discovered I am now running Jellybean v4.1.2

    However.. when I got up this morning to install all of my apps, and put all the music back on my phone....

    When I plug in my USB cable (Same one I have been using through 3 different Android phones now.. a Hero, Legend, and now an S2) Same one that worked perfectly fine to transfer files to and from my phone 2 weeks ago .. suddenly won't work anymore.

    So I go to Settings > More Settings > USB utilities and when I press "Connect storage to PC" I get a popup window saying " Connect USB cable to use mass storage"


    Am I missing something here? ..

    I found a ton of posts this morning where I " think" there are other people having the same issue.. but it's never the same phone.. or it's slightly different..

    Please I would LOVE some help..
    06-14-2013 03:05 PM
  2. HNNNNNGHHH's Avatar
    Okay,

    I have been searching all morning for an answer to this question. And I can't seem to find a definitive one.

    I "just" got my S2 back from warranty work being done yesterday "June 13th" and everything looked 100% different. I did some looking around and discovered I am now running Jellybean v4.1.2

    However.. when I got up this morning to install all of my apps, and put all the music back on my phone....

    When I plug in my USB cable (Same one I have been using through 3 different Android phones now.. a Hero, Legend, and now an S2) Same one that worked perfectly fine to transfer files to and from my phone 2 weeks ago .. suddenly won't work anymore.

    So I go to Settings > More Settings > USB utilities and when I press "Connect storage to PC" I get a popup window saying " Connect USB cable to use mass storage"


    Am I missing something here? ..

    I found a ton of posts this morning where I " think" there are other people having the same issue.. but it's never the same phone.. or it's slightly different..

    Please I would LOVE some help..
    It may have been updated to the latest firmware available for your phone. Have you tried a factory reset? Drivers from the last OS version may be conflicting with the new firmware.

    Posted via Android Central App
    06-14-2013 11:33 PM
  3. Oddwin's Avatar
    When it came back it had just been factory reset. I had to set the whole phone up again.
    06-14-2013 11:36 PM
  4. HNNNNNGHHH's Avatar
    When it came back it had just been factory reset. I had to set the whole phone up again.
    Try a different cable if that helps. If not, it may be a problem with one of your PC's USB ports. The problem isn't the phone itself obviously: if it was, you wouldn't be able to even charge it.

    Posted via Android Central App
    06-14-2013 11:58 PM
  5. Oddwin's Avatar
    Try a different cable if that helps. If not, it may be a problem with one of your PC's USB ports. The problem isn't the phone itself obviously: if it was, you wouldn't be able to even charge it.

    Posted via Android Central App
    I thought this as well. and I tried 4 different cables.

    Running out of Ideas.
    06-15-2013 01:17 AM
  6. srkmagnus's Avatar
    Go to the Samsung website and download the latest drivers for your GS2 model then reboot both the computer and device. See if that fixes your problem.

    Here is the Samsung website, just enter your model number: Download Center: Download Software, Firmware, Drivers & Manuals | Samsung
    06-15-2013 10:17 AM
  7. Asian Mart's Avatar
    In USB section, select the PDA. If it already selected to PDA then re-select it by selecting MODEM and then PDA again.
    Only change the USB setting and then press back and try reconnect to again.
    01-04-2016 12:02 AM

Similar Threads

  1. Trying to return TB to stock, cannot connect to PC without a reboot loop
    By JK75 in forum Thunderbolt Rooting, ROMs, and Hacks
    Replies: 1
    Last Post: 12-15-2012, 04:32 PM
  2. Cannot connect to PC after moisture damage?
    By dupont2005 in forum AT&T Samsung Infuse
    Replies: 10
    Last Post: 10-16-2012, 10:27 AM
  3. Samsung Galaxy 5 (GT-I5500) won't connect to PC
    By Hugh Johnson in forum Misc. Android Phones
    Replies: 0
    Last Post: 12-20-2011, 07:13 PM
  4. Cannot connect to PC after software update
    By jrmarinojr in forum Verizon HTC Thunderbolt
    Replies: 16
    Last Post: 05-18-2011, 11:24 AM
  5. Cannot connect to PC using USB Y-cable
    By RyanD8 in forum Fascinate Accessories
    Replies: 0
    Last Post: 09-18-2010, 01:45 PM
LINK TO POST COPIED TO CLIPBOARD