1. dannychurchfield's Avatar
    when i turn on my phone the backlight comes on but there is no logo...theres nothing...i cant even get to factory restore it because the keys arent working..its a clone of the samsung note from china..please help someone.
    08-17-2013 01:58 PM
  2. Jennifer Stough's Avatar
    Hey Danny,
    First and foremost, has there been any damage to this device?

    Sent from my HTC6435LVW using Tapatalk 4
    08-17-2013 02:02 PM
  3. dannychurchfield's Avatar
    no. went to turn it on yestersay..the backlight came on but no logo...computer doesnt recognise it and i can factory restore it because the keys dont work when i press them.the backlight just stays on constantly
    08-17-2013 02:25 PM
  4. Jennifer Stough's Avatar
    Unfortunately, many Chinese clones are not of the greatest quality. How long ago did you purchase this device? I'm afraid there isn't any technical advice I can give you to get it up and running if the computer won't recognize it and neither the keys or screen are working.

    Jennifer
    Forums Moderator
    08-17-2013 02:48 PM
  5. dannychurchfield's Avatar
    its only a month old....it was a brilliant phone..thought it wouldnt be...bought if from ahappydeal and when you ask them a question it takes almost 2 days for them to reply...might bring it into my local phone repair and see what they say....when i plug it in the battery charger logo comes on so the screen cant be completely gone....im usually very good with phones but its confusing me to whats gone wrong...
    08-17-2013 03:00 PM
  6. Jennifer Stough's Avatar
    That is a pretty odd situation. Have you ever rooted it or made any software changes lately?

    Jennifer
    Forums Moderator
    08-17-2013 03:39 PM
  7. dannychurchfield's Avatar
    ya i rooted it just to partition my sd card
    08-17-2013 04:01 PM
  8. Jennifer Stough's Avatar
    ya i rooted it just to partition my sd card
    Did this issue start occurring immediately after root?

    Jennifer
    Forums Moderator
    08-17-2013 04:18 PM
  9. Golfdriver97's Avatar
    I will be honest, I don't know what to suggest either. Since it's a clone, I don't know if reflashing Samsung stock ROMs would be a wise thing to do.

    Sent from a SlimROM S3.
    08-17-2013 04:24 PM
  10. Golfdriver97's Avatar
    That is a pretty odd situation. Have you ever rooted it or made any software changes lately?

    Jennifer
    Forums Moderator
    Very inclined to agree.

    Sent from a SlimROM S3.
    08-17-2013 04:24 PM
  11. Golfdriver97's Avatar
    when i turn on my phone the backlight comes on but there is no logo...theres nothing...i cant even get to factory restore it because the keys arent working..its a clone of the samsung note from china..please help someone.
    Can you reboot to recovery? Power off/pull battery, and reboot by holding volume up, home and power. Release when you see logo.

    Sent from a SlimROM S3.
    08-17-2013 04:27 PM
  12. dannychurchfield's Avatar
    do you think if i bring in to a repair shop they could fix it or is it completely gone
    08-17-2013 05:36 PM
  13. dannychurchfield's Avatar
    i tried that all that happens is the backlight comes on and nothing else..no vibration or nothing
    08-17-2013 05:38 PM
  14. Golfdriver97's Avatar
    do you think if i bring in to a repair shop they could fix it or is it completely gone
    You can try. I doubt it.

    Sent from a SlimROM S3.
    08-17-2013 05:41 PM
  15. Jennifer Stough's Avatar
    What I'm curious about, did the device ever work properly after rooting?
    Golfdriver97 likes this.
    08-17-2013 07:27 PM
  16. Golfdriver97's Avatar
    What I'm curious about, did the device ever work properly after rooting?
    My guess is barely. If the ROM was not a true Samsung ROM, the rooting procedure may not have been correct. If that was true, it would be similar trying to root an HTC with Samsung root files.
    Sent from a SlimROM S3.
    08-17-2013 08:26 PM
  17. harip8's Avatar
    some issues with my samsung note 3 ( clone)

    Hiiii,

    I am facing some issues with my samsung note 3 ( clone)
    1)before to reset the device it was showing welcome note as Samsung note 3 with Samsung tone, now it showing mediatek and android.
    2) after reset my what's up is showing error msg that, you have not connected to network (I can download or open websites through same network).
    3) my SD card is 8GB card, but in storage its showing only 1.27GB capacity, I have tried with other SD cards also.
    3) In world time my country or cities are not showing. India is my country.

    Can u suggest any tricks or methods to solve this issue.
    Waiting for or reply.

    Thanks & Regards



    Unfortunately, many Chinese clones are not of the greatest quality. How long ago did you purchase this device? I'm afraid there isn't any technical advice I can give you to get it up and running if the computer won't recognize it and neither the keys or screen are working.

    Jennifer
    Forums Moderator
    05-25-2014 01:42 AM
  18. Ortaa's Avatar
    I have same problem. Did you fix your phone ?
    06-13-2014 11:03 AM

Similar Threads

  1. Replies: 59
    Last Post: 05-29-2016, 09:15 PM
  2. Replies: 13
    Last Post: 03-29-2016, 11:28 AM
  3. [Samsung Galaxy Centura] I need help I am new to this phone.
    By hisbeauty4ashes in forum General Help and How To
    Replies: 12
    Last Post: 09-11-2014, 11:26 PM
  4. Is there any OTA update pushed from AT&T for Samsung Galaxy SII Skyrocket??
    By deadlock4400 in forum Samsung Galaxy S II Skyrocket
    Replies: 1
    Last Post: 08-23-2013, 11:41 AM
  5. [Galaxy Note 8.0] Bootloop
    By gavinn in forum Samsung Galaxy Note 8.0 Tablet
    Replies: 1
    Last Post: 08-19-2013, 02:22 AM
LINK TO POST COPIED TO CLIPBOARD