1. C B W's Avatar
    I have a 3 month old iCraig CLP285 Netbook with Android 4.1 that I really like.
    Suddenly, it will not boot up. Finally got it started and there were major changes: all my email was gone as was data stored in Notebook app. My desktop photo was gone, but when I click on the album that contains the photo I want, it sends me back to the app page. Also, all my photos seem to have uploaded into Dropbox as a Camera Upload, even though I did not do it.
    And, altho WiFi was turned on - it did not show this on the notification area.
    Later that night when I tried to use my PC, the DSL had to be rebooted. Never had to do THAT in 5 years!
    After much reading and about 6 attempts to start the unit, I got in and went to System recovery and did a factory reset. Little Andy had a blue gizmo twirling in his stomach, then it said it was going to reboot. After 15 minutes, screen was still scrolling green through Jelly Bean so I hit reset button on bottom of unit. It went into recovery mode again and now shows Andy on his back with a red triangle and exclamation point.
    This is a Netbook - not a tablet or phone. I do NOT have vol up, vol down buttons.
    Any suggestions?
    Old_Blue likes this.
    11-02-2013 12:40 PM
  2. C B W's Avatar
    It seems to be a system launch issue - I have reset the unit, done a factory reset on the one time it actually started up for me, and a firmware installation which was not acknowledged by the unit. Nothing has worked. In all cases, all I get is Andy Android standing there. Any one know ehat causes this issue and how to correct?
    Oh yes, about 3 weeks into owning the little devil, I started having problems with the Power On button - it would take 10 to 12 tries to power the unit on. The screen stayed black, and all of a sudden,it would start up. Major difference now is that the screen does not stay black. Andy shows up and just stands there. Forever. Not doing anything. Just stands there.
    Old_Blue likes this.
    11-04-2013 02:24 PM
  3. juan0069's Avatar
    My unit did the same thing - visit the Craig website:

    Craig Electronics Inc.

    Download the new firmware and follow instructions for upgrade... worked for me! Good Luck!
    Castle2k likes this.
    11-26-2013 11:41 PM
  4. gcArchitect's Avatar
    Having a similar problem. I followed the link given but there's no info in that page. Where did you find the firmware?
    Thank you.
    12-28-2013 04:58 PM
  5. Cecil Re's Avatar
    I have the same problem...jellybean logo just stays on screen...nothing happens
    01-19-2014 01:00 PM
  6. Leah Stanfield's Avatar
    I am experiencing the same problem. Jellybean Android just stands there. I can't get it to do anything. I have reset, rebooted, restarted and nothing. Just got it.
    02-27-2014 03:12 PM
  7. Sam tAYLOR3's Avatar
    This is a Software to hardware conflict, as none of these stall problems would happen to Android Ice cream sandwich, the platform expects a touch screen, as much of jelly bean is prioritized to a touch screen. If you could downgrade Most of these would be solved.-(
    03-05-2014 05:31 PM
  8. flashwebs's Avatar
    The solution to this problem is to reload the system software which you can get from the Craig Electronics website (Google it) and then select E-Digital from the menu at the right. Click on your product (CLP285) and you will see the software download and instructions for installing.

    You will need an SD card to copy the software to. Power off the netbook, insert the SD with the new firmware and it will reload the operating system. When it is done, it will ask you to remove the SD card to complete the process. I have done this before, and it solved my problem. Of course, any data you had in the netbook will be gone.

    I have about 6 of these neat iCraig netbooks and they are extremely portable great little machines for browsing, email, and playing games. I have also installed web servers, media servers, and other useful programs on them. Some of the games expect a touch screen and don't work, but there are plenty that do.

    Don't trash it, Fix it!
    C B W likes this.
    05-25-2014 11:54 AM
  9. Jason Gomez5's Avatar
    Im about to buy this netbook,if was to go on the browser how would i scroll up and down through a web page?
    06-06-2014 05:12 AM
  10. jhr547498's Avatar
    hello, I am trying to repair this issue on the same tablet. When I download the file for the firmware fix and try to extract it to the card it has an error saying it breaks the operation? I have tried unraring it with the two folders and the single folder same result both times and I have tried multiple downloads. Any ideas?
    08-08-2014 11:10 AM
  11. Castle2k's Avatar
    it works! many thanks!!!
    11-14-2014 09:52 PM
  12. Kathy Hall2's Avatar
    I just got my 9 inch high def slimbook ( CRAIG ) in the mail last week at first it turned on great now it wont turn on at all. What can I do?
    10-25-2015 06:47 PM
  13. Laurie Born's Avatar
    I have an icraig 9 inch touch screen tablet Model: CMP 773 GD it has stopped loading completely. The Blue icraig screen comes up and then it goes to the loading screen and it continues to load but it never loads. It will continue to load until the batteries run out, and never completes the function. I would like to know how to reset my machine, I have tried the reset button on the back but it doesn't do anything.
    01-22-2016 02:42 PM
  14. migold's Avatar
    Does anyone have a copy of the upgrade software for the CLP285? I looked on the Craig website and did not find it there. It looks like they are only showing software for the newer models.
    03-17-2016 10:55 PM
  15. migold's Avatar
    Does anyone have a copy of the upgrade software for the CLP285? I looked on the Craig website and did not find it there. It looks like they are only showing software for the newer models.
    03-17-2016 11:09 PM

Similar Threads

  1. Need Keyboard With Case
    By Metal Chaos in forum Samsung Galaxy Note 8.0
    Replies: 3
    Last Post: 11-04-2013, 09:25 PM
  2. does nexus 4 charge faster with the wire less charger?
    By Sento in forum General News & Discussion
    Replies: 1
    Last Post: 11-02-2013, 01:16 PM
  3. Need help troubleshooting a screen problem
    By ScottAbbate in forum AT&T Galaxy S III
    Replies: 0
    Last Post: 11-02-2013, 10:19 AM
  4. Problem loading music files, any ideas?
    By Denisew 1972 in forum Sprint Galaxy S III
    Replies: 0
    Last Post: 11-02-2013, 08:41 AM
  5. Problem with helium backup
    By DanielAnton in forum Google Nexus 5
    Replies: 0
    Last Post: 11-02-2013, 03:54 AM