1. StickyLabel7's Avatar
    I got my shiny new Nexus 7 three days ago and connected it to my gmail account. Then I tried searching the play store and it doesn't seem to be working properly - apps like iPlayer and Evernote are 'not compatible with my device' and when I search for other apps I don't get the proper, basic ones like camera, only independently made ones that are less popular. When I try to download these I get an error message - Error while retrieving information from server (RPC:S-7 EOS:AEC-O). So I tried looking for solutions on the internet - sync it, remove Google account and put it back on, I've even tried setting up an entirely new email, but nothing has worked. I've noticed my device has a permanent sync error but nothing has remedied that. This is all terribly annoying as a device is pretty useless without apps, although I managed to download Facebook right when I got the tablet. The internet works fine, and my Wi-Fi is strong. I don't have a credit card so haven't attached one to the play store - it's the free apps that are giving me grief. Sorry about the long post - I'm a total noob to anything beyond a crappy Samsung slide-up so maybe I'm doing something wrong. Any ideas?
    04-13-2014 08:53 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! Did you buy your N7 from a retail store or directly from Google, or from a reseller or eBay? If you bought it from Google or an actual retail store, you always have the option of returning or exchanging it. Also, are you in the US or another country?

    If you haven't already done so, try wiping the cache partition, which won't erase any personal data: http://forums.androidcentral.com/goo...tion-wipe.html
    04-13-2014 01:07 PM
  3. StickyLabel7's Avatar
    I'm in the UK. Unfortunately I won it so there's no reciept with which to return it. I've tried wiping the cache - so I guess it must be inherently faulty which is a bit annoying.
    04-14-2014 05:13 AM
  4. B. Diddy's Avatar
    Try going to Settings/Apps/All, selecting Google Play Services, then Manage Data, and then Clear Data. You'll probably have to sign back in.

    Posted via Android Central App--please excuse the brevity and any typos!
    04-14-2014 11:34 AM

Similar Threads

  1. Any Possible Functioning CWM recoveries for S5?
    By ballzrdeep in forum Samsung Galaxy S5 Rooting, ROMs & Hacks
    Replies: 9
    Last Post: 05-17-2014, 01:56 PM
  2. app for notes
    By scotswahae in forum Moto G (2013)
    Replies: 7
    Last Post: 04-17-2014, 02:54 AM
  3. Download Booster IS on the Verizon S5!
    By rnd0209 in forum Samsung Galaxy S5
    Replies: 9
    Last Post: 04-13-2014, 09:38 PM
  4. TV App not working
    By ZekkRagnos in forum HTC One M8
    Replies: 5
    Last Post: 04-13-2014, 04:14 PM
  5. Replies: 1
    Last Post: 04-13-2014, 10:18 AM