1. chitchat911's Avatar
    I have a samsung galaxy s advance bought in Aug 2012

    All of a sudden my phone has started to behave weirdly.
    I had kept my phone for charging overnight but the next day morning it showed that there was no charge.I tried plugging it again and again in different electrical sockets but it was not charging. I connect it to my computer through usb thinking that the power adapter could be the issue but there too it was not charging. I switched off and switched on and phone and connected to power supply through adapter and it started to charge and it showed 100% charge within half an hour. In the evening, by around 5:00 it started to beep that there was no charge. I switched it off and took it home. Again it was not charging, I replaced the battery and it showed as charging. But one thing I noticed was that sometimes when it was charging, the screen showed kind of electrical disturbance -kind of lines wavering. This happens while charging after some time.Now I tried to switch it off but it was only restarting!!! I thought that this was because, I had installed a clean master app and this could have terminated some important apps/process. So I uninstalled it, but still it had the issue of restarting when I tried to switch it off. Finally I did a hard reset and restored factory settings, lost all recent data . I charged it and it looked as though it was fine. But the next day morning, without me using it, it started to beep that the battery was low.Again I charge it and within 1 hr the battery showed as charged. After removing the charged phone from the charger, it showed as 100% charge for 6 hrs and then suddenly it started to beep that there was no charge. Even now also when I charge the phone, the screen is Still showing the wavering lines sometimes and still it restarts when i try to switch it off.I did not put the phone in water or anything like that. When I open kies on my desktop to connect to the device, it is not recognizing that I have connected my device.
    05-12-2014 01:31 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! Can you clarify--did you in fact try a new battery, or did you just remove your old battery and put it back in again? This behavior might be explained by a failing battery, so I would suggest trying a new one. You can also do a quick test with your current battery--turn off your phone, take the battery out, lay the battery flat on a table, and try to spin it. If it spins freely, the battery is bulging in the middle, which means it has gone bad.
    05-12-2014 01:56 AM
  3. chitchat911's Avatar
    I did try with a new battery. With the new battery too, when I try to switch off, it was restarting. When I tried to connect to the PC using USB, I got an error that " windows was not able to recognize the usb device". After sometime, it still shows the electrical disturbance/lines on the screen. When I diconnect the phone from the adapter, the lines go away. The last thing i did on the phone, prior to facing these issues was that I put it in my pant pocket and was walking very fast. I wonder if the phone being tossed around in the pant could have loosened some connection/damaged the video adapter/charging circuit..I know it sounds very silly.
    05-12-2014 03:44 AM
  4. B. Diddy's Avatar
    I don't have much else to add at this point. It sounds like some hardware malfunction. All I can suggest at this point is to bring it in to a cellphone repair shop, or contact Samsung support. Might be time for a new phone!
    05-12-2014 02:47 PM
  5. chitchat911's Avatar
    I shudder to think that "it's time for a new phone" as I spent a lot on this. Just in case, whats your take on micromax canvas elanza2
    05-13-2014 12:14 AM
  6. B. Diddy's Avatar
    The phone is almost 2 years old, so it wouldn't be entirely surprising if things started to go wrong. I'm afraid I don't have any experience with MIcromax, sorry!
    05-13-2014 03:11 AM

Similar Threads

  1. GS5 back light on buttons
    By TheGregSkinner in forum General News & Discussion
    Replies: 2
    Last Post: 05-12-2014, 11:18 PM
  2. Problem with home, back, multitask buttons
    By Matt Garrity in forum HTC One M8
    Replies: 3
    Last Post: 05-12-2014, 06:00 PM
  3. Nexus 7 locked in a strange diagnostic screen sequence
    By slow2start in forum Google Nexus 7 Tablet (2012)
    Replies: 1
    Last Post: 05-12-2014, 12:40 PM
  4. Newly rooted on tmobile unlock. Questions
    By 4ringsa6 in forum Sprint LG G2
    Replies: 3
    Last Post: 05-12-2014, 10:40 AM
  5. Why does the details from file explorer and settings>storage doesn't match?
    By mj2293 in forum Android 4.1 / 4.2 / 4.3 Jelly Bean
    Replies: 1
    Last Post: 05-12-2014, 02:00 AM