1. writermanuk's Avatar
    I am a writer and I have recently taken to keeping my current works in progress in cloud storage so that if I get good ideas when I'm out and about I can edit my book on my phone and have the latest version available on my computer next time I'm back home.

    The phone is a Samsung Galaxy S3 and I'm using Kingsoft Office to edit the books. To make editing easier, I recently bought a bluetooth keyboard to use with the phone and that's when I started to hit the problem. The keyboard is a cheap one that I think originates from China. I can't see any branding on it but the model number on the back is SJP-001. It works very well, other than the problem outlined below.

    The problem occurs if I try to write dialogue using the bluetooth keyboard and that dialogue starts with a vowel. When I type the opening double quote to start the dialogue, a double quote appears on the screen but if I then follow that immediately with, say, an E, as soon as I type E on the keyboard the double quote vanishes and I get E with an umlaut (two little dots) above it. Single quote followed by E gives me E with an acute accent.

    Now I can understand that this might be a useful "feature" if I were trying to write in German or French but it's absolutely infuriating when trying to write a novel in English. What is it that's doing this? Is it the keyboard, Kingsoft or Android? I don't get this problem using the Android on-screen keyboard. There is a work around (type opening quote then space, backspace then start the dialogue) but it's a real drag. Any suggestions how I might be able to turn this feature off?
    09-11-2014 01:21 PM
  2. SpookDroid's Avatar
    This is probably the keyboard you're using on your phone. I know, it's a bit hard to grasp, but the keyboard you choose to use in your phone is the one doing the work for you when using an external one. Now, in Samsung devices, sometimes this defaults to Samsung's own keyboard when you connect a Bluetooth one (my Note 3 annoyingly does this) but you might still be under the one you're currently using (my Tab S will stick to SwiftKey even with BT Keyboard connected).

    Depending on the keyboard you're using on your phone, is where you might find some settings for the external keyboard. I'm guessing it's got something to do with either Language settings or Keyboard Layout.

    Have you tried doing the same in another app? Maybe a simple note or trying to compose an e-mail. Does it do the same? If it doesn't, then it's gotta be a setting in Kingsoft's Office. If it does it, it's a setting on your keyboard.
    09-11-2014 01:38 PM
  3. writermanuk's Avatar
    It happens in other apps too. For example, when composing an email. Sorry, I should have thought to try that before posting.
    I had a look at the keyboard settings but couldn;t find anything there to turn this feature off.
    I also had a trawl around the web and found some stuff about "Key Character Map Files". These are apparently supposed to live under /system/usr/keychars but I can't even find a /system top level folder on my phone.
    This whole auto-accent idea strikes me as something someone's thought "Oh, that's a good idea" but they've not really thought it through as to the consequences. Surely this bit of over-cleverness will annoy more people than it helps.
    09-11-2014 02:29 PM
  4. SpookDroid's Avatar
    Which keyboard are you using? I might look into that for settings if I can or if I've already used it. Also, when you connect your keyboard and start typing, does a Keyboard Layout option pop up on your notification bar?

    Or maybe if you go into Bluetooth options and tap on the settings for your physical keyboard, does it give you any other options? Mine doesn't, but this one might.
    09-11-2014 02:44 PM
  5. MorganThaler's Avatar
    The solution to your problem is simple: If you want the quote and not the accented character, press the space bar. It will not give you a space, but it will cancel the character conversion. The US International keyboard in Windows works the same way.
    09-11-2014 06:13 PM
  6. writermanuk's Avatar
    Keyboard was a cheapie off Amazon UK. Tried to post you a link but this forum won't let me. It arrived in an anonymous white box with no branding on the device, the packaging or the (minimal/useless) instruction sheet. Only ID was SJP-001 on underside of keyboard.

    Didn't notice anything on the notification bar and didn't think to check bluetooth settings. Will try both when I get home (currently out walking the dog).
    09-12-2014 09:02 AM
  7. writermanuk's Avatar
    Thanks for the tip. I'd still like to find a way to disable this feature, if there is one. The whole purpose of an external keyboard was to get my ideas down quickly (touch typing) when the muse strikes. Having to remember to hit space after every quote that's followed by a vowel may not sound like an imposition but, believe me, it will slow me down considerably. My style as a novelist is to tell as much of my story as possible through dialogue, so qotes are _very_ frequent.
    09-12-2014 09:08 AM
  8. SpookDroid's Avatar
    Keyboard was a cheapie off Amazon UK. Tried to post you a link but this forum won't let me. It arrived in an anonymous white box with no branding on the device, the packaging or the (minimal/useless) instruction sheet. Only ID was SJP-001 on underside of keyboard.

    Didn't notice anything on the notification bar and didn't think to check bluetooth settings. Will try both when I get home (currently out walking the dog).
    I meant the software keyboard. When typing without the external keyboard, which one do you use? The stock one or any 3rd party one? Also, when you connect your external keyboard and start typing, is there an option to switch keyboards on the notification bar? If so, can you post a picture or list the options that appear when you select that?

    And another thing to try (I just remembered this can happen). There's a keyboard shortcut that changes your keyboard language/layout but I can't remember if it's pressing together the ALT key and the TAB key, or if it's ALT+Space Bar. Can't hurt to try either. If it 'works', you should see the new language displayed briefly on the screen.
    09-12-2014 10:20 AM
  9. anon1mat0's Avatar
    I had the opposite problem, that is I wanted to make special characters and didn't knew how. In Settings under languages I found that the physical keyboard has it's own properties and you can change the layout there, in your case it may be in a different language than English, in mine, it was English when I wanted to do Spanish accents/characters. Playing with those options should help you fix the issue.
    04-21-2015 06:43 PM

Similar Threads

  1. Replies: 10
    Last Post: 09-14-2014, 11:21 AM
  2. rca pro 10 using external usb drive
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 09-12-2014, 01:05 AM
  3. Replies: 3
    Last Post: 09-11-2014, 09:24 PM
  4. htc one m8: texts volume whule using earphones
    By Unregistered in forum Ask a Question
    Replies: 0
    Last Post: 09-11-2014, 11:03 AM
  5. the ability for applications to write to external SD cards...
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 09-11-2014, 04:57 AM
LINK TO POST COPIED TO CLIPBOARD