1. mporosh's Avatar
    I was trying to install a custom rom in my Walton Primo X2 ( rebranded version of Gionee E6 ). I tried the below steps and my phone got stuck like shown in the image. Please help me to recover this.
    1.Turned off my phone.
    2.Booted into Recovery mode – holding down the volume up button and then pressing the power button does it.
    3.Used volume keys to navigate the menus, and power button to select the menu items.
    4.Then Choose “Format data”.


    And my phone got stuck: I waited for about a day; lastly my phone turned off due to battery level. Now I can only turn my phone off long pressing power off. I tried Volume button + power on = again in same result.

    Please help me to get my phone works
    10-29-2014 09:48 AM

Similar Threads

  1. Where Can I Get A Metal Home Button To Go Over My Phone's Home Button?
    By Dankees in forum Samsung Galaxy Note 4 Accessories
    Replies: 4
    Last Post: 11-04-2014, 10:50 PM
  2. Replies: 4
    Last Post: 11-04-2014, 07:58 PM
  3. Can anyone help me fix my menagerie of problems?
    By Kaitster13 in forum Samsung Galaxy S5
    Replies: 3
    Last Post: 10-30-2014, 03:28 PM
  4. Replies: 2
    Last Post: 10-29-2014, 03:02 PM
  5. Replies: 3
    Last Post: 10-29-2014, 01:53 PM
LINK TO POST COPIED TO CLIPBOARD