1. Impa Lei's Avatar
    Hello my tablet was running ok, but suddenly it turned off and when I tried turning it on, it only shows me the prestigio logo and never does anything else... I tried recovery but it doesn't work, pressing and power+ (or -, I tried both) still leave me with the prestigio logo screen... It just won't go into recovery... can anyone please help?
    01-16-2015 07:56 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! When you say you tried Recovery, did you successfully get to the Recovery Menu, or did it not seem to work? Make sure you followed the steps shown here exactly:



    There's no sound, but the steps look to be:

    1. From a powered off state, press and hold Power and Vol Up. You may have to hold these down for about 10 seconds.
    2. Once the screen turns on and you see the logo, release Power but keep Vol Up pressed. Wait another 5-10 seconds.
    3. When you see the Recovery Menu, use the Volume buttons to scroll to Wipe Cache Partition, then press Power to select.
    4. After the cache wipe is done, highlight Reboot System Now and press Power.

    If that doesn't work, try the Wipe Data/Factory Reset option from Recovery.
    01-16-2015 10:39 AM
  3. BobCymru's Avatar
    I'm having the same trouble. No way to get into recovery.
    05-06-2015 07:58 AM
  4. Gogo Elbaz's Avatar
    My Prestigio multipad stuck at formatting cache mode

    its start from 12 hr and dosen't change

    now i switch off my pad and restart it but still in formatting cache mode

    what can i do ?
    04-17-2016 03:45 AM
  5. scooby33's Avatar
    I have the same problem.. CANNOT by any means get into recovery! tried all ways many times EXACTLY AS SHOWN...It will not let me boot new image from sd card as its stuck and cannot a SINGLE THING! I got programs which hook up to android tablets to flash it BUT the computer will not recognise the device, its calls it unrecognisable sometimes & an M3 chip other times, no drivers work either way! it says its a rock USB driver that it needs.. got that but still doesn't pick it up! this issue is not a simple one & holding the power button & volume+ or - just turns on the device into the loading picture or just turns it off.. Tablets all seem to able to have the onboard software in an easily corruptible state.. its either the tablet has run out of memory & the device has kept updating til it crashes & freezes or its one of the many malware internet takeover type virus's.. As a word on caution trying to download the ROCK USB drivers has left me with serious virus's! makes you wonder how these people get their business doesn't it! 1) they cause the problem with free virus/malware laden software. 2) we have to pay to fix it! this is a common theme at the moment..
    06-02-2016 11:04 AM
  6. Romila Robert's Avatar
    This method is not working. Not entering in recovery mode. If it stuck, how to enter in recovery mode? No way. Maybe a short circuit or something. Tried with no battery for 2 days. Nothing. Seems this is common problem at heese tablets.
    09-22-2016 12:55 PM

Similar Threads

  1. Replies: 12
    Last Post: 10-24-2015, 07:24 PM
  2. Replies: 3
    Last Post: 10-22-2015, 01:24 PM
  3. No theme setting on VZW G3?
    By Tex_Norseman in forum LG G3
    Replies: 2
    Last Post: 01-16-2015, 10:02 AM
  4. How do I turn off multiple notifications on my HTC ONE M8?
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 01-16-2015, 07:25 AM
  5. TWRP swipe to unlock but my screen is stuck ? help me please
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 01-16-2015, 06:56 AM
LINK TO POST COPIED TO CLIPBOARD