1. iamtotus's Avatar
    Got my Nexus 5 yesterday and found that the listen to command does not work (or any variation, "play song", "play song by artist" etc). When I say the command it just looks for the song on the play store, but does not pop up with the Play Music app, even though the song is in both my online and local libraries.

    If I go into Google Now -> Settings -> Phone search, I can see that "Apps", "Contacts", and "Play Movies & TV" are checked, but there is no option for Play Music. Going through the Play Music app, I saw no setting to enable it for search.

    I have also tried restoring Google Now to its original state by clearing the app data for the Google Search app, which had the fun extra effect of wiping out all of my homescreens.

    Any advice would be greatly appreciated.
    11-06-2013 01:55 PM
  2. methods's Avatar
    say " Ok Google" then say "Help Me" it will give you a list of all the voice commands, including Playing Music and movies.

    Hope that helps
    11-06-2013 02:44 PM
  3. iamtotus's Avatar
    say " Ok Google" then say "Help Me" it will give you a list of all the voice commands, including Playing Music and movies.

    Hope that helps
    The commands it lists are:
    "Watch <thing>"
    "Play me songs from <thing> "
    "I want to listen to <thing>"
    "Play some <artist>"

    No success.

    I should probably clarify... All of these commands "work". They list the song in the Play Store (as if I do not already own it) and ask if I want to purchase it. I think the main issue is that the Play Music app is not being searched by Google Now. As a result, none of the songs in my library are being searched.
    11-06-2013 03:29 PM
  4. iamtotus's Avatar
    Got it! When you say a command to play music, just underneath the song, album, or artist artwork is an icon for the Play Store. I had not noticed there was a small triangle indicating this is a drop-down menu. I was able to tap the icon, choose the "Play Music" option (Pandora was also listed), and now that is my default player and voice commands work!

    Hope this helps anyone else having issues with the music commands.
    11-06-2013 03:35 PM
  5. keverh's Avatar
    Are you in the US or else where, I am also having the same issue but cannot find a way to enable it from the instructions listed. Am I losing out cause of cross border issues?
    11-08-2013 09:21 PM
  6. leemarkin's Avatar
    same here, googel now can no longer search music, docs, ...translate,...books.....or any other third party apps,..........
    11-14-2013 12:40 AM
  7. rgummadi's Avatar
    unable to play music from my device by using voice command. can some one help how to make this change?
    01-23-2014 08:21 AM
  8. fcastillo#AC's Avatar
    unable to play music from my device by using voice command. can some one help how to make this change?
    The problem is being outside of the US. For some reasone, google commands don't work outside of the US. I used a free US vpn to test it out and after connected to the VPN, I had no problem and all my voice commands to play music worked without any problems...
    I wonder if there's a way to fix this, perhaps using a Xposed Framework module

    EDIT: I'm managed to fix this. Now voice commands work to play music even outside of the US. You will need Xposed Framework with the Google Now API module). One of the plugins for the module is Music Controls) which will let you play any song from your favorite music app. The commands are a little bit more rigid: "play songs by <artist>", "play song <title>", any other voice command won't work. Nonetheless, this is a great progress!
    02-04-2014 01:52 PM
  9. clh42's Avatar
    The problem isn't only outside the U.S., and isn't only with 4.4. Or I guess there might be a different issue that keeps it working from outside the U.S. But there's definitely issues inside the U.S. as well. Unless it's tied to my specific phone model in the US, the Samsung Galaxy S3 (which is possible I supposed because I know Samsung does weird things over standard Android on their phones and I suppose something Samsung has done could be interfering with the Google Now music play functionality). I've had my S3 for a little over a year now and this has been a problem since the original 4.1 software that came on it up through the 4.3 software I got about a month ago. I desperately want to make my S3 use Google Now instead of S-Voice for varous reasons, and I know how and have done that, but Google Now is just useless when it comes to playing music by voice in the car. S-Voice may be crap for a number of other reasons, but IF it actually understands what I say, S-Voice never fails to correctly play the music.

    It's not that Google Now music voice commands never work, but they only seem to work about 1/3 of the time. Artists seem to be the most reliable, but even then it's only about half the time. Some artists it will understand and play just fine, other artists it will only display standard Google Search results with no option at the bottom to select your music player. Album is about the same as artist, works about half the time. Trying to play a specific song almost never works and displays the standard Google Search results probably 90% of the time. Playlist seems to work most of the time but I only have 3 playlists.

    I've seen a lot of other threads on various forums reporting the same issue from various Android versions and other, non-Samsung, phones too.
    02-08-2014 11:43 AM