11-04-2016 09:31 PM
30 12
  1. Ambient13's Avatar
    Hi guys,

    So, I know this issue is really common... but after lots of searching I haven't found a satisfactory solution, only a couple of wonky workarounds.

    My Nexus 4 is running 4.4.2 - everything is stock, and unrooted. Perhaps this WiFi bug comes as no surprise since Google likes to take its time fixing it. Anyways, a few certain SSIDs, including a really common public one here called Shaw Go WiFi, are stuck looping "Obtaining IP Address" when I try to connect. Apparently the problem is to do with a DHCP request conflict btwn the router and the client.

    With public WiFi, all you can do is deal with it through the client side (or in other words, you have no control over the router). That said, when other devices work on the same network, you know it can't just be the router - my understanding is that it has to do with the kernel/drivers as well. Plus, this did not use to ever happen on my N4 before, which definitely means it isn't 100% on the router side. Perhaps it is to do with my installation of Snapdragon Battery Guru, which I promptly uninstalled to fix the problem but to no avail.

    I also tried factory resetting, twice. The second time I did a true hard reset from scratch by not signing in with my Google account or syncing apps/app data. Evidently neither reset resolved the problem.

    I have only noticed two prominent workarounds in my research:

    1. Deleting a system folder containing files pertaining to the DHCP and fiddling with a couple permissions. This can only be done with root access, which I don't have and want to avoid for now unless I truly need to use it.
    2. Use a static IP. Except this is not a real solution at all since it only works for each SSID you come across that doesn't play nice, and it doesn't work anyways if you do not know the Static IP, Gateway address and Subnet mask, etc in the case of a public access point.

    In terms of a REAL solution, I initially had hopes that 4.4.3 will be the one to fix this .. and who knows it might. But when I looked deep into past threads throughout the web, I was flabbergasted to find out that this problem has been pervasive since at least the days of Gingerbread, well before I converted to Android along with many others. If after all this time the problem is still there, how can we be sure that Google will resolve it in the next dot release?

    Long story short, I am wondering if there is an alternative that is remotely ideal, or at least better than the two mentioned above. If anyone can chime in with a hint that would be great.
    05-10-2014 03:00 AM
  2. Ambient13's Avatar
    Since originally posting, I have tried: unlocking the bootloader, rooting my device, and deleting old DHCP leases. Then I unrooted, flashed a fresh factory image of stock 4.4.2 and re-locked OEM bootloader.

    Nothing has worked so far.
    05-14-2014 09:22 PM
  3. purplepundit's Avatar
    Today I receved my Android 4.4.2 KITKAT tablet and breaking my head to connect to wi-fi which it shows 'obtaining IP Address...' in a loop. If you found any solution, please update me friend! Thanks
    06-28-2014 01:43 PM
  4. ColbyJvonBrown's Avatar
    My moto g does this sometimes, so I just forget the network, turn WiFi off, put my phone into airplane mode, then turn it off for 2 min. and clear cache and boot it up take airplane mode off and turn WiFi on and then it connects to the network. And sometimes its just the network you try is messed up, mine will connect and show reddish bars but then I can't use the web or play store and anything to do with the internet!! I hope this helps!!!

    Posted via Android Central App
    06-28-2014 09:14 PM
  5. purplepundit's Avatar
    Sorry Colby. It didn't work with my tab. Though I tried another option by resetting the wi-fi security settings of my modem to NO-SECURITY. It works, but I can't keep the network open without any security. Does this gives any hint on the problem? Any option to change the wi-fi security settings?

    Thank you for your support!

    My moto g does this sometimes, so I just forget the network, turn WiFi off, put my phone into airplane mode, then turn it off for 2 min. and clear cache and boot it up take airplane mode off and turn WiFi on and then it connects to the network. And sometimes its just the network you try is messed up, mine will connect and show reddish bars but then I can't use the web or play store and anything to do with the internet!! I hope this helps!!!

    Posted via Android Central App
    07-08-2014 02:37 PM
    Hi all. I've had my Note 3 since January and never had any issues with the wifi. On Monday I noticed it was not picking up my router. It showed but like everyone has said, it keeps "looping" obtaining IP address. If anyone finds a fix please keep me in the "loop"!
    07-09-2014 08:27 PM
  7. Olger Ferhati's Avatar
    Press these menu options on your phone: Settings > Wi-fi> (Choose your network by tapping on it for a few seconds) > Modify network config

    Check "Show advanced options"

    Choose IP Settings: "Static"

    Enter these details
    IP - or (I chose

    Gateway - (I chose since that's my router address)

    NPL - 24

    Netmask - (I could not find this option)

    DNS 1 - or (I had the latter by default and let it stay)

    DNS 2 -

    And save.

    It just connected in a few milliseconds.
    08-15-2014 10:10 AM
  8. JynB's Avatar
    this worked for me just now!!! I had to fill out every single other field that you didn't mention with just gibberish until the 'Save' button would appear and i clicked it. Now it says I am connected, like *POOF* no problem! Now i just gotta do this at home thank you so much
    08-21-2014 03:10 PM
  9. Android Optimizer's Avatar
    I don't know if this will do any good, but you guys can give it a shot:

    Android Revolution HD | Mobile Device Technologies: How To: Fix Wi-Fi connecting issues on the HTC One running Android 4.4.2

    Obviously you can rename it to something other than what is given in the instructions. You may want to stay away from numbers since that may in someway be an issue. Those of you with Notes could call it something like Note Three, Note Four, or something along those lines.
    08-27-2014 11:08 PM
  10. zuki888fc's Avatar
    This worked like a charm. Bless!!!
    10-06-2014 02:27 AM
  11. Jodi Avecilla's Avatar
    Thanks for the tip! I tried it, and it worked perfectly for the home wifi. Has been making me nuts for over a month now!
    10-12-2014 06:18 AM
  12. Naman Agarwal1's Avatar
    Thanx alot, just changed my ip to 253 and everything worked fine , can you explaion what was the issue. i would love to hear it.
    10-12-2014 01:56 PM
  13. Appslova_com's Avatar
    Try this method:
    1. Go to Settings and tap on Wi-Fi.
    2. Turn on the Wi-Fi and connect to a network.
    3. Long press on the connected network and select Modify Network.
    4. Check Show Advance Options.
    5. On IP Settings drop down menu, select Static.
    6. Assign IP of your choice but leave other variable untouched.
    mohammad55555 likes this.
    10-31-2014 04:35 AM
  14. Krizelle Joy Cayme's Avatar
    Thank you it works
    11-24-2014 07:57 PM
  15. Vijay Beetun's Avatar

    Got all the way thru with the steps but the save button is not working. It appears dull colored and doesn't press. What can the problem be?
    11-28-2014 06:44 AM
  16. pratik pimplapure's Avatar
    re write IP address on dual IPaddress bar then press on save option
    12-18-2014 10:19 PM
  17. rkg1389's Avatar
    Thank you very much for giving me wi fi solution. it did work fist class.
    12-22-2014 05:05 AM
  18. Piyush Shingala's Avatar
    Thanks, It Worked............
    01-18-2015 04:23 AM
  19. giunteriz's Avatar
    Hi i have done everything you wrote step by step, changed connection type to static, and so on. But after i restart the phone (Galaxy S4 I9505) it is asking me again to login to my wifi, not autoconnecting at all. When i login i go in wifi settings and found that my IP settings after restart again changed to DHCP.
    Nothing changed. Can you help me, what is the problem and ho to fix it?
    02-05-2015 02:30 PM
  20. Drishan Poovaya's Avatar
    Thanks, man. Works like a charm on my oneplus one
    02-28-2015 10:58 PM
  21. ieldan's Avatar
    No quarantees that this helps, but this worked for me and since it is easy and permanent solution You may want to give this a try first.
    Go to your router setup and on the configuration for the Wireless Radio chance the channel number.

    Best of luck, hope this helps at least some of You.

    03-22-2015 10:16 AM
  22. cdiddy2000's Avatar
    That IP Work around for the "Obtaining IP LOOP" worked for my Samsung Notebook 2.
    As soon as I hit SAVE, it connected!

    Nothing else had previously worked apart from shutting off my home router, and restarting it. Thanks for the solution!

    04-19-2015 03:27 AM
  23. simplereader's Avatar
    i have done all above. it is connected. but i am not able to open any website. no data is being transferred. whereas, the same router connection if working for other mobile devices????
    04-19-2015 07:09 AM
  24. Sifti Alap's Avatar
    Thank U so much.... it worked like wonders....
    07-30-2015 02:49 AM
  25. Paris Bueller's Avatar
    Thank you and high five, that worked great!
    10-14-2015 03:59 PM
30 12

Similar Threads

  1. Samsung Galaxy S4 SCH-I545 will not update to KitKat
    By JEXXICA_19 in forum Samsung Galaxy S4
    Replies: 9
    Last Post: 11-03-2014, 12:10 AM
  2. Google Play HTC One (M8) missed calls led notification not turning on
    By worldsoutro in forum Google Play edition HTC One M8
    Replies: 3
    Last Post: 05-12-2014, 03:51 PM
  3. No alarm app on watch
    By 1812dave in forum Samsung Gear 2 & Gear 2 Neo
    Replies: 2
    Last Post: 05-11-2014, 10:27 AM
  4. hbo go not working on nexus 7, but work on 5
    By bigworld005 in forum Google Nexus 7 Tablet (2013)
    Replies: 2
    Last Post: 05-10-2014, 01:19 PM
  5. Has anyone loaded KitKat onto a NEC Terrain?
    By bs03 in forum Misc. Android Phones
    Replies: 0
    Last Post: 05-09-2014, 11:51 PM